Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1606076 - rapidsvn: FTBFS in Fedora rawhide
Summary: rapidsvn: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rapidsvn
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1424240 1556310 (view as bug list)
Depends On:
Blocks: F26FTBFS F28FTBFS F29FTBFS
TreeView+ depends on / blocked
 
Reported: 2018-07-20 18:19 UTC by Mohan Boddu
Modified: 2018-12-04 21:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-04 21:49:04 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2018-07-20 18:19 UTC, Mohan Boddu
no flags Details
root.log (deleted)
2018-07-20 18:19 UTC, Mohan Boddu
no flags Details
state.log (deleted)
2018-07-20 18:19 UTC, Mohan Boddu
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github https://github.com/RapidSVN RapidSVN issues 35 0 None None None 2018-08-06 20:46:04 UTC

Description Mohan Boddu 2018-07-20 18:19:14 UTC
rapidsvn failed to build from source in Fedora rawhide

https://koji.fedoraproject.org/koji/taskinfo?taskID=28227635


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
Please fix rapidsvn at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
rapidsvn will be orphaned. Before branching of Fedora 30,
rapidsvn will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Mohan Boddu 2018-07-20 18:19:22 UTC
Created attachment 1467273 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Mohan Boddu 2018-07-20 18:19:27 UTC
Created attachment 1467274 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Mohan Boddu 2018-07-20 18:19:30 UTC
Created attachment 1467275 [details]
state.log

Comment 4 Tim Jackson 2018-08-06 20:27:18 UTC
duplicate of #1424240

Comment 5 Tim Jackson 2018-08-06 20:45:33 UTC
I've tried building from the latest upstream git on F28; it fails, apparently less severely though still fails due to a bunch of type conversion errors. See https://github.com/RapidSVN/RapidSVN/issues/35

Comment 6 Tim Jackson 2018-08-06 20:50:41 UTC
Posted to upstream mailing list:
http://rapidsvn.tigris.org/ds/viewMessage.do?dsForumId=671&dsMessageId=3623661

Comment 7 Tim Jackson 2018-08-06 20:51:37 UTC
*** Bug 1424240 has been marked as a duplicate of this bug. ***

Comment 8 Jan Kurik 2018-08-14 11:03:28 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 9 Scott Talbert 2018-11-06 01:28:01 UTC
(In reply to Tim Jackson from comment #5)
> I've tried building from the latest upstream git on F28; it fails,
> apparently less severely though still fails due to a bunch of type
> conversion errors. See https://github.com/RapidSVN/RapidSVN/issues/35

Latest upstream git seems to build OK if you switch to use wxWidgets 3.0 (change wxGTK-devel to wxGTK3-devel).

Comment 10 Tim Jackson 2018-11-25 21:22:08 UTC
Many thanks for the tip Scott! The change to wxWidgets 3.0 does indeed solve a lot of issues. There are some other changes that are needed to the spec file, but it fundamentally builds now. I'll push an update soon.

Comment 11 Tim Jackson 2018-12-03 22:07:09 UTC
So I finally pushed a fix to git which cleans up the whole spec and builds with the latest upstream version... and it now fails on F-30 because some of the build tools use Python 2. So, down another rabbit hole. At least tools/msgfmt.py fails to run with the Python 3 interpreter. If anyone has the desire to help then it will be much appreciated, since upstream is not very active.

Comment 12 Tim Jackson 2018-12-03 22:09:23 UTC
*** Bug 1556310 has been marked as a duplicate of this bug. ***

Comment 13 Tim Jackson 2018-12-03 22:12:20 UTC
for i in de fr hu it_IT pt_BR ru es uk zh_CN ja ; do \
    python3 ../../../tools/msgfmt.py -o ./$i/rapidsvn.mo ./$i/rapidsvn.po ; \
done
  File "../../../tools/msgfmt.py", line 86
    0x950412deL,       # Magic
              ^
SyntaxError: invalid syntax

Comment 14 Tim Jackson 2018-12-03 22:19:40 UTC
so, number with an "L" suffix is a long integer, apparently: https://docs.python.org/2/library/stdtypes.html

Looks like it can just be removed in Python3 : https://stackoverflow.com/questions/24059842/l-suffix-in-long-integer-in-python-3-x

but then it's:

  File "../../../tools/msgfmt.py", line 113
    except IOError, msg:

:-(

Comment 15 Scott Talbert 2018-12-04 04:09:13 UTC
(In reply to Tim Jackson from comment #11)
> So I finally pushed a fix to git which cleans up the whole spec and builds
> with the latest upstream version... and it now fails on F-30 because some of
> the build tools use Python 2. So, down another rabbit hole. At least
> tools/msgfmt.py fails to run with the Python 3 interpreter. If anyone has
> the desire to help then it will be much appreciated, since upstream is not
> very active.

You can just BuildRequire: /usr/bin/python for now and still use Python 2.  See:
https://fedoraproject.org/wiki/Changes/Move_usr_bin_python_into_separate_package

Comment 16 Tim Jackson 2018-12-04 21:18:58 UTC
Thanks. Having looked further, this is some kind of standard tool which is used instead of gettext msgfmt, and it's actually just a makefile fix to use gettext instead (which I believe was the case in previous builds, but upstream is now using msgfmt.py as default instead)

Comment 17 Tim Jackson 2018-12-04 21:47:38 UTC
Now successfully built in rawhide!
https://koji.fedoraproject.org/koji/taskinfo?taskID=31269439

Thanks for the help Scott!


Note You need to log in before you can comment on or make changes to this bug.