Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1606501 - teckit FTBFS: tests fail on aarch64
Summary: teckit FTBFS: tests fail on aarch64
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: teckit
Version: 29
Hardware: aarch64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1736896 (view as bug list)
Depends On:
Blocks: F31FTBFS F29FTBFS 1732841
TreeView+ depends on / blocked
 
Reported: 2018-07-20 20:19 UTC by Mohan Boddu
Modified: 2019-08-19 02:29 UTC (History)
3 users (show)

Fixed In Version: teckit-2.5.9-1.fc31 teckit-2.5.7-5.fc30 teckit-2.5.7-4.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-19 01:01:41 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2018-07-20 20:19 UTC, Mohan Boddu
no flags Details
root.log (deleted)
2018-07-20 20:19 UTC, Mohan Boddu
no flags Details
state.log (deleted)
2018-07-20 20:19 UTC, Mohan Boddu
no flags Details

Description Mohan Boddu 2018-07-20 20:19:37 UTC
teckit failed to build from source in Fedora rawhide

https://koji.fedoraproject.org/koji/taskinfo?taskID=28236380


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
Please fix teckit at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
teckit will be orphaned. Before branching of Fedora 30,
teckit will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Mohan Boddu 2018-07-20 20:19:45 UTC
Created attachment 1468447 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Mohan Boddu 2018-07-20 20:19:49 UTC
Created attachment 1468448 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Mohan Boddu 2018-07-20 20:19:55 UTC
Created attachment 1468449 [details]
state.log

Comment 4 Jan Kurik 2018-08-14 08:52:13 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 5 Petr Pisar 2019-08-09 11:31:46 UTC
*** Bug 1736896 has been marked as a duplicate of this bug. ***

Comment 6 Petr Pisar 2019-08-09 11:33:30 UTC
Tests fail on aarch64 only:

make  check-TESTS
make[2]: Entering directory '/builddir/build/BUILD/teckit-2.5.7/test'
make[3]: Entering directory '/builddir/build/BUILD/teckit-2.5.7/test'
FAIL: dotests.pl
============================================================================
Testsuite summary for teckit 2.5.7
============================================================================
# TOTAL: 1
# PASS:  0
# SKIP:  0
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0
============================================================================

Comment 7 Petr Pisar 2019-08-09 11:48:29 UTC
There was a new upstream release 2.5.9. Also upstream commit:

commit 99f5259cf419c53c805c856ff59f28ce916e4743 (origin/jlinton-remove_binary_compression_check)
Author: Jeremy Linton <jeremy.linton>
Date:   Mon May 21 16:00:59 2018 -0500

    Remove compressed image test
    
    The binary representation of a compressed block of data
    can vary depending on small implementation details in the
    compression library. Lets depend on the tests following
    the binary image comparison to decompress the .tec file
    and validate that the compress/decompress logic is functional.
    
    Signed-off-by: Jeremy Linton <jeremy.linton>

looks promising.

This package is needed for texlive-xetex. I will take this package <https://pagure.io/releng/issue/8597>.

Comment 8 Petr Pisar 2019-08-09 12:56:07 UTC
The test log:

FAIL: dotests.pl
================
compiling Greek mapping (uncompressed)... ok
comparing... ok
compiling Greek mapping (compressed)... ok
comparing... failed: Binary files ./SILGreek2004-04-27.tec.orig and SILGreek.tec differ

And the 99f5259cf419c53c805c856ff59f28ce916e4743 commit stat:

test/Makefile.am                 |   1 -
 test/SILGreek2004-04-27.tec.orig | Bin 8694 -> 0 bytes
 test/dotests.pl                  |   4 +++-
 3 files changed, 3 insertions(+), 2 deletions(-)

Very promising.

Comment 9 Fedora Update System 2019-08-09 13:23:34 UTC
FEDORA-2019-cd57b5fe4b has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-cd57b5fe4b

Comment 10 Fedora Update System 2019-08-09 13:28:59 UTC
FEDORA-2019-1db142a2be has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-1db142a2be

Comment 11 Fedora Update System 2019-08-11 01:22:52 UTC
teckit-2.5.7-4.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-1db142a2be

Comment 12 Fedora Update System 2019-08-11 02:20:08 UTC
teckit-2.5.7-5.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-cd57b5fe4b

Comment 13 Fedora Update System 2019-08-19 01:01:41 UTC
teckit-2.5.7-5.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2019-08-19 02:29:10 UTC
teckit-2.5.7-4.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.