Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1607171 - tigervnc 1.9.0 dropped provides for 'vnc', which avahi-ui-tools still requires
Summary: tigervnc 1.9.0 dropped provides for 'vnc', which avahi-ui-tools still requires
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tigervnc
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Grulich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1608884 1609478 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-22 21:59 UTC by "FeRD" (Frank Dana)
Modified: 2018-08-09 16:50 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-27 16:47:50 UTC
Type: Bug


Attachments (Terms of Use)

Description "FeRD" (Frank Dana) 2018-07-22 21:59:30 UTC
Description of problem:

I'm not sure whether this should be filed against tigervnc or avahi, but avahi-ui-tools has a Requires: 'vnc', which was in the Provides for tigervnc-1.8.0 but was dropped in the new package.

Version-Release number of selected component (if applicable):

tigervnc-1.9.0-1.fc28
avahi-ui-tools-0.7-12.fc28


How reproducible: Always

Steps to Reproduce:
1. sudo dnf install tigervnc-1.9.0-1.fc28
2. sudo dnf install avahi-ui-tools

Actual results:

Dependencies resolved.
================================================================================
 Package               Arch          Version                Repository     Size
================================================================================
Installing:
 avahi-ui-tools        x86_64        0.7-12.fc28            fedora         30 k
Downgrading:
 tigervnc              x86_64        1.8.0-7.fc28           fedora        255 k


Expected results:

The Requires for avahi-ui-tools would be satisfied by tigervnc-1.9.0

Additional info:

It seems the gitso package will also be affected by this change:

$ sudo dnf repoquery --whatrequires vnc       
avahi-ui-tools-0:0.7-12.fc28.x86_64
gitso-0:0.6-17.fc28.noarch

Comment 1 A. Galama 2018-07-23 14:43:22 UTC
dnf upgrade fails for me too:


# dnf upgrade
Last metadata expiration check: 1:41:53 ago on Mon 23 Jul 2018 02:58:23 PM CEST.
Dependencies resolved.

 Problem: package avahi-ui-tools-0.7-12.fc28.x86_64 requires vnc, but none of the providers can be installed
  - cannot install both tigervnc-1.9.0-1.fc28.x86_64 and tigervnc-1.8.0-10.fc28.x86_64
  - cannot install both tigervnc-1.8.0-7.fc28.x86_64 and tigervnc-1.9.0-1.fc28.x86_64
  - cannot install the best update candidate for package tigervnc-1.8.0-10.fc28.x86_64
  - cannot install the best update candidate for package avahi-ui-tools-0.7-12.fc28.x86_64
============================================================================================================================================================================================================================================
 Package                                                  Arch                                                   Version                                                      Repository                                               Size
============================================================================================================================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 tigervnc                                                 x86_64                                                 1.8.0-7.fc28                                                 fedora                                                  255 k
 tigervnc                                                 x86_64                                                 1.9.0-1.fc28                                                 updates                                                 273 k

Transaction Summary
============================================================================================================================================================================================================================================
Skip  2 Packages

Nothing to do.
Complete!

Comment 2 Fedora Update System 2018-07-24 07:55:51 UTC
gitso-0.6-19.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-cf1b3b7c45

Comment 3 Fedora Update System 2018-07-24 07:56:03 UTC
gitso-0.6-19.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-dc0dde19e3

Comment 4 Fedora Update System 2018-07-24 15:11:52 UTC
avahi-0.7-13.fc27, gitso-0.6-19.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-cf1b3b7c45

Comment 5 Fedora Update System 2018-07-24 17:21:24 UTC
avahi-0.7-13.fc28, gitso-0.6-19.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-dc0dde19e3

Comment 6 Jan Grulich 2018-07-26 12:49:44 UTC
*** Bug 1608884 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2018-07-27 16:47:50 UTC
avahi-0.7-13.fc28, gitso-0.6-19.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Jan Grulich 2018-07-30 05:48:04 UTC
*** Bug 1609478 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2018-08-09 16:50:43 UTC
avahi-0.7-13.fc27, gitso-0.6-19.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.