Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1618911 - pcsd fails to start: Ruby gem location '/usr/lib/pcsd/vendor/bundle/ruby' does not exist
Summary: pcsd fails to start: Ruby gem location '/usr/lib/pcsd/vendor/bundle/ruby' doe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pcs
Version: rawhide
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
Assignee: Ivan Devat
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1644926 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-18 05:29 UTC by Andrew Price
Modified: 2020-07-21 10:03 UTC (History)
7 users (show)

Fixed In Version: pcs-0.10.0.alpha.6-1.fc29 pcs-0.10.5-8.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 17:23:23 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Andrew Price 2018-08-18 05:29:05 UTC
[root@rawhide1 ~]# systemctl start pcsd
Job for pcsd.service failed because the control process exited with error code.
See "systemctl status pcsd.service" and "journalctl -xe" for details.
[root@rawhide1 ~]# systemctl status pcsd
● pcsd.service - PCS GUI and remote configuration interface
   Loaded: loaded (/usr/lib/systemd/system/pcsd.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sat 2018-08-18 06:21:40 BST; 5s ago
     Docs: man:pcsd(8)
           man:pcs(8)
  Process: 526 ExecStart=/usr/sbin/pcsd (code=exited, status=1/FAILURE)
 Main PID: 526 (code=exited, status=1/FAILURE)

Aug 18 06:21:40 rawhide1 systemd[1]: Starting PCS GUI and remote configuration interface...
Aug 18 06:21:40 rawhide1 systemd[1]: pcsd.service: Main process exited, code=exited, status=1/FAILURE
Aug 18 06:21:40 rawhide1 systemd[1]: pcsd.service: Failed with result 'exit-code'.
Aug 18 06:21:41 rawhide1 systemd[1]: Failed to start PCS GUI and remote configuration interface.
[root@rawhide1 ~]# cat /var/log/pcsd/pcsd.log
E, [2018-08-18T06:13:53.039 #00000]    ERROR -- : Ruby gem location '/usr/lib/pcsd/vendor/bundle/ruby' does not exist
E, [2018-08-18T06:15:23.771 #00000]    ERROR -- : Ruby gem location '/usr/lib/pcsd/vendor/bundle/ruby' does not exist
E, [2018-08-18T06:17:02.119 #00000]    ERROR -- : Ruby gem location '/usr/lib/pcsd/vendor/bundle/ruby' does not exist
E, [2018-08-18T06:20:13.876 #00000]    ERROR -- : Ruby gem location '/usr/lib/pcsd/vendor/bundle/ruby' does not exist
E, [2018-08-18T06:21:40.938 #00000]    ERROR -- : Ruby gem location '/usr/lib/pcsd/vendor/bundle/ruby' does not exist

Comment 1 Andrew Price 2018-08-18 05:38:44 UTC
This is with pcs-0.10.0.alpha.2-1.fc29.x86_64

Comment 2 Ivan Devat 2018-08-27 07:37:39 UTC
There are no bundled ruby gems in rawhide anymore and ruby gem location does not exist. However, pcsd was still checking it.

Comment 3 Jan Pokorný [poki] 2018-10-02 20:54:40 UTC
Well, even after this fix on Rawhide:

# systemctl start pcsd
> Job for pcsd.service failed because the control process exited with error code.
> See "systemctl status pcsd.service" and "journalctl -xe" for details.

# journalctl --no-hostname -b -u pcsd.service 2>/dev/null | tail -n+2
> Oct 02 22:40:09 systemd[1]: Starting PCS GUI and remote configuration interface...
> Oct 02 22:40:09 systemd[14932]: pcsd.service: Failed to execute command: No such file or directory
> Oct 02 22:40:09 systemd[14932]: pcsd.service: Failed at step EXEC spawning /usr/lib/pcsd/pcsd: No such file or directory
> Oct 02 22:40:09 systemd[1]: pcsd.service: Main process exited, code=exited, status=203/EXEC
> Oct 02 22:40:09 systemd[1]: pcsd.service: Failed with result 'exit-code'.
> Oct 02 22:40:09 systemd[1]: Failed to start PCS GUI and remote configuration interface.

# dnf repoquery -f /usr/lib/pcsd/pcsd
> [no answer]

->

# dnf repoquery -f '/usr/lib/pcsd/pcsd*'
> pcs-0:0.10.0.alpha.2-3.fc30.x86_64
# rpm -ql pcs | grep '/usr/lib/pcsd/pcsd.*'
> /usr/lib/pcsd/pcsd-cli.rb
> /usr/lib/pcsd/pcsd.logrotate
> /usr/lib/pcsd/pcsd.pam
> /usr/lib/pcsd/pcsd.rb
> /usr/lib/pcsd/pcsd_action_command.rb
> /usr/lib/pcsd/pcsd_exchange_format.rb
> /usr/lib/pcsd/pcsd_file.rb
> /usr/lib/pcsd/pcsd_remove_file.rb

# { printf '#!%s\n' "$(which ruby)"; cat /usr/lib/pcsd/pcsd.rb; } > /usr/lib/pcsd/pcsd
# chmod +x /usr/lib/pcsd/pcsd

->

> Oct 02 22:51:15 systemd[1]: Starting PCS GUI and remote configuration interface...
> Oct 02 22:51:15 systemd[15770]: pcsd.service: Failed to execute command: No such file or directory
> Oct 02 22:51:15 systemd[15770]: pcsd.service: Failed at step EXEC spawning /usr/lib/pcsd/pcsd: No such file or directory
> Oct 02 22:51:15 systemd[1]: pcsd.service: Main process exited, code=exited, status=203/EXEC
> Oct 02 22:51:15 systemd[1]: pcsd.service: Failed with result 'exit-code'.
> Oct 02 22:51:15 systemd[1]: Failed to start PCS GUI and remote configuration interface.
> Oct 02 22:52:03 systemd[1]: Starting PCS GUI and remote configuration interface...
> Oct 02 22:52:03 pcsd[15853]: /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:59:in `require': cannot load such file -- bootstrap.rb (LoadError)
> Oct 02 22:52:03 pcsd[15853]:         from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:59:in `require'
> Oct 02 22:52:03 pcsd[15853]:         from /usr/lib/pcsd/pcsd:12:in `<main>'
> Oct 02 22:52:03 systemd[1]: pcsd.service: Main process exited, code=exited, status=1/FAILURE
> Oct 02 22:52:03 systemd[1]: pcsd.service: Failed with result 'exit-code'.
> Oct 02 22:52:03 systemd[1]: Failed to start PCS GUI and remote configuration interface.

->

:-/


# rpm -q pcs ruby
> pcs-0.10.0.alpha.2-3.fc30.x86_64
> ruby-2.5.1-100.fc30.x86_64

Comment 4 Fedora Update System 2018-10-10 07:34:05 UTC
pcs-0.10.0.alpha.6-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-fada53478c

Comment 5 Fedora Update System 2018-10-10 15:50:13 UTC
pcs-0.10.0.alpha.6-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-fada53478c

Comment 6 Jan Pokorný [poki] 2018-10-12 08:45:23 UTC
Confirming that pcs-0.10.0.alpha.6-1.fc30.x86_64 WFM, thanks!

FTR, apparently this change made the trick:

-ExecStart=/usr/lib/pcsd/pcsd
+ExecStart=/usr/sbin/pcsd

That being told, aren't there ruby-based daemon related files that
became obsolete and hence amount to just a residual binary litter?
E.g. mentioned /usr/lib/pcsd/pcsd.rb.

Comment 7 Ondrej Mular 2018-10-23 09:01:09 UTC
We have not removed all of the ruby code yet, therefore most of the ruby files (such as /usr/lib/pcsd/pcsd.rb) must be preserved in rpm. All daemon-related ruby files that are not required anymore have been removed already.

Comment 8 Fedora Update System 2018-10-30 17:23:23 UTC
pcs-0.10.0.alpha.6-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Clayton Louden 2018-11-01 01:49:08 UTC
*** Bug 1644926 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2020-07-21 10:03:11 UTC
FEDORA-2020-0a4ce6ab7e has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.