Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1622910 - graphite-build-index fails
Summary: graphite-build-index fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: graphite-web
Version: 28
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Piotr Popieluch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-28 08:06 UTC by Kees de Jong
Modified: 2018-10-25 22:11 UTC (History)
3 users (show)

Fixed In Version: graphite-web-1.1.3-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-25 22:11:15 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Kees de Jong 2018-08-28 08:06:55 UTC
Description of problem: In /usr/share/doc/graphite-web/README.fedora it states to build the index with `/usr/bin/graphite-build-index`. However, this fails with the error:
# graphite-build-index                                                                                                                                                                                                                                                                                                                                
Traceback (most recent call last):
  File "/usr/bin/graphite-build-index", line 10, in <module>
    from graphite.util import write_index
ImportError: cannot import name write_index


Version-Release number of selected component (if applicable): graphite-web-1.1.1-4.fc28.noarch


How reproducible: Run `/usr/bin/graphite-build-index`


Steps to Reproduce: /usr/share/doc/graphite-web/README.fedora


Actual results: Fails with Python error.


Expected results: Building the Graphite index as the README states.


Additional info: Step 1 of /usr/share/doc/graphite-web/README.fedora can also be updated to: `django-admin-1.11 migrate --settings=graphite.settings --run-syncdb --no-input`

Comment 1 Kees de Jong 2018-08-28 08:13:01 UTC
An upstream bugreport wouldn't make sense, since this problem hasn't been tested on the latest version available (1.1.3). Bumping the graphite-web version to the latest might also fix it. More info: https://github.com/graphite-project/graphite-web/releases

Comment 2 Piotr Popieluch 2018-09-15 21:10:34 UTC
I think this is fixed in a later version. Will check if I can bump F28 to a later release.

Comment 3 Kees de Jong 2018-10-15 14:05:53 UTC
(In reply to Piotr Popieluch from comment #2)
> I think this is fixed in a later version. Will check if I can bump F28 to a
> later release.

Do you have an ETA? :)

Comment 4 Piotr Popieluch 2018-10-15 16:42:42 UTC
Building 1.1.3 for F28 right now. 

Didn't update to 1.1.4 as those packages (from F29 and Rawhide) are already on Python 3 and didn't want to switch during in a released Fedora.

Comment 5 Fedora Update System 2018-10-15 18:41:17 UTC
python-whisper-1.1.3-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-7325e1e893

Comment 6 Fedora Update System 2018-10-15 18:41:42 UTC
python-carbon-1.1.3-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-628f6fda04

Comment 7 Fedora Update System 2018-10-15 18:42:12 UTC
graphite-web-1.1.3-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-c15abbf7b9

Comment 8 Fedora Update System 2018-10-16 12:37:54 UTC
python-whisper-1.1.3-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-7325e1e893

Comment 9 Fedora Update System 2018-10-16 12:37:58 UTC
python-carbon-1.1.3-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-628f6fda04

Comment 10 Fedora Update System 2018-10-16 12:38:01 UTC
graphite-web-1.1.3-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-c15abbf7b9

Comment 11 Fedora Update System 2018-10-25 22:11:15 UTC
python-whisper-1.1.3-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2018-10-25 22:11:18 UTC
python-carbon-1.1.3-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2018-10-25 22:11:20 UTC
graphite-web-1.1.3-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.