Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1627117 - perl-Gtk3-0.034-3.fc30 FTBFS: Undefined subroutine &Gtk3::Gdk::PIXDATA_HEADER_LENGTH called at /builddir/build/BUILD/Gtk3-0.034/blib/lib/Gtk3.pm line 2119
Summary: perl-Gtk3-0.034-3.fc30 FTBFS: Undefined subroutine &Gtk3::Gdk::PIXDATA_HEADER...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Gtk3
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Berrangé
QA Contact: Fedora Extras Quality Assurance
URL: https://apps.fedoraproject.org/kosche...
Whiteboard:
: 1675630 (view as bug list)
Depends On: 1676474
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2018-09-10 13:37 UTC by Petr Pisar
Modified: 2019-08-09 08:04 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-08 13:21:57 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
CPAN 127071 0 None None None 2018-09-10 13:37:18 UTC

Description Petr Pisar 2018-09-10 13:37:19 UTC
perl-Gtk3-0.034-3.fc30 fails to build in F30 because a test fails:

t/floating-refs.t .............. ok
GLib-GIO-Message: 00:13:22.454: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.
Undefined subroutine &Gtk3::Gdk::PIXDATA_HEADER_LENGTH called at /builddir/build/BUILD/Gtk3-0.034/blib/lib/Gtk3.pm line 2119.
# Looks like your test exited with 255 just after 162.
t/overrides.t .................. 
Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 71/233 subtests 

A difference between passing and failing build root is at <https://apps.fedoraproject.org/koschei/build/5371427>.

This bug is probably caused by upgrading gdk-pixbuf2 from 2.36.12-2.fc29 to 2.38.0-2.fc30.

Comment 1 Daniel Berrangé 2019-02-12 11:23:53 UTC
*** Bug 1675630 has been marked as a duplicate of this bug. ***

Comment 3 Petr Pisar 2019-04-12 07:51:01 UTC
This is still broken in Fedora 29 (perl-Gtk3-0.034-3.fc29).

Comment 4 Mohan Boddu 2019-08-08 13:21:57 UTC
The following builds were made: perl-Gtk3-0.034-5.fc30 perl-Gtk3-0.034-6.fc30 perl-Gtk3-0.035-1.fc31 perl-Gtk3-0.035-2.fc31 perl-Gtk3-0.035-3.fc31

Comment 5 Petr Pisar 2019-08-09 08:04:06 UTC
(In reply to Mohan Boddu from comment #4)
> The following builds were made: perl-Gtk3-0.034-5.fc30
> perl-Gtk3-0.034-6.fc30 perl-Gtk3-0.035-1.fc31 perl-Gtk3-0.035-2.fc31
> perl-Gtk3-0.035-3.fc31

(In reply to Petr Pisar from comment #3)
> This is still broken in Fedora 29 (perl-Gtk3-0.034-3.fc29).
                                 ^^^


Note You need to log in before you can comment on or make changes to this bug.