Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1634232 - dnf lost aliases for command arguments
Summary: dnf lost aliases for command arguments
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 29
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Pavla Kratochvilova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-29 07:36 UTC by Kees de Jong
Modified: 2020-05-26 06:41 UTC (History)
10 users (show)

Fixed In Version: dnf-4.2.5-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-29 02:15:12 UTC
Type: Bug


Attachments (Terms of Use)

Description Kees de Jong 2018-09-29 07:36:31 UTC
Description of problem: I just tried the Fedora 29 Beta, I was surprised that the command argument aliases for DNF are not working anymore. 


Version-Release number of selected component (if applicable):
# dnf --version
3.6.1
  Installed: dnf-0:3.6.1-1.fc29.noarch at Sat 29 Sep 2018 07:10:28 AM GMT
  Built    : Fedora Project at Tue 25 Sep 2018 09:39:56 AM GMT

  Installed: rpm-0:4.14.2-1.fc29.x86_64 at Tue 25 Sep 2018 07:54:53 PM GMT
  Built    : Fedora Project at Wed 22 Aug 2018 08:07:47 AM GMT


How reproducible on Fedora 29 Beta:
# dnf up
No such command: up. Please use /usr/bin/dnf --help
It could be a DNF plugin command, try: "dnf install 'dnf-command(up)'"

How reproducible on Fedora 28:
# dnf up
Last metadata expiration check: 0:26:51 ago on za 29 sep 2018 09:05:27 CEST.
Dependencies resolved.
Nothing to do.
Complete!

To get a full overview of the aliases on Fedora 28, type in dnf in the command line and then double press the tab key:
# dnf 
Display all 107 possibilities? (y or n)
autoremove                    debug-dump                    dup                           groups                        install-nevra                 playground                    repograph                     reposync                      up
autoremove-n                  debuginfo-install             erase                         groupupdate                   leaves                        provides                      repoinfo                      ri                            update
autoremove-na                 debug-restore                 erase-n                       help                          list                          ref                           repolist                      rm                            updateinfo
autoremove-nevra              deplist                       erase-na                      history                       list-sec                      refresh                       repomanage                    se                            update-minimal
build-dep                     dg                            erase-nevra                   in                            list-security                 rei                           repo-packages                 search                        update-to
builddep                      distribution-synchronization  fedup                         info                          list-updateinfo               reinstall                     repo-pkgs                     sh                            upgrade
check                         distro-sync                   group                         info-sec                      localinstall                  remove                        repoquery                     shell                         upgrade-minimal
check-update                  distrosync                    grouperase                    info-security                 makecache                     remove-n                      repoquery-n                   summary-updateinfo            upgrade-to
check-upgrade                 dist-upgrade                  groupinfo                     info-updateinfo               mark                          remove-na                     repoquery-na                  swap                          up-min
clean                         downgrade                     groupinstall                  install                       mc                            remove-nevra                  repoquery-nevra               system-upgrade                versionlock
config-manager                download                      grouplist                     install-n                     module                        repoclosure                   repository-packages           u-m                           whatprovides
copr                          dsync                         groupremove                   install-na                    needs-restarting              repo-graph                    repository-pkgs               um 

Version on Fedora 28:
# dnf --version
2.7.5
  Installed: dnf-0:2.7.5-12.fc28.noarch at wo 30 mei 2018 06:27:57 GMT
  Built    : Fedora Project at wo 18 apr 2018 14:29:51 GMT

  Installed: rpm-0:4.14.2-1.fc28.x86_64 at za 08 sep 2018 12:10:32 GMT
  Built    : Fedora Project at wo 22 aug 2018 12:06:17 GMT


Expected results: Unless this feature got removed (can't find any mention in the changelogs), I would expect these aliases to still work.


Additional info: These kind of aliases are also present in zypper (SUSE), so it's a nice feature to win people over from SUSE to Fedora/RHEL.

Comment 1 Tim Hammerquist 2018-12-15 10:22:10 UTC
I also really liked this abbreviation in Fedora 27, also missing in F29 for me.

After digging through the dnf repo, I found these links:

https://github.com/rpm-software-management/dnf/pull/980

https://github.com/rpm-software-management/dnf/pull/980/commits/a32955de06f29f8e16e5f73d89bd3fb2441cd91a

Appears these abbreviated commands were removed to resolve ambiguity in shell completion.

Comment 2 Neal Gompa 2019-04-20 18:06:02 UTC
We should be able to reintroduce them soon enough.

The basic functionality was restored: https://github.com/rpm-software-management/dnf/commit/da52d0ee8ec53fc67477a448ef9da73e32ce2cf2

There's a PR open for installing the aliases: https://github.com/rpm-software-management/dnf/pull/1382

Comment 3 Pavla Kratochvilova 2019-04-24 06:55:29 UTC
The patch adds back some of the aliases that were removed previously (namely: dsync, dg, in, mc, rei, rm, se, sh, up, up-min), and some are in zypper.conf file that won't be included in Fedora. The idea is to support one abbreviation for each command at maximum and have a separate config file for zypper compatibility.

Comment 4 Fedora Update System 2019-04-25 16:43:35 UTC
dnf-4.2.5-1.fc29 libdnf-0.31.0-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-2612a121ba

Comment 5 Fedora Update System 2019-04-26 22:10:11 UTC
dnf-4.2.5-1.fc29, libdnf-0.31.0-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-2612a121ba

Comment 6 Fedora Update System 2019-04-29 02:15:12 UTC
dnf-4.2.5-1.fc29, libdnf-0.31.0-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Marius Andreiana 2020-05-26 06:41:39 UTC
*** Bug 1839951 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.