Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1645829 - xfce panel, some tool tips broken, whole panel "shutters" instead of showing tool tips
Summary: xfce panel, some tool tips broken, whole panel "shutters" instead of showing ...
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: xfwm4
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-04 06:24 UTC by Paul DeStefano
Modified: 2019-11-27 18:16 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-27 18:16:33 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Screenshot of missing tooltip. (deleted)
2018-11-04 16:39 UTC, Paul DeStefano
no flags Details
Screen-capture of the problem. (deleted)
2018-11-05 03:27 UTC, Paul DeStefano
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME/gtk/issues/1371 0 None None None 2018-12-16 14:42:30 UTC

Description Paul DeStefano 2018-11-04 06:24:39 UTC
Description of problem:
Directly after upgrade to F29, nearly all my tool tips are broken, except for BOINC manger in the system tray.

Version-Release number of selected component (if applicable):
xfce4-panel-4.13.3-20.fc29.x86_64

How reproducible:
Always since upgrade, but I cannot see any pattern to which panel icons have this problem.  Nearly all of those I have chosen to put in my panel have the problem, including the Xfce menu, several applications marked as "(external)", and several that are not marked as "(external)", both launcher-based applications and non-launcher panel apps like Dictionary.

Steps to Reproduce:
1. Upgrade to F29 from F28
2. Add Xfce menu to Xfce panel
3. put mouse on top of Xfce menu button, wait

Comment 1 Mukundan Ragavan 2018-11-04 13:16:42 UTC
Can you post some screenshots? All tooltips are functional here.

What is your locale? I am wondering if this has something to do with locales - just a wild guess to be honest.

Comment 2 Paul DeStefano 2018-11-04 16:38:31 UTC
Hmm, I don't know how a screen shot would capture the flashing...yeah, it doesn't show the panel going into convulsions.  I'll try to take a screen-cast in a bit.

Comment 3 Paul DeStefano 2018-11-04 16:39:01 UTC
Created attachment 1501377 [details]
Screenshot of missing tooltip.

Comment 4 Paul DeStefano 2018-11-05 03:27:20 UTC
Created attachment 1501626 [details]
Screen-capture of the problem.

Here is a screen-capture of the issue in action.  I suspect something with the video stack since I only see this on my RX480 system and not my laptop.

Comment 5 Jan "Yenya" Kasprzak 2018-11-06 16:52:36 UTC
I have the same problem, and another one with tooltips of some GTK apps, which might be related to this - reported as bug #1647105.

Comment 6 Mukundan Ragavan 2018-11-06 22:49:51 UTC
(In reply to Paul DeStefano from comment #4)
> 
> Here is a screen-capture of the issue in action.  I suspect something with
> the video stack since I only see this on my RX480 system and not my laptop.

Interesting. What's the difference in hardware?

Comment 7 Paul DeStefano 2018-11-07 05:17:24 UTC
I'm not sure what you mean, but my AMD system (CPU+GPU, F29) shows this bug.  My Intel-based laptop (CPU+integrated GPU, F30) does not.  Does that answer your question?

Also, my locale is en_US.utf8.

Looks like it's not just me, though.  Yenya, what video stack to you have?

Comment 8 Jan "Yenya" Kasprzak 2018-11-07 08:50:38 UTC
My shiny new desktop computer :-) where the screencast attached to bug #1647105 was created has this graphics card:

1d:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Lexa PRO [Radeon RX 550/550X] (rev c7)

and a Ryzen 2700X CPU. I use stock graphics drivers from Fedora.

I can see the problem also on my HP Elitebook 840, which has an integrated Intel graphics and Intel CPU.

Comment 9 Jan "Yenya" Kasprzak 2018-11-07 09:17:13 UTC
I have another interesting observation: my panel is set up like this (from top of the screen to bottom):

(f) main menu
various launchers (firefox, Terminal, Thunar, ...)
|
expandable spacer
|
workspace switcher
window menu
notification area
system load monitor
orage clock
lock screen (action buttons)

On my desktop, I see the applet blinking and tooltip flashing only when holding the mouse above the main menu, all launchers, and the lock screen button. All the other applets display the correct steady tooltip.

On my laptop, the situation is similar, _except_ that I can see the problem also with window menu applet (which displays correct tooltip on my desktop computer).

Comment 10 Raphael Groner 2018-11-07 19:06:37 UTC
Thanks for the information. This lets me suspect a general bug somewhere in Gtk3.

Do you have compositor enabled? If yes, please try to disable and report if the issue is still there. What window manager is used, propably xfwm4 as the default?

Comment 11 Paul DeStefano 2018-11-07 23:01:04 UTC
Actually, I did try that, and it didn't resolve the problem; tool tips still don't show up.  But, the panel doesn't shutter with the compositor off; only the button flashes underneath the mouse pointer.

Comment 12 Jan "Yenya" Kasprzak 2018-11-08 07:51:49 UTC
Re: comment #10

AFAIK I don't use any compositor. But I do use Sawfish instead of Xfwm4. I'll try xfwm4 later - now I have too many important active windows in my session :-)

sawfish-1.12.90-4.fc29.x86_64

Comment 13 Jan "Yenya" Kasprzak 2018-11-08 13:36:31 UTC
When replacing sawfish by xfwm4 on my desktop, Panel displays correct tooltips, but flashing tooltips in Liferea, Thunar and Gajim (as described in bug #1647105) remain. Killing xfwm4 and returning to sawfish again, tooltips for Panel applets flash as before.

Comment 14 Paul DeStefano 2018-11-08 14:59:14 UTC
Oh yeah, sorry, I'm using xfwm4.

Comment 15 Paul DeStefano 2018-11-08 16:06:52 UTC
Aha! so, I see the same shuttering an absent tool tips in OpenOffice, too. So, it's not panel.  Do we agree that it's xfwm4?

Comment 16 Mukundan Ragavan 2018-11-08 23:05:42 UTC
(In reply to Paul DeStefano from comment #15)
> Aha! so, I see the same shuttering an absent tool tips in OpenOffice, too.
> So, it's not panel.  Do we agree that it's xfwm4?

FANTASTIC! I can finally reproduce this. It's likely to be xfwm4.

Comment 17 Jan "Yenya" Kasprzak 2018-11-09 07:31:26 UTC
Really? As I said before, I experience the same problem without xfwm4.

Comment 18 Paul DeStefano 2018-11-09 16:44:59 UTC
Oh, I read it wrong; I thought you said sawfish worked and xfwm4 didn't.  Well, I have xfwm4 and I see the problem with tooltips on the Xfce panel and in OpenOffice.  Although, I cannot seem to find another application that has this problem; I've checked quite a few.

In any case, this does happen with xfwm4.  Does anyone know how OpenOffice buttons are different from other app buttons?  I think that would tell us what we want to know.

Comment 19 Trevor Cordes 2018-12-08 06:14:30 UTC
It's probably a GTK3 thing, if I had to guess.

Happens to me right after upgrading to F29.

My setup:
nvidia binary drivers
xfce
sawfish wm
no compositor

It annoys me most in qalculate, but happens in many apps.  The easiest example I've found to show the bug is in gnome-terminal (in bash) run: printf '\033]8;;%s\a%s\033]8;;\a' hello world
and hover over "world".

https://gitlab.gnome.org/GNOME/gtk/issues/1371 upstream is almost certainly this bug.  Haven't tried its workaround yet, but it sounds easy enough (but needs a logout to take effect).

bz 1647105 and bz 1644128 are almost certainly duplicates.

Comment 20 Sam G 2019-04-16 17:17:18 UTC
I'm also having this problem in Fedora 29 with the latest LibreOffice 6.1.5.2-5 release (it was present in earlier versions also). The system is running KDE and radeon graphics drivers on a dual Xeon, so it doesn't seem to be a duplicate or related to the wm.

Comment 21 Raphael Groner 2019-04-16 17:42:12 UTC
This could be an issue within the driver, too. What GPU do you use?

Comment 22 Paul DeStefano 2019-05-02 03:06:00 UTC
AMDGPU driver with RX 480 GPU.  Since AMDGPU, there have been many problems, but this one is very new and does not correlate with the switch to AMDGPU, though it may correlate with an update to it.  I would bet on some other part of the stack, but probably has to do with supporting AMD in some way.

Comment 23 Jan "Yenya" Kasprzak 2019-05-02 08:53:39 UTC
This seems to be fixed in F30, or at least I am not able to reproduce this on two of my computers, which I have upgraded to F30 so far (one of them has AMD GPU, the other one is a laptop with IntelHD GPU).

Comment 24 Paul DeStefano 2019-05-02 16:20:23 UTC
Ah, right, I was wrong.  I did see this on my labtop with Intel GPU, too.

But, I also see that it got fixed on rawhide a short while ago.  Sorry, I forgot it was happening on that system, too.

Does this indicate what was the fix and what was the problem?

Comment 25 Ben Cotton 2019-10-31 19:26:35 UTC
This message is a reminder that Fedora 29 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora 29 on 2019-11-26.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
Fedora 'version' of '29'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 29 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 26 Jan "Yenya" Kasprzak 2019-11-01 07:24:02 UTC
FWIW, it is apparently also not present in F31.

Comment 27 Ben Cotton 2019-11-27 18:16:33 UTC
Fedora 29 changed to end-of-life (EOL) status on 2019-11-26. Fedora 29 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.