Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1650875 - Selecting Settings->Scripting causes instant crash to desktop
Summary: Selecting Settings->Scripting causes instant crash to desktop
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: codeblocks
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Dan Horák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1699529 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-17 00:37 UTC by Ian Laurie
Modified: 2019-06-17 23:33 UTC (History)
2 users (show)

Fixed In Version: codeblocks-17.12-12.fc31 codeblocks-17.12-12.fc30 codeblocks-17.12-12.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-17 18:27:54 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Ian Laurie 2018-11-17 00:37:29 UTC
Description of problem:
Selecting Settings->Scripting causes instant crash to desktop.

Version-Release number of selected component (if applicable):
codeblocks-17.12-7.fc29.x86_64

How reproducible:
100% always

Steps to Reproduce:
1. Open Code::Blocks
2. Click Settings on the menu
3. Select "Scripting..."

Actual results:
Crashes to desktop with loss of work.

Expected results:
Should not crash.

Additional info:
For me this is 100% repeatable.

Comment 1 Ian Laurie 2018-11-23 01:34:23 UTC
FWIW codeblocks-17.12-7.fc29.i686 has the same problem.

Comment 2 Ian Laurie 2018-12-23 21:31:03 UTC
Updated codeblocks-17.12-9.fc29.x86_64 still crashes to the desktop when you select "Scripting" on the settings menu.

Comment 3 Dan Horák 2019-06-07 10:39:30 UTC
(gdb) where
#0  0x00007fffa6db2668 in __libc_signal_restore_set (set=0x7fffe6167038) at ../sysdeps/unix/sysv/linux/internal-signals.h:84
#1  0x00007fffa6db2668 in __GI_raise (sig=<optimized out>) at ../sysdeps/unix/sysv/linux/raise.c:48
#2  0x00007fffa6d94710 in __GI_abort () at abort.c:79
#3  0x00000001209e6634 in std::__replacement_assert(char const*, int, char const*, char const*)
    (__condition=0x120a203d0 "__builtin_expect(__n < this->size(), true)", __function=0x120a2f6a8 "std::vector<_Tp, _Alloc>::reference std::vector<_Tp, _Alloc>::operator[](std::vector<_Tp, _Alloc>::size_type) [with _Tp = ScriptEntry; _Alloc = std::allocator<ScriptEntry>; std::vector<_Tp, _Alloc>::r"..., __line=1009, __file=0x120a20538 "/usr/include/c++/9/bits/stl_vector.h")
    at /usr/include/c++/9/ppc64le-redhat-linux/bits/c++config.h:463
#4  0x00000001209e6634 in std::vector<ScriptEntry, std::allocator<ScriptEntry> >::operator[](unsigned long) (__n=<optimized out>, this=0x7fffe6167ac8)
    at /usr/include/c++/9/bits/stl_vector.h:1009
#5  0x00000001209e6634 in ScriptingSettingsDlg::UpdateState() (this=0x7fffe6167708) at scriptingsettingsdlg.cpp:106
#6  0x00000001209ecafc in ScriptingSettingsDlg::FillScripts() (this=0x7fffe6167708) at scriptingsettingsdlg.cpp:96
#7  0x00000001209ed408 in ScriptingSettingsDlg::ScriptingSettingsDlg(wxWindow*) (this=0x7fffe6167708, parent=<optimized out>) at scriptingsettingsdlg.cpp:58
#8  0x0000000120991e2c in MainFrame::OnSettingsScripting(wxCommandEvent&) (this=<optimized out>, event=...) at main.cpp:4789


which corresponds to https://github.com/jenslody/codeblocks/blob/master/src/src/scriptingsettingsdlg.cpp#L106

Comment 4 Dan Horák 2019-06-07 11:32:54 UTC
*** Bug 1699529 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2019-06-07 13:30:28 UTC
FEDORA-2019-194f1b2540 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-194f1b2540

Comment 6 Fedora Update System 2019-06-07 13:30:29 UTC
FEDORA-2019-f0040e3eae has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-f0040e3eae

Comment 7 Ian Laurie 2019-06-07 23:17:36 UTC
Tested codeblocks-17.12-12.fc30.x86_64 and it seems to be fixed.

Comment 8 Fedora Update System 2019-06-08 00:51:06 UTC
codeblocks-17.12-12.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-f0040e3eae

Comment 9 Fedora Update System 2019-06-08 03:00:36 UTC
codeblocks-17.12-12.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-194f1b2540

Comment 10 Fedora Update System 2019-06-17 18:27:54 UTC
codeblocks-17.12-12.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2019-06-17 23:33:24 UTC
codeblocks-17.12-12.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.