Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1675390 - mingw-wine-gecko: FTBFS in Fedora rawhide/f30
Summary: mingw-wine-gecko: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mingw-wine-gecko
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Cronenworth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1423951 1604850 1736123 (view as bug list)
Depends On: 1722489
Blocks: F31FTBFS F26FTBFS F29FTBFS F30FTBFS 1732841
TreeView+ depends on / blocked
 
Reported: 2019-02-11 20:53 UTC by Fedora Release Engineering
Modified: 2019-09-13 21:30 UTC (History)
5 users (show)

Fixed In Version: mingw-wine-gecko-2.47-9.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-13 21:30:05 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 20:53 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 20:53 UTC, Fedora Release Engineering
no flags Details
state.log (653 bytes, text/plain)
2019-02-11 20:53 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 20:53:09 UTC
mingw-wine-gecko failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32414687


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix mingw-wine-gecko at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
mingw-wine-gecko will be orphaned. Before branching of Fedora 31,
mingw-wine-gecko will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 20:53:11 UTC
Created attachment 1531263 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 20:53:13 UTC
Created attachment 1531264 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 20:53:14 UTC
Created attachment 1531265 [details]
state.log

Comment 4 Michael Cronenworth 2019-02-20 01:02:25 UTC
*** Bug 1604850 has been marked as a duplicate of this bug. ***

Comment 5 Michael Cronenworth 2019-02-20 01:02:35 UTC
*** Bug 1423951 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Release Engineering 2019-04-26 23:29:40 UTC
Dear Maintainer,

your package has not been built successfully in f30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 7 Tim Landscheidt 2019-06-19 10:32:50 UTC
@Michael: I assume your change to ASSIGNED and removing Andreas from needinfo was inadvertent; unfortunately, I don't seem to be able to change the status back to NEW.  If you intend to work on this bug yourself, please assign it to yourself.

Comment 8 Michael Cronenworth 2019-06-19 13:33:33 UTC
Andreas is, AFAIK, no longer in Fedora development. I'm the primary maintainer for any wine related package.

I contacted upstream about these issues back in May 2018 and never got a response. I haven't had the time to pursue the issue further. I'd accept any patches.

Comment 9 Tim Landscheidt 2019-06-20 13:16:59 UTC
@Michael: I'm sorry, soon afterwards I looked at the changelog and saw your contributions.

AFAICT, the bug is due to old-configure trying to compile a test case to "conftest", but i686-w64-mingw32-gcc creating a file "conftest.exe" (cf. bug #1722489).  I think fixing this The Right Way™ (for example, by updating autoconf or something similar), especially without upstream's support, would be a monumental task.

Comment 10 Tim Landscheidt 2019-06-20 13:24:27 UTC
Some random stuff I noted:

- "%" needs be escaped as "%%" in "#Source0:        http://downloads.sourceforge.net/wine/wine-mozilla-%{version}-src.tar.bz2".

- "BuildRequires: gcc" and "BuildRequires: gcc-c++" are missing.

- I prefer "%autosetup -n wine-mozilla-%{version} -p1" instead of "%setup", "cd"s and "%patch".

- "sed -i 's,cross_compiling=.*$,cross_compiling=yes,' nsprpub/configure" seems to be a NOP.

- "cp wine/mozconfig-common wine/mozconfig-common.build" seems to be a NOP.

- "echo "export CFLAGS=\"-DWINE_GECKO_SRC\"" >> wine/mozconfig-common" sets CFLAGS unconditionally to "-DWINE_GECKO_SRC", so upstream's "export CFLAGS="$CFLAGS -DWINE_GECKO_SRC"" which would allow to pass CFLAGS by environment is ignored.

Comment 11 Michael Cronenworth 2019-08-02 02:51:51 UTC
*** Bug 1736123 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Release Engineering 2019-08-08 15:57:42 UTC
The package was retired.

Comment 13 Michael Cronenworth 2019-08-09 19:11:19 UTC
We're still here folks.

Latest update: https://www.winehq.org/pipermail/wine-devel/2019-August/149411.html

Comment 14 Ben Cotton 2019-08-13 17:03:35 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 15 Ben Cotton 2019-08-13 17:14:02 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 16 Michael Cronenworth 2019-09-13 21:30:05 UTC
It only took 3 years, but we're building again.


Note You need to log in before you can comment on or make changes to this bug.