Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1677062 - open link in e.g. terminal does not work if 'Firefox on Wayland' is running
Summary: open link in e.g. terminal does not work if 'Firefox on Wayland' is running
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ffwayland
TreeView+ depends on / blocked
 
Reported: 2019-02-13 22:14 UTC by Chris Murphy
Modified: 2019-02-27 09:18 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-27 09:18:15 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
screenshot of error (deleted)
2019-02-13 22:14 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2019-02-13 22:14:02 UTC
Created attachment 1534591 [details]
screenshot of error

Description of problem:

If I launch Firefox on Wayland, and then click to open a URL in gnome-terminal, I get an error dialog from Firefox. This works as expected if Firefox is running instead.

Version-Release number of selected component (if applicable):
firefox-wayland-65.0-4.fc29.x86_64
firefox-65.0-4.fc29.x86_64


How reproducible:
Always


Steps to Reproduce:
1. Launch Firefox on Wayland
2. gnome-terminal, click on a URL (can copy paste a URL into terminal and then right click on that URL and choose to open link or double click on the url)
3.

Actual results:

Error dialog screenshot attached

Expected results:

The URL should be opened in Firefox on Wayland, same as if Firefox had been launched.

Additional info:

Comment 1 Martin Stransky 2019-02-27 09:18:15 UTC
Yes, it's because you need to specify your default application in Settings -> Details -> Default Application. "Firefox" and "Firefox on Wayland" are two different applications which can't share the same Firefox profile, so when one is running you can't launch another one.


Note You need to log in before you can comment on or make changes to this bug.