Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1696853 - rpm-ostree install or upgrade fails with an Authorization error 'The name is not activatable'
Summary: rpm-ostree install or upgrade fails with an Authorization error 'The name is ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm-ostree
Version: 30
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Colin Walters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: IoT
TreeView+ depends on / blocked
 
Reported: 2019-04-05 18:42 UTC by Paul Whalen
Modified: 2019-05-21 13:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-21 13:01:29 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Paul Whalen 2019-04-05 18:42:57 UTC
Description of problem:
Attempting to upgrade or install a new package with rpm-ostree fails with:

error: Authorization error: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name is not activatable


Version-Release number of selected component (if applicable):
rpm-ostree-2019.3-1.fc30.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1. Install the latest F30 IoT nightly (Fedora-IoT-30-20190404.0)
2. Attempt to upgrade


Actual results:
[root@localhost ~]# rpm-ostree status
State: idle
AutomaticUpdates: disabled
Deployments:
● ostree://fedora-iot:fedora/devel/x86_64/iot
                   Version: 30.20190404.0 (2019-04-04T01:30:05Z)
                    Commit: 5fcfdd8ef12d3a84bc4b66c8c48130c20beff09c7dff661153f856dcf7c5fbb1
              GPGSignature: Valid signature by C2A3FA9DC67F68B98BB543F47BB90722DBBDCF7C

[root@localhost ~]# rpm-ostree upgrade
error: Authorization error: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name is not activatable

from journalctl 

Apr 05 14:25:29 localhost.localdomain rpm-ostree[3647]: Allowing active client :1.32 (uid 0)
Apr 05 14:25:29 localhost.localdomain rpm-ostree[3647]: client(id:cli dbus:1.32 unit:session-3.scope uid:0) added; new total=1
Apr 05 14:25:29 localhost.localdomain rpm-ostree[3647]: client(id:cli dbus:1.32 unit:session-3.scope uid:0) vanished; remaining=0
Apr 05 14:25:29 localhost.localdomain rpm-ostree[3647]: In idle state; will auto-exit in 62 seconds

Comment 1 Colin Walters 2019-04-05 18:49:01 UTC
Hmm, did IoT drop polkit?  Looks like an rpm-ostree bug if we're not gracefully handling polkitd not being present.

Comment 2 Paul Whalen 2019-04-05 19:01:03 UTC
(In reply to Colin Walters from comment #1)
> Hmm, did IoT drop polkit?

Yes, polkit is missing from the current installation, but I dont think it was intentional.

Comment 3 Fabian Affolter 2019-05-19 22:07:57 UTC
Upgrading Fedora-IoT-ostree-x86_64-30-20190428.0.iso with rpm-ostree works for me.

Comment 4 Paul Whalen 2019-05-21 13:01:29 UTC
This is no longer and issue after pulling in polkit.


Note You need to log in before you can comment on or make changes to this bug.