Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1698217 - python3-cairocffi is missing dependency on python3-xcffib
Summary: python3-cairocffi is missing dependency on python3-xcffib
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-cairocffi
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Felix Schwarz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1685654 1731545
TreeView+ depends on / blocked
 
Reported: 2019-04-09 20:09 UTC by Florian Festi
Modified: 2019-11-28 01:31 UTC (History)
2 users (show)

Fixed In Version: python-cairocffi-0.9.0-4.fc31 python-cairocffi-0.9.0-3.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-28 01:10:58 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Florian Festi 2019-04-09 20:09:07 UTC
Description of problem:

Installing python3-cairocffi does not also install python3-xcffib

Version-Release number of selected component (if applicable):
python3-cairocffi-0.9.0-1.fc29.noarch

How reproducible:


Steps to Reproduce:
1. Install python3-cairocffi but not python3-xcffib
2. open python3 shell
3. import python3-cairocffi

Actual results:

Type "help", "copyright", "credits" or "license" for more information.
>>> import cairo
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ModuleNotFoundError: No module named 'cairo'
>>> import cairocffi
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python3.7/site-packages/cairocffi/__init__.py", line 18, in <module>
    from ._ffi import ffi
  File "/usr/lib/python3.7/site-packages/cairocffi/_ffi.py", line 3, in <module>
    from xcffib._ffi import ffi as _ffi0
ModuleNotFoundError: No module named 'xcffib'


Expected results:
The import works without error

Additional info:
Looks like there is a dependency on the python3-xcffib package is missing.

Comment 1 Felix Schwarz 2019-05-28 06:57:29 UTC
@Eric: Would you mind giving me commit access so I can fix that package?

Comment 2 Ben Cotton 2019-08-13 17:05:41 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 3 Ben Cotton 2019-08-13 18:54:48 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 4 Felix Schwarz 2019-11-03 22:56:05 UTC
Eric: ping (see comment 1)

This is getting annoying as I had to add a workaround also to python-cairosvg.

Comment 5 Felix Schwarz 2019-11-19 21:26:14 UTC
fixed in rawhide, will push updates for F30/F31.

Comment 6 Fedora Update System 2019-11-19 22:28:58 UTC
FEDORA-2019-f22c39b8ac has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-f22c39b8ac

Comment 7 Fedora Update System 2019-11-19 22:44:25 UTC
FEDORA-2019-183108b8e6 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-183108b8e6

Comment 8 Fedora Update System 2019-11-20 01:28:15 UTC
python-cairocffi-0.9.0-4.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-f22c39b8ac

Comment 9 Fedora Update System 2019-11-20 02:19:39 UTC
python-cairocffi-0.9.0-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-183108b8e6

Comment 10 Fedora Update System 2019-11-28 01:10:58 UTC
python-cairocffi-0.9.0-4.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2019-11-28 01:31:09 UTC
python-cairocffi-0.9.0-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.