Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1698920 - ifup/ifdown not part of the base install anymore (F30)
Summary: ifup/ifdown not part of the base install anymore (F30)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rkhunter
Version: 30
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-11 12:42 UTC by Kees de Jong
Modified: 2019-05-10 00:46 UTC (History)
3 users (show)

Fixed In Version: rkhunter-1.4.6-4.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-10 00:46:59 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Kees de Jong 2019-04-11 12:42:35 UTC
Description of problem:
The default config includes references to whitelist /sbin/ifup and /sbin/ifdown. These files are part of the package network-scripts, which has been deprecated in Fedora 30. The package network-scripts is not installed by default anymore. Therefore these files cannot be whitelisted by default, rkhunter fails when `rkhunter --propupd` is run.

Version-Release number of selected component (if applicable): rkhunter-1.4.6-3.fc30.noarch


Steps to Reproduce:
1. Install rkhunter with `dnf install rkhunter`
2. Then run `rkhunter --propupd`

Actual results:
Errors show up.
Invalid SCRIPTWHITELIST configuration option: Non-existent pathname: /sbin/ifup
Invalid SCRIPTWHITELIST configuration option: Non-existent pathname: /sbin/ifdown

Expected results:
The default config should be compatible with the base install.

Additional info:
It seems like network-scripts is deprecated since Fedora 29: https://utcc.utoronto.ca/~cks/space/blog/linux/NetworkScriptsAndPPPoE

The following lines should be removed from the rkhunter.conf
SCRIPTWHITELIST=/sbin/ifup
SCRIPTWHITELIST=/sbin/ifdown

Comment 1 Fedora Update System 2019-04-14 23:43:28 UTC
rkhunter-1.4.6-4.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-4ee312d293

Comment 2 Fedora Update System 2019-04-15 01:43:01 UTC
rkhunter-1.4.6-4.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-4ee312d293

Comment 3 Fedora Update System 2019-05-10 00:46:59 UTC
rkhunter-1.4.6-4.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.