Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1713281 - python3-saml fails to install due to broken dependency on defusedxml
Summary: python3-saml fails to install due to broken dependency on defusedxml
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python3-saml
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Jeremy Cline
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F31FailsToInstall PYTHON38
TreeView+ depends on / blocked
 
Reported: 2019-05-23 10:09 UTC by Miro Hrončok
Modified: 2019-07-10 11:45 UTC (History)
1 user (show)

Fixed In Version: python3-saml-1.6.0-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-10 11:45:57 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2019-05-23 10:09:14 UTC
Error: 
 Problem: conflicting requests
  - nothing provides python3.7dist(defusedxml) = 0.5.0 needed by python3-saml-1.3.0-4.fc30.noarch


https://github.com/onelogin/python3-saml/commit/064b7275fba1e5f39a9116ba1cdcc5d01fc34daa

I've updated defusedxml recently, there is no API change so it didn't cross my mind that somebody would pin a specific version of it.

This blocks the Python 3.8 rebuild of python-social-auth-core.


Note You need to log in before you can comment on or make changes to this bug.