Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1726286 - 20-zipl-kernel.install deletes /tmp when kernel-core is installed in s390x container image
Summary: 20-zipl-kernel.install deletes /tmp when kernel-core is installed in s390x co...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: s390utils
Version: 30
Hardware: s390x
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Horák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-02 13:46 UTC by Jakub Čajka
Modified: 2019-07-11 00:58 UTC (History)
2 users (show)

Fixed In Version: s390utils-2.9.0-3.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1778771 (view as bug list)
Environment:
Last Closed: 2019-07-11 00:58:00 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
[PATCH] - fix /tmp being deleted when kernel-core is installed in a container (#1726286) (deleted)
2019-07-02 14:21 UTC, Javier Martinez Canillas
no flags Details | Diff

Description Jakub Čajka 2019-07-02 13:46:39 UTC
Description of problem:
20-zipl-kernel.install deletes /tmp when kernel-core is installed in s390x container image after it gets invoked by kernel-install with 3rd parameter in format of /tmp/kernel-install.5GcCL

Version-Release number of selected component (if applicable):
s390utils-base-2.8.0-3.fc30.s390x

How reproducible:
Always

Steps to Reproduce:
1.Run fedora:30 container(podman run --rm -ti registry.fedoraproject.org/fedora:30 /bin/bash)
2.Run "dnf update" or "dnf distro-sync" in it
3.Run "dnf install kernel-core" in it
4.Run "mktemp" in it

Actual results:
$mktemp
mktemp: failed to create file via template ‘/tmp/tmp.XXXXXXXXXX’: No such file or directory
$ls /
bin  boot  dev  etc  home  lib  lib64  lost+found  media  mnt  opt  proc  root  run  sbin  srv  sys  usr  var

Expected results:
$mktemp
/tmp/tmp.c0aVsVxDMe
$ls /
bin  boot  dev  etc  home  lib  lib64  lost+found  media  mnt  opt  proc  root  run  sbin  srv  sys  tmp  usr  var

Comment 2 Javier Martinez Canillas 2019-07-02 14:21:52 UTC
Created attachment 1586726 [details]
[PATCH] - fix /tmp being deleted when kernel-core is installed in a  container (#1726286)

I've provided a patch to fix this issue. Could you please test it?

There's also a s390utils-2.8.0-4.fc30 scratch build here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=36003888

Comment 3 Jakub Čajka 2019-07-02 14:41:49 UTC
(In reply to Javier Martinez Canillas from comment #2)
> Created attachment 1586726 [details]
> [PATCH] - fix /tmp being deleted when kernel-core is installed in a 
> container (#1726286)
> 
> I've provided a patch to fix this issue. Could you please test it?
> 
> There's also a s390utils-2.8.0-4.fc30 scratch build here:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=36003888

Works for me in the container. Thanks for quick fix :).

Comment 4 Fedora Update System 2019-07-02 15:43:22 UTC
FEDORA-2019-bfc68ba177 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-bfc68ba177

Comment 5 Fedora Update System 2019-07-03 02:27:01 UTC
s390utils-2.9.0-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-bfc68ba177

Comment 6 Fedora Update System 2019-07-11 00:58:00 UTC
s390utils-2.9.0-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.