Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1731186 - [ppc64le/ipc] firefox-wayland display hang
Summary: [ppc64le/ipc] firefox-wayland display hang
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 30
Hardware: ppc64le
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ffwayland
TreeView+ depends on / blocked
 
Reported: 2019-07-18 14:40 UTC by Jonathan Briggs
Modified: 2019-11-27 09:41 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-27 09:41:26 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Jonathan Briggs 2019-07-18 14:40:02 UTC
Description of problem:
On this Power9 system firefox-wayland used to work well on gnome-shell. Some time in the last week or two it stopped working. Now firefox-wayland content does not display anything. The browser frame with the buttons, menus, bookmarks, etc, still works, but no content.

Sometimes if I wait for many minutes and alt-tab back to the firefox-wayland window, content will flash, then vanish again.

Version-Release number of selected component (if applicable):
firefox-wayland-67.0.4-1.fc30.ppc64le
gnome-shell-3.32.2-2.fc30.ppc64le
0030:01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon Pro WX 7100]

How reproducible:
Always

Steps to Reproduce:
1. Log into a Wayland Gnome session on a Power9 with Radeon GPU.
2. Start firefox-wayland
3. Load google.com

Actual results:
A white screen with no contents.

Expected results:
Google's home page

Additional info:
Browser does appear to load the page over the network. It just never displays it.

Same software versions seem to work on AMD64 with Radeon GPU in Wayland.

Comment 1 Martin Stransky 2019-07-23 07:04:19 UTC
Do in-process pages work? (about:support, about:config)? Do menus work? You can try to disable e10s by setting browser.tabs.remote.autostart to false at about:config.

Comment 2 Jonathan Briggs 2019-07-23 13:33:16 UTC
about: pages all seem to work.
Disabling remote.autostart did make it work. Pages seem to render just fine without e10s.

Comment 3 Martin Stransky 2019-07-23 13:49:54 UTC
Looks like IPC issue - can you check your security/audit logs if there's anything related? May be also selinux issue.

Comment 4 Jonathan Briggs 2019-07-23 14:18:29 UTC
Nothing in there about selinux. There's many of these:

{
        "_TRANSPORT" : "stdout",
        "_SYSTEMD_USER_SLICE" : "-.slice",
        "SYSLOG_IDENTIFIER" : "firefox.desktop",
        "PRIORITY" : "6",
        "_AUDIT_LOGINUID" : "1000",
        "_AUDIT_SESSION" : "45",
        "_SYSTEMD_UNIT" : "session-45.scope",
        "_HOSTNAME" : "power.zlynx.org",
        "_SYSTEMD_CGROUP" : "/user.slice/user-1000.slice/session-45.scope",
        "_COMM" : "gnome-shell",
        "_SELINUX_CONTEXT" : "unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023",
        "_SYSTEMD_INVOCATION_ID" : "d0c0103b222f4956850fac0bb677ef3c",
        "_MACHINE_ID" : "4cacafa8a07f455fa9c84d6cf1a02751",
        "_STREAM_ID" : "3960cd3f53604be29e338ea628e932a4",
        "__MONOTONIC_TIMESTAMP" : "5650708392151",
        "_CAP_EFFECTIVE" : "0",
        "_PID" : "11965",
        "_UID" : "1000",
        "__CURSOR" : "s=c96c7a6b377849b1ab08348150de6e92;i=184aa4;b=cd12f40079244b37a71cd03333d265d5;m=523a87768d7;t=58e592c528456;x=5b902e7435d43a7a",
        "_SYSTEMD_SLICE" : "user-1000.slice",
        "_EXE" : "/usr/bin/gnome-shell",
        "_SYSTEMD_OWNER_UID" : "1000",
        "MESSAGE" : "###!!! [Child][MessageChannel] Error: (msgtype=0x530005,name=PHttpChannel::Msg_Cancel) Closed channel: cannot send/recv",
        "_GID" : "1000",
        "_CMDLINE" : "/usr/bin/gnome-shell",
        "_BOOT_ID" : "cd12f40079244b37a71cd03333d265d5",
        "_SYSTEMD_SESSION" : "45",
        "__REALTIME_TIMESTAMP" : "1563888530392150"
}

Comment 5 Martin Stransky 2019-11-05 13:48:55 UTC
Can you please try Fedora 31? Thanks.

Comment 6 Jonathan Briggs 2019-11-11 05:37:48 UTC
(In reply to Martin Stransky from comment #5)
> Can you please try Fedora 31? Thanks.

Sorry, can't right now. Attempted to update to Fedora 31 but my Talos II is now refusing to boot both CPUs. Thought that had been fixed, but obviously not.

I'll let you know how it goes once I can get things updated.

Comment 7 Jonathan Briggs 2019-11-27 02:30:16 UTC
(In reply to Martin Stransky from comment #5)
> Can you please try Fedora 31? Thanks.

Using firefox-wayland-70.0.1-4.fc31.ppc64le and launching with the Firefox On Wayland launcher icon from gnome-shell, this appears to be working fine now.

Comment 8 Martin Stransky 2019-11-27 09:41:26 UTC
Thanks, closing then.


Note You need to log in before you can comment on or make changes to this bug.