Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1741699 - Build wxGTK 3.0 for EPEL8
Summary: Build wxGTK 3.0 for EPEL8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: wxGTK3
Version: epel8
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Scott Talbert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1741915 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-15 20:58 UTC by Orion Poplawski
Modified: 2019-09-02 01:19 UTC (History)
5 users (show)

Fixed In Version: wxGTK3-3.0.4-10.el8.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-02 01:19:03 UTC
Type: Bug


Attachments (Terms of Use)

Description Orion Poplawski 2019-08-15 20:58:46 UTC
Description of problem:

Let's get wxGTK 3.0.X into EPEL8.  I would suggest creating a new wxGTK3.0 package to allow for packaging multiple versions considering the long lifespan of RHEL8.  This can be done without a full package review via the exception process.

I did a scratch build of current here: https://koji.fedoraproject.org/koji/taskinfo?taskID=37061851  

Unfortunately RHEL8.0 is not providing various GUI libraries (namely webkit2gtk3-devel) on aarch64 and s390x so we will need to ExcludeArch those.

Comment 1 Scott Talbert 2019-08-15 21:15:33 UTC
(In reply to Orion Poplawski from comment #0)
> Let's get wxGTK 3.0.X into EPEL8.  I would suggest creating a new wxGTK3.0
> package to allow for packaging multiple versions considering the long
> lifespan of RHEL8.  This can be done without a full package review via the
> exception process.

Unless you feel strongly about it, I'm inclined to use the existing wxGTK3 name since that's what people are used to on Fedora and the other EPEL's.  IF we ever do a renaming in Fedora, I'd say we can do the same in EL too.

> Unfortunately RHEL8.0 is not providing various GUI libraries (namely
> webkit2gtk3-devel) on aarch64 and s390x so we will need to ExcludeArch those.

Thanks for the heads-up on that.

Comment 2 Orion Poplawski 2019-08-15 21:42:18 UTC
I really don't have a strong preference, but I think it gives you a lot more flexibility.  It can always "Provide: wxGTK3" for compatibility.  It's your package though, you can decide.  But 10 years is a long time :).

Comment 3 Scott Talbert 2019-08-16 13:04:45 UTC
*** Bug 1741915 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2019-08-17 14:07:32 UTC
FEDORA-EPEL-2019-a44a523f63 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-a44a523f63

Comment 5 Fedora Update System 2019-08-18 01:27:46 UTC
wxGTK3-3.0.4-10.el8.1 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-a44a523f63

Comment 6 Phil Wyett 2019-08-19 09:38:00 UTC
Package is -10.el8.1' when really should be '-10.1.el8' '.1' wrong side of dust tag?

Comment 7 Scott Talbert 2019-08-19 13:13:31 UTC
(In reply to Phil Wyett from comment #6)
> Package is -10.el8.1' when really should be '-10.1.el8' '.1' wrong side of
> dust tag?

I just did it that way because it seemed that's what Smooge was doing with all the other epel8 packages.  I suppose it is per this policy:
https://docs.fedoraproject.org/en-US/packaging-guidelines/Versioning/#_you_need_to_change_an_old_branch_without_rebuilding_the_others

But it probably isn't necessary, since there is no upgrade path from Fedora's to EL.

Comment 8 Fedora Update System 2019-09-02 01:19:03 UTC
wxGTK3-3.0.4-10.el8.1 has been pushed to the Fedora EPEL 8 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.