Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1746841 - condor fails to build with Python 3.8 on Fedora 32+
Summary: condor fails to build with Python 3.8 on Fedora 32+
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: condor
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Tim Theisen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F32FTBFS F32FailsToInstall PYTHON38
TreeView+ depends on / blocked
 
Reported: 2019-08-29 11:35 UTC by Miro Hrončok
Modified: 2021-07-26 12:55 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-05 22:54:05 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2019-08-29 11:35:27 UTC
condor fails to build with Python 3.8.0b3 in Fedora 32.

See the build failures at https://koji.fedoraproject.org/koji/search?match=glob&type=package&terms=condor

BUILDSTDERR: CMake Error: failed to create symbolic link '/usr/bosco_install': permission denied
BUILDSTDERR: CMake Error: failed to create symbolic link '/usr/condor_install': permission denied
BUILDSTDERR: CMake Error: failed to create symbolic link '/usr/condor_configure': permission denied
...
BUILDSTDERR: mkdir: cannot create directory '/usr/lib/condor': Permission denied
BUILDSTDERR: chmod: cannot access '/usr/lib/condor/': No such file or directory
...
BUILDSTDERR: mkdir: cannot create directory '/usr/lib/condor': Permission denied
BUILDSTDERR: cp: cannot create regular file '/usr/lib/condor': Permission denied
BUILDSTDERR: cp: cannot create regular file '/usr/lib/condor': Permission denied
BUILDSTDERR: cp: cannot create regular file '/usr/lib/condor': Permission denied
BUILDSTDERR: cp: cannot create regular file '/usr/lib/condor': Permission denied
BUILDSTDERR: chmod: cannot access '/usr/lib/condor/': No such file or directory
...
BUILDSTDERR: mv: cannot stat '/builddir/build/BUILDROOT/condor-8.8.4-2.fc32.x86_64//usr/share/condor/libpy3classad3.7_8_8_4.so': No such file or directory


It is not important whether the problem is relevant to Python 3.8, this issue is blocking the Python 3.8 rebuilds.
If this package won't build with 3.8, it won't be installable, along with all its dependent packages, in Fedora 32 and further.

Furthermore, as it fails to install, its dependent packages will fail to install and/or build as well.

Please rebuild the package in Fedora 32 (rawhide).

Let us know here if you have any questions. Thank You!

Comment 1 Tim Theisen 2019-10-05 22:54:05 UTC
I have removed the python2 dependencies on the f32 branch. HTCondor now builds properly with Python 3.8.

Comment 2 Petr Viktorin (pviktori) 2019-10-07 09:09:49 UTC
Thank you!


Note You need to log in before you can comment on or make changes to this bug.