Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1752263 - SELinux is preventing rtkit-daemon from 'sys_ptrace' accesses on the cap_userns labeled rtkit_daemon_t
Summary: SELinux is preventing rtkit-daemon from 'sys_ptrace' accesses on the cap_user...
Keywords:
Status: CLOSED DUPLICATE of bug 1750024
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-15 12:22 UTC by Michael Chapman
Modified: 2019-09-16 08:10 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-16 08:10:46 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Michael Chapman 2019-09-15 12:22:54 UTC
This SELinux alert was reported in bug 1723308 for F30, but it's hitting F29 as well. Any chance for an updated package for F29 as well?

-----

SELinux is preventing rtkit-daemon from sys_ptrace access on the cap_userns labeled rtkit_daemon_t.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that rtkit-daemon should be allowed sys_ptrace access on cap_userns labeled rtkit_daemon_t by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'rtkit-daemon' --raw | audit2allow -M my-rtkitdaemon
# semodule -X 300 -i my-rtkitdaemon.pp

Additional Information:
Source Context                system_u:system_r:rtkit_daemon_t:s0
Target Context                system_u:system_r:rtkit_daemon_t:s0
Target Objects                Unknown [ cap_userns ]
Source                        rtkit-daemon
Source Path                   rtkit-daemon
Port                          <Unknown>
Host                          beren.home
Source RPM Packages           
Target RPM Packages           
Policy RPM                    <Unknown>
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     beren.home
Platform                      Linux beren.home 5.2.13-100.fc29.x86_64 #1 SMP Fri
                              Sep 6 14:43:49 UTC 2019 x86_64 x86_64
Alert Count                   30
First Seen                    2019-09-15 22:04:27 AEST
Last Seen                     2019-09-15 22:11:24 AEST
Local ID                      9bdccf7f-5f0e-4ced-9251-b9cfe7a4a119

Raw Audit Messages
type=AVC msg=audit(1568549484.736:476): avc:  denied  { sys_ptrace } for  pid=2041 comm="rtkit-daemon" capability=19  scontext=system_u:system_r:rtkit_daemon_t:s0 tcontext=system_u:system_r:rtkit_daemon_t:s0 tclass=cap_userns permissive=0


Hash: rtkit-daemon,rtkit_daemon_t,rtkit_daemon_t,cap_userns,sys_ptrace

Comment 1 Lukas Vrabec 2019-09-16 08:10:46 UTC

*** This bug has been marked as a duplicate of bug 1750024 ***


Note You need to log in before you can comment on or make changes to this bug.