Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1766814 - singularity-3.5.0 is available
Summary: singularity-3.5.0 is available
Keywords:
Status: CLOSED DUPLICATE of bug 1777565
Alias: None
Product: Fedora
Classification: Fedora
Component: singularity
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dave Dykstra
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-30 00:36 UTC by Upstream Release Monitoring
Modified: 2020-01-04 20:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-27 21:16:26 UTC
Type: ---


Attachments (Terms of Use)

Description Upstream Release Monitoring 2019-10-30 00:36:17 UTC
Latest upstream release: 3.5.0-rc.1
Current version/release in rawhide: 3.4.2-1.1.fc32
URL: https://github.com/sylabs/singularity/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/10920/

Comment 1 Upstream Release Monitoring 2019-11-13 17:40:51 UTC
Latest upstream release: 3.5.0
Current version/release in rawhide: 3.5.0~rc.2-1.fc32
URL: https://github.com/sylabs/singularity/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/10920/

Comment 2 Fedora Update System 2019-11-20 18:52:12 UTC
FEDORA-EPEL-2019-d70eb8987e has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-d70eb8987e

Comment 3 Dave Dykstra 2019-11-20 19:00:13 UTC
3.5.0 is already in testing for these releases (I forgot to link this bug to them):
el6: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-9301358df3
el7: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-f6587c90ec
fc31: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a1e4cdb6f6
And in rawhide
rawhide: https://bodhi.fedoraproject.org/updates/FEDORA-2019-267aeec82e

It did not build in fc29 and fc30 because of a lack of golang-1.13.  el8 had the same problem, but I applied a patch to revert that to golang-1.11 in a singularity-3.5.0-1.1.  A side effect of that is that the plugin system will be broken.  I don't think it's worth doing the same for the older Fedora releases.

Having done all that, there have been significant other bugs found in the upstream 3.5.0, so I do not plan to promote 3.5.0 to stable.  A 3.5.1 is expected soon.

Comment 4 Fedora Update System 2019-11-21 02:43:08 UTC
singularity-3.5.0-1.1.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-d70eb8987e

Comment 5 Dave Dykstra 2019-11-27 21:16:26 UTC
Superceded by #1777565

*** This bug has been marked as a duplicate of bug 1777565 ***

Comment 6 Fedora Update System 2019-12-05 18:31:02 UTC
FEDORA-EPEL-2019-e3cdc4c5bf has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-e3cdc4c5bf

Comment 7 Fedora Update System 2019-12-07 03:04:14 UTC
singularity-3.5.1-1.1.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-e3cdc4c5bf

Comment 8 Fedora Update System 2019-12-18 00:10:08 UTC
singularity-3.5.2-1.1.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-f1206dff97

Comment 9 Fedora Update System 2020-01-04 20:08:11 UTC
singularity-3.5.2-1.1.el8 has been pushed to the Fedora EPEL 8 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.