Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1770535 - [abrt] gnome-shell: meta_window_get_work_area_for_logical_monitor(): gnome-shell killed by SIGABRT
Summary: [abrt] gnome-shell: meta_window_get_work_area_for_logical_monitor(): gnome-sh...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1765537 1767703 1768485 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-10 10:42 UTC by Jonas Ådahl
Modified: 2019-11-15 03:01 UTC (History)
8 users (show)

Fixed In Version: mutter-3.34.1-9.fc31 mutter-3.34.1-11.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-15 03:01:51 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Jonas Ådahl 2019-11-10 10:42:39 UTC
This bug was initially created as a copy of Bug #1767703


Description of problem:
Intel NUC8i7BEH, connected via DisplayPort (Thunderbolt port) to Dell UP2516D monitor, in turn connected via DisplayPort to another Dell UP2516D monitor.

The primary monitor utilizes a KVM feature; USB cable connects from machine to monitor and mouse, keyboard and audio are directly connected to the monitor.  Another PC is also connected to the monitor via USB.

Steps to reproduce:
1.  With above configuration and Gnome Shell open, use monitor controls to change display/KVM input to another PC

This behavior is reproduceable and can be worked around by first locking the PC before changing display input.

I have updated to the latest BIOS firmware available from Intel, this did not resolve the behavior.

Version-Release number of selected component:
gnome-shell-3.34.1-2.fc31

Additional info:
reporter:       libreport-2.10.1
backtrace_rating: 4
cgroup:         0::/user.slice/user-1000.slice/user/gnome-shell-wayland.service
cmdline:        /usr/bin/gnome-shell
crash_function: meta_window_get_work_area_for_logical_monitor
executable:     /usr/bin/gnome-shell
journald_cursor: s=768e5b5ce8f947869caeb0e84fa421b5;i=85ac1;b=752a4670e4834aea971f995aa0f9cc73;m=4f5c4542;t=59642a2a06d5a;x=eaa3ec44aab36486
kernel:         5.3.7-301.fc31.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 1 Jonas Ådahl 2019-11-10 10:43:43 UTC
*** Bug 1767703 has been marked as a duplicate of this bug. ***

Comment 2 Jonas Ådahl 2019-11-10 10:44:33 UTC
*** Bug 1768485 has been marked as a duplicate of this bug. ***

Comment 3 Jonas Ådahl 2019-11-11 15:44:20 UTC
*** Bug 1765537 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2019-11-11 16:14:09 UTC
FEDORA-2019-c9e297f88f has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-c9e297f88f

Comment 5 Fedora Update System 2019-11-12 11:01:51 UTC
FEDORA-2019-4c65e7710a has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-4c65e7710a

Comment 6 Fedora Update System 2019-11-13 04:56:36 UTC
gnome-shell-3.34.1-3.fc31, mutter-3.34.1-9.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-c9e297f88f

Comment 7 Fedora Update System 2019-11-13 10:52:26 UTC
gnome-shell-3.34.1-4.fc31, mutter-3.34.1-11.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-4c65e7710a

Comment 8 Fedora Update System 2019-11-15 03:01:51 UTC
gnome-shell-3.34.1-4.fc31, mutter-3.34.1-11.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.