Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1770540 - [abrt] gnome-shell: set_workspace_state(): gnome-shell killed by SIGABRT
Summary: [abrt] gnome-shell: set_workspace_state(): gnome-shell killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1759244 1768228 1768229 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-10 10:57 UTC by Jonas Ådahl
Modified: 2019-11-15 03:01 UTC (History)
7 users (show)

Fixed In Version: mutter-3.34.1-9.fc31 mutter-3.34.1-11.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-15 03:01:48 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME/mutter/merge_requests/895 0 None None None 2019-11-10 10:59:00 UTC

Description Jonas Ådahl 2019-11-10 10:57:21 UTC
This bug was initially created as a copy of Bug #1768229



Version-Release number of selected component:
gnome-shell-3.34.1-2.fc31

Additional info:
reporter:       libreport-2.10.1
backtrace_rating: 4
cgroup:         0::/user.slice/user-1000.slice/user/gnome-shell-x11.service
cmdline:        /usr/bin/gnome-shell
crash_function: set_workspace_state
executable:     /usr/bin/gnome-shell
journald_cursor: s=aaab50d7328f4df48596ea1f7f189d5b;i=449d;b=f4398330de134827a6df481ceb329b3e;m=24eedee9;t=59672694b710e;x=5a685746d5d50f5f
kernel:         5.3.7-301.fc31.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 0 (10 frames)
 #7 set_workspace_state at ../src/core/window.c:4822
 #8 _meta_window_shared_new at ../src/core/window.c:1309
 #9 meta_window_x11_new at ../src/x11/window-x11.c:3481
 #10 handle_other_xevent at ../src/x11/events.c:1407
 #11 meta_x11_display_handle_xevent at ../src/x11/events.c:1857
 #12 xevent_filter at ../src/x11/events.c:1899
 #13 gdk_event_apply_filters at gdkeventsource.c:79
 #14 gdk_event_source_translate_event at gdkeventsource.c:198
 #15 _gdk_x11_display_queue_events at gdkeventsource.c:341
 #16 gdk_display_get_event at gdkdisplay.c:441

This is a private, duplicate bug report of bug 1768228. The report has been created because Bugzilla cannot grant access to a comment for a specific group.

Comment 1 Jonas Ådahl 2019-11-10 10:59:27 UTC
*** Bug 1768229 has been marked as a duplicate of this bug. ***

Comment 2 Jonas Ådahl 2019-11-10 11:00:23 UTC
*** Bug 1768228 has been marked as a duplicate of this bug. ***

Comment 3 Jonas Ådahl 2019-11-10 11:01:15 UTC
*** Bug 1759244 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2019-11-11 16:14:05 UTC
FEDORA-2019-c9e297f88f has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-c9e297f88f

Comment 5 Fedora Update System 2019-11-12 11:00:26 UTC
FEDORA-2019-4c65e7710a has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-4c65e7710a

Comment 6 Fedora Update System 2019-11-13 04:56:34 UTC
gnome-shell-3.34.1-3.fc31, mutter-3.34.1-9.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-c9e297f88f

Comment 7 Fedora Update System 2019-11-13 10:52:23 UTC
gnome-shell-3.34.1-4.fc31, mutter-3.34.1-11.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-4c65e7710a

Comment 8 Fedora Update System 2019-11-15 03:01:48 UTC
gnome-shell-3.34.1-4.fc31, mutter-3.34.1-11.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.