Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1770783 - multicomponent wwsympa_url with mod_proxy_fcgi is broken
Summary: multicomponent wwsympa_url with mod_proxy_fcgi is broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: sympa
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Xavier Bachelot
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-11 10:48 UTC by debugitu
Modified: 2020-06-11 18:53 UTC (History)
2 users (show)

Fixed In Version: sympa-6.2.56-1.fc31 sympa-6.2.56-1.fc32 sympa-6.2.56-1.el6 sympa-6.2.56-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-02 03:13:27 UTC
Type: Bug


Attachments (Terms of Use)

Description debugitu 2019-11-11 10:48:42 UTC
Description of problem:

Customizing the wwsympa_url in /etc/sympa/sympa.conf and in /etc/httpd/conf.d/sympa.conf breaks the web access using multiple component local path when using mod_proxy_fcgi.

For example, when using http://host.domain/aa/bb as value for wwsympa_url we get syslog message: wwsympa[pid_num]: info main:: ... "Unknown action bb" and pop-up message on the web interface: ERROR(bb) - unknown action


Version-Release number of selected component (if applicable):

It is mod_proxy_fcgi specific issue. It is not broken with mod_fcgid.


How reproducible:


Steps to Reproduce:
1.
Change and enable variable of wwsympa_url in /etc/sympa/sympa.conf like:
< #wwsympa_url         (You must define this parameter to enable web interface)
---
> wwsympa_url         http://host.domain/aa/bb
2.
Update /etc/httpd/conf.d/sympa.conf:

--- sympa.conf.orig	2019-10-16 19:01:34.000000000 +0200
+++ sympa.conf	2019-11-11 11:31:00.442563893 +0100
@@ -9,11 +9,11 @@
 ## Definition of Sympa FastCGI server.
 <IfModule mod_proxy_fcgi.c>
     # If you changed wwsympa_url in sympa.conf, change this path too.
-    <Location /sympa>
+    <Location /aa/bb>
         SetHandler "proxy:unix:/var/run/sympa/wwsympa.socket|fcgi://"
         # Don't forget to edit lines below!
         Require local
-        #Require all granted
+        Require all granted
     </Location>
 
 #    # You may uncomment following lines to enable SympaSOAP feature.


3.

Restart wwsympa and httpd with
systemctl restart wwsympa.service
systemclt reload httpd.service

Actual results:

syslog message: wwsympa[pid_num]: info main:: ... "Unknown action bb"
pop-up message on the web interface: ERROR(bb) - unknown action

Expected results:

No "Unknown action bb" syslog message
No pop-up message on the web interface. The web interface keeps working with /aa/bb local path.


Additional info:

Comment 1 Xavier Bachelot 2020-03-03 16:24:07 UTC
It looks like this may be fixed in sympa 6.2.54.
https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-471d8a7abd

Could you please test and report back ?

Comment 2 debugitu 2020-03-04 11:21:38 UTC
I just tested again, the release 6.2.54 did not fix.

There is a reference for that bug at
https://github.com/sympa-community/sympa/issues/879

In that issue there is no milestone, no assignee, no pull request
at the time of writing this. It looks like the issue is still pending.

Comment 3 Xavier Bachelot 2020-03-04 11:31:18 UTC
Thanks for testing.
In https://github.com/sympa-community/sympa/issues/879 there's a reference to https://github.com/sympa-community/sympa/issues/876 which was closed with https://github.com/sympa-community/sympa/pull/885 which is in sympa 6.2.54. This made me think this may have been fixed, but unfortunately is not yet.
As this is most probably not a packaging issue, could you please follow up in the upstream bug at https://github.com/sympa-community/sympa/issues/879 ?

Comment 4 debugitu 2020-03-04 11:36:35 UTC
Sure, I will follow-up the upstream bug, already subscribed.
However, I am using only the EPEL package version of sympa,
I cannot verify its reproducibility with different packaging.

Comment 5 Xavier Bachelot 2020-03-04 12:52:34 UTC
No worries, I'll make sure to backport the fix for this bug in the Fedora/EPEL package as soon as there is one and make a build available for you to test.

Comment 6 debugitu 2020-03-04 13:14:03 UTC
Thank you in advance!

Comment 7 IKEDA Soji 2020-03-07 01:47:05 UTC
This issue was forwarded to upstream:
  GitHub sympa-community/sympa#879 <https://github.com/sympa-community/sympa/issues/879>.

Comment 8 debugitu 2020-03-12 12:25:21 UTC
Hi Xavier,

Is it possible to have a new CentOS7 test package with this patch:
https://github.com/sympa-community/sympa/commit/f71abf8d535c494320afd24a157db5de9079970d.patch ?

Comment 9 Fedora Update System 2020-05-24 16:12:47 UTC
FEDORA-EPEL-2020-05b9f2eac5 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-05b9f2eac5

Comment 10 Fedora Update System 2020-05-24 16:12:49 UTC
FEDORA-2020-9b6c969aac has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-9b6c969aac

Comment 11 Fedora Update System 2020-05-24 16:12:50 UTC
FEDORA-2020-029901598c has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-029901598c

Comment 12 Fedora Update System 2020-05-25 03:55:39 UTC
FEDORA-2020-9b6c969aac has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-9b6c969aac`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-9b6c969aac

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2020-05-25 04:10:37 UTC
FEDORA-2020-d767d9077b has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-d767d9077b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-d767d9077b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2020-05-25 04:12:01 UTC
FEDORA-EPEL-2020-05b9f2eac5 has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-05b9f2eac5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Fedora Update System 2020-05-25 04:17:48 UTC
FEDORA-2020-029901598c has been pushed to the Fedora 30 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-029901598c`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-029901598c

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2020-05-25 04:18:01 UTC
FEDORA-EPEL-2020-ffaa79c364 has been pushed to the Fedora EPEL 6 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-ffaa79c364

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Fedora Update System 2020-06-02 03:13:27 UTC
FEDORA-2020-9b6c969aac has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 18 Fedora Update System 2020-06-07 19:46:35 UTC
FEDORA-2020-d767d9077b has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 19 Fedora Update System 2020-06-11 18:43:54 UTC
sympa-6.2.56-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2020-06-11 18:53:42 UTC
sympa-6.2.56-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.