Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1775789 - perl-Fsdb for epel8
Summary: perl-Fsdb for epel8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: perl-Fsdb
Version: epel8
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: John Heidemann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1775788 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-22 19:48 UTC by John Heidemann
Modified: 2019-12-14 01:01 UTC (History)
3 users (show)

Fixed In Version: perl-Fsdb-2.69-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-26 06:58:10 UTC
Type: Bug


Attachments (Terms of Use)

Description John Heidemann 2019-11-22 19:48:31 UTC
Description of problem:

perl-Fsdb is on epel7, but not epel8
8 is the New Hotness.

Version-Release number of selected component (if applicable):
perl-Fsdb-2.69-2 should build on epel8

How reproducible:
every time


Steps to Reproduce:
1.fedpkg switch-branch epel8
2.
3.

Actual results:
Could not execute switch_branch: Unknown remote branch origin/epel8


Expected results:
Switched to branch 'epel8'


Additional info:
It seems like a shame this action requires opening a ticket.

Comment 1 John Heidemann 2019-11-22 19:51:28 UTC
fedpkg request-repo  epel8 1775789

fails with

Could not execute request_repo: The Bugzilla bug provided is not the proper type


It's unclear how I get epel8 added :-(

Comment 2 John Heidemann 2019-11-22 19:54:48 UTC
*** Bug 1775788 has been marked as a duplicate of this bug. ***

Comment 3 Paul Howarth 2019-11-23 15:21:42 UTC
Request the branch as follows from your existing checkout of perl-Fsdb:

  fedpkg request-branch epel8

You don't need to specify a bugzilla ticket as this is not a new (to Fedora/EPEL) package.

Comment 4 John Heidemann 2019-11-24 00:11:34 UTC
Thanks, Paul.

However, fedpkg request-branch epel8
gives

Could not execute request_branch: The following error occurred while creating a new issue in Pagure: Invalid or expired token. Please visit https://pagure.io/settings#nav-api-tab to get or renew your API token.
For invalid or expired token refer to "fedpkg request-repo -h" to set a token in your user configuration.
Could not execute request_branch: The following error occurred while creating a new issue in Pagure: Invalid or expired token. Please visit https://pagure.io/settings#nav-api-tab to get or renew your API token.
For invalid or expired token refer to "fedpkg request-repo -h" to set a token in your user configuration.

which seems to suggest I do

fedpkg request-repo epel8 1775789

Which leads back to the error message I reported in comment 1.

What am I doing wrong?

Comment 5 Paul Howarth 2019-11-24 10:42:09 UTC
No, it's saying you've got an expired Pagure token.

Get a new token from https://pagure.io/settings/token/new (I usually tick all the boxes) and it goes in ~/.config/rpkg/fedpkg.conf

Then try the fedpkg request without the ticket number again.

Comment 6 John Heidemann 2019-11-25 01:51:00 UTC
Thanks.  I had a non-expired token that I got for this purpose.
But at your prompting I got a new token and also chmod'ed the fedpkg.conf go-rwx.  One of those two things fixed it and seems to have created two tickets in fedora-scm-requests.

I guess that means that this ticket was not needed (other than to get me to retry that step)?

Comment 7 Paul Howarth 2019-11-25 07:24:52 UTC
Well now that you have this ticket you can reference it in the update for the EPEL-8 package when you've built it.

Comment 8 John Heidemann 2019-11-26 06:58:10 UTC
Yes, thank you very much.  Epel8 should now be active.

Comment 9 John Heidemann 2019-11-26 06:58:26 UTC
Yes, thank you very much.  Epel8 should now be active.

Comment 10 Paul Howarth 2019-11-27 09:46:35 UTC
You still need to submit an update to get the package into epel8, just the same as you will have done for epel7.

The separate build for epel8-playground does not need an update.

Comment 11 Fedora Update System 2019-11-28 04:58:11 UTC
FEDORA-EPEL-2019-bb03499a53 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-bb03499a53

Comment 12 John Heidemann 2019-11-28 04:59:56 UTC
Thank you for the prompt in comment 10.  Should now be closed.

Comment 13 Fedora Update System 2019-11-29 03:37:32 UTC
perl-Fsdb-2.69-1.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-bb03499a53

Comment 14 Fedora Update System 2019-12-14 01:01:49 UTC
perl-Fsdb-2.69-1.el8 has been pushed to the Fedora EPEL 8 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.