Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1775896 - drop-down menus do not work/open!
Summary: drop-down menus do not work/open!
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 31
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: Jan Horak
QA Contact: Fedora Extras Quality Assurance
Depends On:
Blocks: ffwayland
TreeView+ depends on / blocked
Reported: 2019-11-23 12:04 UTC by lejeczek
Modified: 2019-12-06 15:23 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2019-12-06 15:23:40 UTC
Type: Bug

Attachments (Terms of Use)

Description lejeczek 2019-11-23 12:04:39 UTC
Description of problem:

eg. site with does not work for me is Amazon's.

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:

Actual results:

Expected results:

Additional info:

Comment 1 Florian Bezdeka 2019-11-25 09:27:14 UTC
Looks like the mobile version had the same problem:

Comment 2 Martin Stransky 2019-11-25 09:31:02 UTC
Jan, can you look at it please? Thanks.

Comment 3 Ejner Fergo 2019-11-25 14:06:41 UTC
Same issue here, using firefox-70.0.1-4.fc31.x86_64 on Wayland

Standard html dropdown not working, such as this example:

Have not tried under Xorg yet.

Comment 4 blackenbrew 2019-11-29 20:57:47 UTC
Was opening a new ticket then saw this. My findings listed below:

Description of problem: Dropdown menus not working

Version-Release number of selected component (if applicable): Fedora 31, Firefox 70.0.1-4

How reproducible: Always

Steps to Reproduce:
1. Open a website with dropdowns
2. Try to click a dropdown- no menu is shown
3. Menu still works though if using arrow keys to get to next/previous selection

Actual results:
No dropdown menu shown

Expected results:
Show a dropdown menu that can let you click on appropriate choice

Additional info:
- Fedora 31 box that was upgraded from Firefox 30
- Refreshed Firefox, no change
- Changed gfx.webrender.(enabled|all) to true, also no change with bug
- Same result on sites with both insecure (self-signed) sites AND normal sites
- Fedora is currently using Wayland environment
- AMD video card (R9 270 I believe) if that matters

Will try to report later if noticing issues on a laptop I have with intel chipset (no external graphics card)

Comment 5 blackenbrew 2019-11-30 02:02:48 UTC
Can add this:

Cannot reproduce on a system with:
- fresh install of Fedora 31 beta updated fully to today (running wayland)
- Firefox 70.0.1-4
- intel chipset (no external video- stock driver then)
- same add-ons as above machine (so add-ons shouldn't play a part)
- same extensions as above
- no change of stock gfx.webrender.xxxx

Comment 6 Matthias Runge 2019-12-02 09:22:49 UTC
Another observation: when starting a new instance, <selects> work, just leaving the page open for some time (under 10 mins), the list does not pop up anymore.

Comment 7 Matthias Runge 2019-12-02 10:01:58 UTC
(In reply to Matthias Runge from comment #6)
> Another observation: when starting a new instance, <selects> work, just
> leaving the page open for some time (under 10 mins), the list does not pop
> up anymore.

The issue can not be reproduced in safe-mode.

Comment 8 Ejner Fergo 2019-12-05 09:56:41 UTC
Looks like dropdown works again in Firefox 71

Comment 9 blackenbrew 2019-12-05 12:41:07 UTC
Can confirm that after updating to firefox-71.0-8.npgo dropdowns are good. Thanks!

Comment 10 Florian Bezdeka 2019-12-06 09:18:51 UTC
Can confirm as well that after updating to Firefox 71 the dropdowns are working again.

Comment 11 lejeczek 2019-12-06 15:22:19 UTC
The reporter here - 71 version looks good and drop-down menus work for me too.

Comment 12 Martin Stransky 2019-12-06 15:23:40 UTC
Closing, Thanks!

Note You need to log in before you can comment on or make changes to this bug.