Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1797531 - Confusing error when running container with parameter --rm
Summary: Confusing error when running container with parameter --rm
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: podman
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lokesh Mandvekar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
Depends On:
Blocks: F32FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-02-03 11:21 UTC by Lukas Slebodnik
Modified: 2020-03-29 00:15 UTC (History)
13 users (show)

Fixed In Version: podman-1.8.2-2.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-29 00:15:27 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Lukas Slebodnik 2020-02-03 11:21:04 UTC
Description of problem:
I noticed that confusing ERROR when debugging unrelated issue

Version-Release number of selected component (if applicable):
sh-5.0# rpm -q podman crun
podman-1.8.0-0.1.dev.git4699d5e.fc32.x86_64
crun-0.11-1.fc32.x86_64

How reproducible:
Deterministic

Steps to Reproduce:
1. dnf install -y podman iptables
2. podman run --rm registry.fedoraproject.org/fedora:31 cat /etc/os-release

Actual results:
sh-5.0# podman run --rm registry.fedoraproject.org/fedora:31 cat /etc/os-release
NAME=Fedora
VERSION="31 (Container Image)"
ID=fedora
VERSION_ID=31
VERSION_CODENAME=""
PLATFORM_ID="platform:f31"
PRETTY_NAME="Fedora 31 (Container Image)"
ANSI_COLOR="0;34"
LOGO=fedora-logo-icon
CPE_NAME="cpe:/o:fedoraproject:fedora:31"
HOME_URL="https://fedoraproject.org/"
DOCUMENTATION_URL="https://docs.fedoraproject.org/en-US/fedora/f31/system-administrators-guide/"
SUPPORT_URL="https://fedoraproject.org/wiki/Communicating_and_getting_help"
BUG_REPORT_URL="https://bugzilla.redhat.com/"
REDHAT_BUGZILLA_PRODUCT="Fedora"
REDHAT_BUGZILLA_PRODUCT_VERSION=31
REDHAT_SUPPORT_PRODUCT="Fedora"
REDHAT_SUPPORT_PRODUCT_VERSION=31
PRIVACY_POLICY_URL="https://fedoraproject.org/wiki/Legal:PrivacyPolicy"
VARIANT="Container Image"
VARIANT_ID=container
ERRO[0000] Error forwarding signal 23 to container d063b783f6dda253450866f46342a342381ba3a315d94bb7d8891a30dcd830f7: container has already been removed

Expected results:
sh-5.0# podman run --rm registry.fedoraproject.org/fedora:31 cat /etc/os-release
NAME=Fedora
VERSION="31 (Container Image)"
ID=fedora
VERSION_ID=31
VERSION_CODENAME=""
PLATFORM_ID="platform:f31"
PRETTY_NAME="Fedora 31 (Container Image)"
ANSI_COLOR="0;34"
LOGO=fedora-logo-icon
CPE_NAME="cpe:/o:fedoraproject:fedora:31"
HOME_URL="https://fedoraproject.org/"
DOCUMENTATION_URL="https://docs.fedoraproject.org/en-US/fedora/f31/system-administrators-guide/"
SUPPORT_URL="https://fedoraproject.org/wiki/Communicating_and_getting_help"
BUG_REPORT_URL="https://bugzilla.redhat.com/"
REDHAT_BUGZILLA_PRODUCT="Fedora"
REDHAT_BUGZILLA_PRODUCT_VERSION=31
REDHAT_SUPPORT_PRODUCT="Fedora"
REDHAT_SUPPORT_PRODUCT_VERSION=31
PRIVACY_POLICY_URL="https://fedoraproject.org/wiki/Legal:PrivacyPolicy"
VARIANT="Container Image"
VARIANT_ID=container

Additional info:

Comment 1 Ed Santiago 2020-02-03 13:16:58 UTC
Fixed by https://github.com/containers/libpod/pull/5036

Comment 2 Ben Cotton 2020-02-11 17:20:27 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 3 Matthew Heon 2020-03-18 18:01:11 UTC
Fix is https://github.com/baude/libpod/commit/d4ce6a010b94864de31b9a1abb0654c79157b7c8

For context, see https://github.com/containers/libpod/issues/5483#issuecomment-598431764

In brief, this was a change in the Go 1.14 runtime that broke us. The fix is merged upstream, and is working its way into a release (Podman 1.8.2) that we hope to have out next week.

On un-patched systems where Podman is built with Go 1.14, we expect additional error messages when containers are stopped (which will not affect exit code of the process) and (more seriously) the process in the container will be bombarded by Signal 23 at a rate of several per second on average, which could break some applications.

Comment 4 Fedora Blocker Bugs Application 2020-03-18 18:19:53 UTC
Proposed as a Blocker for 32-final by Fedora user mheon using the blocker tracking app because:

 This is a serious regression in Podman caused by an upgrade of the Go toolchain to 1.14 in F32. Container processes started by `podman run` will be repeatedly sent signal 23 (several times a second) which could cause breakage in containerized applications. Fix is, fortunately, relatively simple.

Comment 5 Fedora Update System 2020-03-20 14:01:11 UTC
FEDORA-2020-92d6ffa26f has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-92d6ffa26f

Comment 6 Fedora Update System 2020-03-21 01:43:57 UTC
podman-1.8.2-2.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-92d6ffa26f

Comment 7 Geoffrey Marr 2020-03-23 19:41:10 UTC
Discussed during the 2020-03-23 blocker review meeting: [0]

The decision to classify this bug as a "RejectedBlocker" and an "AcceptedFreezeException" was made as there are (still) no criteria at all requiring podman/container functionality to work at all so we really cannot block on this. However, it's obviously important functionality these days that we would want to work at release, so accepted as an FE issue.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-03-23/f32-blocker-review.2020-03-23-16.00.txt

Comment 8 Fedora Update System 2020-03-29 00:15:27 UTC
FEDORA-2020-92d6ffa26f has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.