Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1799139 - acpica-tools: FTBFS in Fedora rawhide/f32
Summary: acpica-tools: FTBFS in Fedora rawhide/f32
Keywords:
Status: CLOSED DUPLICATE of bug 1863143
Alias: None
Product: Fedora
Classification: Fedora
Component: acpica-tools
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Al Stone
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F32FTBFS
TreeView+ depends on / blocked
 
Reported: 2020-02-06 15:55 UTC by Fedora Release Engineering
Modified: 2020-10-21 15:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-14 17:13:45 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2020-02-06 15:55 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2020-02-06 15:55 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2020-02-06 15:55 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2020-02-06 15:55:12 UTC
acpica-tools failed to build from source in Fedora rawhide/f32

https://koji.fedoraproject.org/koji/taskinfo?taskID=41315685


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
Please fix acpica-tools at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
acpica-tools will be orphaned. Before branching of Fedora 33,
acpica-tools will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2020-02-06 15:55:19 UTC
Created attachment 1658381 [details]
build.log

Comment 2 Fedora Release Engineering 2020-02-06 15:55:21 UTC
Created attachment 1658382 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2020-02-06 15:55:22 UTC
Created attachment 1658383 [details]
state.log

Comment 4 Ben Cotton 2020-02-11 17:16:21 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 5 Fedora Release Engineering 2020-02-16 04:28:41 UTC
Dear Maintainer,

your package has not been built successfully in 32. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
will be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 33 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 31 will be
retired regardless of the status of this bug.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/33/Schedule

Comment 6 Al Stone 2020-02-16 20:54:00 UTC
Working on a fix; a new version of the upstream source has also arrived.

Comment 7 Troy Dawson 2020-07-15 15:52:56 UTC
Newer version is building much better.
A scratch build shows that it builds on all arches but s390x.
s390x is only failling on the second batch of tests, run-misc-tests.sh

Here is the output of a scratch build.
https://koji.fedoraproject.org/koji/taskinfo?taskID=47262933

Comment 8 Al Stone 2020-07-15 17:10:53 UTC
(In reply to Troy Dawson from comment #7)
> Newer version is building much better.
> A scratch build shows that it builds on all arches but s390x.
> s390x is only failling on the second batch of tests, run-misc-tests.sh

My last test builds showed a significant number of failures in the first batch of
tests, as well.

> Here is the output of a scratch build.
> https://koji.fedoraproject.org/koji/taskinfo?taskID=47262933

Yeah, s390x is by definition problematic; ACPICA does not support big-endian at all.
The last few upstream revisions have caused a lot of bugs as a result; still working
on the patches to clean that up.

Comment 9 Miro Hrončok 2020-10-14 17:13:45 UTC

*** This bug has been marked as a duplicate of bug 1863143 ***


Note You need to log in before you can comment on or make changes to this bug.