Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1799410 - glibd: FTBFS in Fedora rawhide/f32
Summary: glibd: FTBFS in Fedora rawhide/f32
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: glibd
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Neal Gompa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1813529
Blocks: F32FTBFS 1799159
TreeView+ depends on / blocked
 
Reported: 2020-02-06 16:59 UTC by Fedora Release Engineering
Modified: 2020-03-21 02:14 UTC (History)
2 users (show)

Fixed In Version: glibd-2.1.0-5.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-21 02:14:25 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2020-02-06 16:59 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2020-02-06 16:59 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2020-02-06 17:00 UTC, Fedora Release Engineering
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github gtkd-developers GlibD issues 7 0 None closed Fails to build on Fedora 32 (glib2-2.63.5) 2020-03-14 09:10:43 UTC

Description Fedora Release Engineering 2020-02-06 16:59:54 UTC
glibd failed to build from source in Fedora rawhide/f32

https://koji.fedoraproject.org/koji/taskinfo?taskID=41317425


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
Please fix glibd at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
glibd will be orphaned. Before branching of Fedora 33,
glibd will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2020-02-06 16:59:56 UTC
Created attachment 1659047 [details]
build.log

Comment 2 Fedora Release Engineering 2020-02-06 16:59:58 UTC
Created attachment 1659048 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2020-02-06 17:00:00 UTC
Created attachment 1659049 [details]
state.log

Comment 4 Ben Cotton 2020-02-11 17:08:18 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 5 Fedora Release Engineering 2020-02-16 04:33:42 UTC
Dear Maintainer,

your package has not been built successfully in 32. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
will be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 33 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 31 will be
retired regardless of the status of this bug.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/33/Schedule

Comment 6 Neal Gompa 2020-02-23 15:39:16 UTC
Working on it, but also filed upstream issue: https://github.com/gtkd-developers/GlibD/issues/7

Comment 7 Fabio Valentini 2020-03-03 22:51:16 UTC
I can't imagine how this went wrong, but the package you built today/yesterday isn't installable in rawhide:

$ mock -r fedora-rawhide-x86_64 install glibd-devel

Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides libglibd-2.0.so()(64bit) needed by glibd-devel-2.1.0-4.fc33.x86_64

Not sure how an intra-package dependency can be not satisfied :D

Comment 8 Neal Gompa 2020-03-04 04:24:30 UTC
(In reply to Fabio Valentini from comment #7)
> I can't imagine how this went wrong, but the package you built
> today/yesterday isn't installable in rawhide:
> 
> $ mock -r fedora-rawhide-x86_64 install glibd-devel
> 
> Error: 
>  Problem: cannot install the best candidate for the job
>   - nothing provides libglibd-2.0.so()(64bit) needed by
> glibd-devel-2.1.0-4.fc33.x86_64
> 
> Not sure how an intra-package dependency can be not satisfied :D

WTF?!

Comment 9 Neal Gompa 2020-03-14 09:16:44 UTC
So this turns out to be caused by a new Meson bug... 🤦‍♂️

Anyway, I've filed bug 1813529 over it.

Comment 10 Fedora Update System 2020-03-19 23:56:50 UTC
FEDORA-2020-d76b2690b5 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-d76b2690b5

Comment 11 Fedora Update System 2020-03-20 01:59:30 UTC
appstream-0.12.10-1.fc32, appstream-generator-0.8.1-1.fc32, glibd-2.1.0-5.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-d76b2690b5

Comment 12 Fedora Update System 2020-03-21 02:14:25 UTC
appstream-0.12.10-1.fc32, appstream-generator-0.8.1-1.fc32, glibd-2.1.0-5.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.