Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1799635 - matreshka: FTBFS in Fedora rawhide/f32
Summary: matreshka: FTBFS in Fedora rawhide/f32
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: matreshka
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Zhukov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1833651 1833991 (view as bug list)
Depends On: 1800306
Blocks: F32FTBFS F32FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2020-02-06 18:38 UTC by Fedora Release Engineering
Modified: 2020-06-26 10:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-26 10:05:47 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2020-02-06 18:38 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2020-02-06 18:39 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2020-02-06 18:39 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2020-02-06 18:38:55 UTC
matreshka failed to build from source in Fedora rawhide/f32

https://koji.fedoraproject.org/koji/taskinfo?taskID=41318959


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
Please fix matreshka at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
matreshka will be orphaned. Before branching of Fedora 33,
matreshka will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2020-02-06 18:38:58 UTC
Created attachment 1659643 [details]
build.log

Comment 2 Fedora Release Engineering 2020-02-06 18:39:00 UTC
Created attachment 1659644 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2020-02-06 18:39:01 UTC
Created attachment 1659645 [details]
state.log

Comment 4 Ben Cotton 2020-02-11 16:35:16 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 5 Fedora Release Engineering 2020-02-16 04:27:26 UTC
Dear Maintainer,

your package has not been built successfully in 32. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
will be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 33 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 31 will be
retired regardless of the status of this bug.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/33/Schedule

Comment 6 Pavel Zhukov 2020-05-09 21:27:34 UTC
*** Bug 1833651 has been marked as a duplicate of this bug. ***

Comment 7 Pavel Zhukov 2020-05-11 07:00:17 UTC
*** Bug 1833991 has been marked as a duplicate of this bug. ***

Comment 8 Pavel Zhukov 2020-05-13 14:26:11 UTC
https://forge.ada-ru.org/matreshka/ticket/517

Comment 9 Igor Raits 2020-06-26 09:54:06 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (ignatenkobrain).

All subpackages of a package agaisnt which this bug was filled are now installable or removed from Fedora 33.

Thanks for taking care of it!


Note You need to log in before you can comment on or make changes to this bug.