Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1800290 - z88dk: FTBFS in Fedora rawhide/f32: /usr/bin/ld: m5.o:/builddir/build/BUILD/z88dk/src/appmake/m5.c:35: multiple definition of `checksum'
Summary: z88dk: FTBFS in Fedora rawhide/f32: /usr/bin/ld: m5.o:/builddir/build/BUILD/z...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: z88dk
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1865659 (view as bug list)
Depends On:
Blocks: F32FTBFS F33FTBFS
TreeView+ depends on / blocked
 
Reported: 2020-02-06 20:28 UTC by Fedora Release Engineering
Modified: 2020-08-03 23:38 UTC (History)
2 users (show)

Fixed In Version: z88dk-1.10.1-20.20150709cvs.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-03 23:02:31 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2020-02-06 20:28 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2020-02-06 20:28 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2020-02-06 20:28 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2020-02-06 20:28:13 UTC
z88dk failed to build from source in Fedora rawhide/f32

https://koji.fedoraproject.org/koji/taskinfo?taskID=41323161


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
Please fix z88dk at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
z88dk will be orphaned. Before branching of Fedora 33,
z88dk will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2020-02-06 20:28:15 UTC
Created attachment 1661487 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Fedora Release Engineering 2020-02-06 20:28:17 UTC
Created attachment 1661488 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2020-02-06 20:28:19 UTC
Created attachment 1661489 [details]
state.log

Comment 4 Kevin Kofler 2020-02-06 22:08:09 UTC
/usr/bin/ld: m5.o:/builddir/build/BUILD/z88dk/src/appmake/m5.c:35: multiple definition of `checksum'; sc3000.o:/builddir/build/BUILD/z88dk/src/appmake/sc3000.c:47: first defined here
Fallout from -fno-common.

Comment 5 Ben Cotton 2020-02-11 16:40:05 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 6 Fedora Release Engineering 2020-02-16 04:30:10 UTC
Dear Maintainer,

your package has not been built successfully in 32. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
will be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 33 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 31 will be
retired regardless of the status of this bug.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/33/Schedule

Comment 7 Kevin Kofler 2020-08-03 22:44:44 UTC
*** Bug 1865659 has been marked as a duplicate of this bug. ***

Comment 8 Kevin Kofler 2020-08-03 23:02:31 UTC
https://koji.fedoraproject.org/koji/buildinfo?buildID=1580644
(pending s390x because the builders are busy)

Comment 9 Kevin Kofler 2020-08-03 23:38:37 UTC
The successful build is completely done now.


Note You need to log in before you can comment on or make changes to this bug.