Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1800845 - python-nipy fails to build with numpy 1.18
Summary: python-nipy fails to build with numpy 1.18
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-nipy
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Aniket Pradhan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1842132 (view as bug list)
Depends On:
Blocks: F32FTBFS F33FTBFS 1842132
TreeView+ depends on / blocked
 
Reported: 2020-02-08 10:26 UTC by Miro Hrončok
Modified: 2021-07-14 01:19 UTC (History)
6 users (show)

Fixed In Version: python-nipy-0.5.0-1.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-14 01:19:51 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github nipy nipy pull 458 0 None closed FIX various fixes for deprecations in numpy, scipy, sphinx 2021-01-06 16:28:29 UTC
Red Hat Bugzilla 1799940 0 unspecified CLOSED python-nipy: FTBFS in Fedora rawhide/f32 2021-02-22 00:41:40 UTC

Description Miro Hrončok 2020-02-08 10:26:40 UTC
python-nipy fails to build with numpy 1.18:

+ nosetests-3.9 -v -e test_implemented_function
Failure: ModuleNotFoundError (No module named 'numpy.testing.decorators') ... ERROR
======================================================================
ERROR: Failure: ModuleNotFoundError (No module named 'numpy.testing.decorators')
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python3.9/site-packages/nose/failure.py", line 39, in runTest
    raise self.exc_val.with_traceback(self.tb)
  File "/usr/lib/python3.9/site-packages/nose/loader.py", line 416, in loadTestsFromName
    module = self.importer.importFromPath(
  File "/usr/lib/python3.9/site-packages/nose/importer.py", line 47, in importFromPath
    return self.importFromDir(dir_path, fqname)
  File "/usr/lib/python3.9/site-packages/nose/importer.py", line 94, in importFromDir
    mod = load_module(part_fqname, fh, filename, desc)
  File "/usr/lib64/python3.9/imp.py", line 244, in load_module
    return load_package(name, filename)
  File "/usr/lib64/python3.9/imp.py", line 216, in load_package
    return _load(spec)
  File "<frozen importlib._bootstrap>", line 702, in _load
  File "<frozen importlib._bootstrap>", line 671, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 789, in exec_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  File "/builddir/build/BUILD/nipy-0.4.2/build/lib.linux-x86_64-3.9/nipy/__init__.py", line 12, in <module>
    from nipy.testing import Tester
  File "/builddir/build/BUILD/nipy-0.4.2/build/lib.linux-x86_64-3.9/nipy/testing/__init__.py", line 44, in <module>
    from . import decorators as dec
  File "/builddir/build/BUILD/nipy-0.4.2/build/lib.linux-x86_64-3.9/nipy/testing/decorators.py", line 11, in <module>
    from numpy.testing.decorators import *
ModuleNotFoundError: No module named 'numpy.testing.decorators'


This is what I get on Fedora 31:

DeprecationWarning: Importing from numpy.testing.decorators is deprecated since numpy 1.15.0, import from numpy.testing instead.


This blocks the Python 3.9 rebuild.

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.9/fedora-rawhide-x86_64/01224747-python-nipy/

For all our attempts to build python-nipy with Python 3.9, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/package/python-nipy/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.9:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/

Let us know here if you have any questions.

Python 3.9 will be included in Fedora 33. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.9.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Ben Cotton 2020-02-11 16:36:36 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 2 Aniket Pradhan 2020-02-17 08:43:38 UTC
The issue has already been reported upstream. I will try to work on it and submit a patch, if possible. :D

Comment 3 Miro Hrončok 2020-05-25 13:02:10 UTC
This comment is mass posted to all bugs blocking the Python 3.9 tracker, sorry if it is not 100 % relevant. When in doubt, please ask.


The Python 3.9 rebuild is in progress in a Koji side tag.

If you fix this bug, please don't rebuild the package in regular rawhide, but do it in the side tag with:

    $ fedpkg build --target=f33-python

The rebuild is progressing slowly and it is possible this package won't have all the required build dependencies yet. If that's the case, please just leave the fix committed and pushed and we will eventually rebuild it for you.

You are not asked to go and try rebuild all the missing dependencies yourself. If you know there is a bootstrap loop in the dependencies, let me know and we can untangle it together.

If you want to test your fix or reproduce the failure, you can still use the Copr repo mentioned in the initial comment of this bug: https://copr.fedorainfracloud.org/coprs/g/python/python3.9/

Comment 4 Miro Hrončok 2020-05-29 07:12:00 UTC
Python 3.9 update: The f33-python side tag is currently being merged.

New builds in f33-python are no longer possible, but python3 is not yet updated to Python 3.9 in rawhide. You can check when Python is Python 3.9 with:

    $ koji wait-repo f33-build --build python3.9-3.9.0~b1-3.fc3

And build the packages normally after that.

Comment 5 Ankur Sinha (FranciscoD) 2020-06-07 09:57:01 UTC
Note: upstream are aware of all of these issues:

https://github.com/nipy/nipy/pull/458

However, they're not quite as cutting edge as Fedora is and would prefer to pin requirements to older working versions for the moment until they can find the time to update everything to newer versions of numpy/sympy and so on.

I don't currently have cycles to look into upstream code, but if anyone does (especially with knowledge of sympy etc.), please consider helping upstream update their code.

PS: is there a "help-wanted" keyword/tag on bugzilla?

Comment 6 Miro Hrončok 2020-06-07 12:59:54 UTC
> PS: is there a "help-wanted" keyword/tag on bugzilla?

I don't think so, but try asking explicitly on the python-devel mailing list.

Comment 7 Ankur Sinha (FranciscoD) 2020-06-11 09:57:48 UTC
*** Bug 1842132 has been marked as a duplicate of this bug. ***

Comment 8 Ben Cotton 2020-08-11 13:07:42 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 33 development cycle.
Changing version to 33.

Comment 9 Ankur Sinha (FranciscoD) 2020-08-13 20:38:18 UTC
I've disabled tests to fix the builds for the time being. Leaving this open, though.

Comment 10 Igor Raits 2020-08-21 05:22:15 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (ignatenkobrain).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 33.

Thanks for taking care of it!

Comment 11 Ben Cotton 2021-02-09 15:14:08 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 12 Fedora Update System 2021-07-05 07:53:59 UTC
FEDORA-2021-4062d43f11 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-4062d43f11

Comment 13 Fedora Update System 2021-07-06 01:11:02 UTC
FEDORA-2021-4062d43f11 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-4062d43f11`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-4062d43f11

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2021-07-14 01:19:51 UTC
FEDORA-2021-4062d43f11 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.