Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1800991 - cannot upgrade eclipse because of eclipse-usage
Summary: cannot upgrade eclipse because of eclipse-usage
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-usage
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mat Booth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-09 21:31 UTC by Heldwin
Modified: 2020-08-28 14:58 UTC (History)
4 users (show)

Fixed In Version: eclipse-usage-4.16.0-2.fc31
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-28 14:58:03 UTC
Type: Bug


Attachments (Terms of Use)

Description Heldwin 2020-02-09 21:31:28 UTC
Description of problem:
Cannot update eclipse, because eclipse-usage cannot find a dependency.
Not sure if it is because of the obsoletes eclipse-epp-logging <= 2.0.8-4

Version-Release number of selected component (if applicable):
eclipse-usage-4.11.0-1.fc31.noarch
eclipse-epp-logging-2.0.7-8.fc31.noarch

Informations:
 Problème 1: package eclipse-usage-4.11.0-1.fc31.noarch requires osgi(org.eclipse.epp.logging.aeri.core), but none of the providers can be installed
  - package eclipse-usage-4.11.0-1.fc31.noarch requires osgi(org.eclipse.epp.logging.aeri.ide), but none of the providers can be installed
  - package eclipse-platform-1:4.14-5.fc31.x86_64 obsoletes eclipse-epp-logging <= 2.0.8-4 provided by eclipse-epp-logging-2.0.7-8.fc31.noarch
  - cannot install the best update candidate for package eclipse-usage-4.11.0-1.fc31.noarch
  - cannot install the best update candidate for package eclipse-abrt-0.0.3-9.fc31.noarch
 Problème 2: problem with installed package eclipse-usage-4.11.0-1.fc31.noarch
  - package eclipse-usage-4.11.0-1.fc31.noarch requires osgi(org.eclipse.epp.logging.aeri.core), but none of the providers can be installed
  - package eclipse-usage-4.11.0-1.fc31.noarch requires osgi(org.eclipse.epp.logging.aeri.ide), but none of the providers can be installed
  - package eclipse-platform-1:4.14-5.fc31.x86_64 obsoletes eclipse-epp-logging <= 2.0.8-4 provided by eclipse-epp-logging-2.0.7-8.fc31.noarch
  - cannot install the best update candidate for package eclipse-epp-logging-2.0.7-8.fc31.noarch

Comment 1 a.lexander.aristov 2020-02-14 21:02:13 UTC
Eclipse doesn't start. Logs shows a lot of missing dependancies.

dnf update reports the following


Last metadata expiration check: 0:17:59 ago on Sat 15 Feb 2020 12:43:30 AM +04.
Dependencies resolved.

 Problem 1: package eclipse-usage-4.11.0-1.fc31.noarch requires osgi(org.eclipse.epp.logging.aeri.core), but none of the providers can be installed
  - package eclipse-usage-4.11.0-1.fc31.noarch requires osgi(org.eclipse.epp.logging.aeri.ide), but none of the providers can be installed
  - package eclipse-platform-1:4.14-5.fc31.x86_64 obsoletes eclipse-epp-logging <= 2.0.8-4 provided by eclipse-epp-logging-2.0.7-8.fc31.noarch
  - cannot install the best update candidate for package eclipse-usage-4.11.0-1.fc31.noarch
  - cannot install the best update candidate for package eclipse-abrt-0.0.3-9.fc31.noarch
  - package eclipse-epp-logging-2.0.8-1.module_f31+6165+9b01e00c.noarch is filtered out by modular filtering
  - package eclipse-epp-logging-2.0.8-2.module_f31+6519+12cd0b27.noarch is filtered out by modular filtering
 Problem 2: problem with installed package eclipse-usage-4.11.0-1.fc31.noarch
  - package eclipse-usage-4.11.0-1.fc31.noarch requires osgi(org.eclipse.epp.logging.aeri.core), but none of the providers can be installed
  - package eclipse-usage-4.11.0-1.fc31.noarch requires osgi(org.eclipse.epp.logging.aeri.ide), but none of the providers can be installed
  - package eclipse-platform-1:4.14-5.fc31.x86_64 obsoletes eclipse-epp-logging <= 2.0.8-4 provided by eclipse-epp-logging-2.0.7-8.fc31.noarch
  - cannot install the best update candidate for package eclipse-epp-logging-2.0.7-8.fc31.noarch
  - package eclipse-epp-logging-2.0.8-1.module_f31+6165+9b01e00c.noarch is filtered out by modular filtering
  - package eclipse-epp-logging-2.0.8-2.module_f31+6519+12cd0b27.noarch is filtered out by modular filtering
Nothing to do.
Complete!

Comment 2 Fedora Admin user for bugzilla script actions 2020-08-18 14:53:41 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 3 Fedora Update System 2020-08-20 13:03:03 UTC
FEDORA-2020-fb0c1e9c3e has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-fb0c1e9c3e

Comment 4 Fedora Update System 2020-08-21 01:03:52 UTC
FEDORA-2020-fb0c1e9c3e has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-fb0c1e9c3e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-fb0c1e9c3e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2020-08-28 14:58:03 UTC
FEDORA-2020-fb0c1e9c3e has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.