Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1807459 - python-nistats fails to build with Python 3.9: no module named pytest and numpy version incompatibility
Summary: python-nistats fails to build with Python 3.9: no module named pytest and num...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: python-nistats
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ankur Sinha (FranciscoD)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1841750 (view as bug list)
Depends On: 1799941
Blocks: F33FTBFS PYTHON39
TreeView+ depends on / blocked
 
Reported: 2020-02-26 12:08 UTC by Miro Hrončok
Modified: 2020-09-08 21:17 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-08 21:17:45 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2020-02-26 12:08:23 UTC
python-nistats fails to build with Python 3.9.0a3.

  ModuleNotFoundError: No module named 'pytest'

and

  TypeError: object of type <class 'float'> cannot be safely interpreted as an integer.

and

  AttributeError: module 'collections' has no attribute 'Iterable'

See https://docs.python.org/3.9/whatsnew/3.9.html#removed

"The abstract base classes in collections.abc no longer are exposed in the regular collections module. This will help create a clearer distinction between the concrete classes and the abstract base classes."



For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.9/fedora-rawhide-x86_64/01252599-python-nistats/

For all our attempts to build python-nistats with Python 3.9, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/package/python-nistats/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.9:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/

Let us know here if you have any questions.

Python 3.9 will be included in Fedora 33. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.9.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2020-02-28 09:05:43 UTC
In Python 3.9.0a4 we have managed to revert the change that disables importing abstract base classes (collections.abc) directly form the regular collections module. It was reverted to ease transition for projects that did not yet actually dropped support for Python 2.7. The removal is scheduled for Python 3.10 instead.

Leaving this open for the other problems.

Comment 2 Miro Hrončok 2020-05-25 13:02:25 UTC
This comment is mass posted to all bugs blocking the Python 3.9 tracker, sorry if it is not 100 % relevant. When in doubt, please ask.


The Python 3.9 rebuild is in progress in a Koji side tag.

If you fix this bug, please don't rebuild the package in regular rawhide, but do it in the side tag with:

    $ fedpkg build --target=f33-python

The rebuild is progressing slowly and it is possible this package won't have all the required build dependencies yet. If that's the case, please just leave the fix committed and pushed and we will eventually rebuild it for you.

You are not asked to go and try rebuild all the missing dependencies yourself. If you know there is a bootstrap loop in the dependencies, let me know and we can untangle it together.

If you want to test your fix or reproduce the failure, you can still use the Copr repo mentioned in the initial comment of this bug: https://copr.fedorainfracloud.org/coprs/g/python/python3.9/

Comment 3 Miro Hrončok 2020-05-29 07:12:10 UTC
Python 3.9 update: The f33-python side tag is currently being merged.

New builds in f33-python are no longer possible, but python3 is not yet updated to Python 3.9 in rawhide. You can check when Python is Python 3.9 with:

    $ koji wait-repo f33-build --build python3.9-3.9.0~b1-3.fc3

And build the packages normally after that.

Comment 4 Miro Hrončok 2020-06-11 15:17:21 UTC
*** Bug 1841750 has been marked as a duplicate of this bug. ***

Comment 5 Ben Cotton 2020-08-11 13:09:48 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 33 development cycle.
Changing version to 33.

Comment 6 Charalampos Stratakis 2020-09-07 16:19:22 UTC
According to the upstream page [0]:

Nistats is RETIRED and will no longer receive fixes and updates!
Its latest release, 0.0.1rc will be the last release, available via PyPI.
Its functionality will now be available in the release of Nilearn 0.7.0 in late 2020.

Since it's FTBFS I would suggest retiring it after making sure nothing else depends on it.

[0] https://nistats.github.io/

Comment 7 Ankur Sinha (FranciscoD) 2020-09-07 16:58:22 UTC
Hi Charalampos,

Yes, that all of nistats will be included in nilearn in the future is noted in other bugs on the package. I was waiting for the FTI process to retire the package automatically, but if that's too much of a wait, I'll retire it now.

Cheers,

Comment 8 Ankur Sinha (FranciscoD) 2020-09-07 17:04:19 UTC
I've retired nistats now. Please let me know if there's anything else to do here. (I haven't orphaned it yet)

Comment 9 Igor Raits 2020-09-08 06:37:29 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (ignatenkobrain).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 33.

Thanks for taking care of it!

Comment 10 Miro Hrončok 2020-09-08 21:17:45 UTC
Automation has figured out the package is retired in Fedora 33.

If you like it to be unretired, please open a ticket at https://pagure.io/releng/new_issue?template=package_unretirement


Note You need to log in before you can comment on or make changes to this bug.