Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1816527 - JSC broken on ppc64le
Summary: JSC broken on ppc64le
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: webkit2gtk3
Version: 32
Hardware: ppc64le
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Catanzaro
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1817959 (view as bug list)
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2020-03-24 08:40 UTC by Trung LE
Modified: 2020-04-29 16:09 UTC (History)
14 users (show)

Fixed In Version: webkit2gtk3-2.28.0-8.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-15 22:58:02 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
WebKit Project 209236 0 None None None 2020-03-24 13:19:27 UTC

Description Trung LE 2020-03-24 08:40:50 UTC
Description of problem:

epiphany crashed after few seconds in the main window


Version-Release number of selected component (if applicable):

* Fedora 32 BETA (5.6.0-0.rc5.git0.2.fc32.ppc64le)
* epiphany-3.36.0-1.fc32
* webkit2gtk3-2.27.90-2.fc32


How reproducible:


Steps to Reproduce:
1. Run `epiphany`
2. At the main window, don't do anything, just wait for 2 or 3 seconds

Actual results:
Crashed

Expected results:
No crash

Additional info:

```
           PID: 4135024 (epiphany)
           UID: 1000 (tle)
           GID: 1000 (tle)
        Signal: 6 (ABRT)
     Timestamp: Tue 2020-03-24 19:30:29 AEDT (21s ago)
  Command Line: epiphany -p
    Executable: /usr/bin/epiphany
 Control Group: /user.slice/user-1000.slice/session-6.scope
          Unit: session-6.scope
         Slice: user-1000.slice
       Session: 6
     Owner UID: 1000 (tle)
       Boot ID: f7cc7ae1d9e64ccca0b9a401e000e41f
    Machine ID: 5632f07729a648c49d05933910ac9490
      Hostname: orion.dev
       Storage: /var/lib/systemd/coredump/core.epiphany.1000.f7cc7ae1d9e64ccca0b9a401e000e41f.4135024.1585038629000000000000.lz4
       Message: Process 4135024 (epiphany) of user 1000 dumped core.

Stack trace of thread 4135024:
#0  0x00007fffa0b29258 in raise () at /lib64/libc.so.6
#1  0x00007fffa0b07c68 in abort () at /lib64/libc.so.6
#2  0x00007fff9c0d00d4 in JSC::Config::permanentlyFreeze() () at /lib64/libjavascriptcoregtk-4.0.so.18
#3  0x00007fff9c2e9360 in JSC::VM::VM(JSC::VM::VMType, JSC::HeapType) () at /lib64/libjavascriptcoregtk-4.0.so.18
#4  0x00007fff9c2ea0c4 in JSC::VM::create(JSC::HeapType) () at /lib64/libjavascriptcoregtk-4.0.so.18
#5  0x00007fff9e10b138 in WebCore::ContentExtensions::parseRuleList(WTF::String const&) () at /lib64/libwebkit2gtk-4.0.so.37
#6  0x00007fff9d1e4ad8 in API::ContentRuleListStore::compileContentRuleList(WTF::String const&, WTF::String&&, WTF::CompletionHandler<void (WTF::RefPtr<API::ContentRuleList, WTF::DumbPtrTraits<API::ContentRuleList> >, std::error_code)>) () at /lib64/libwebkit2gtk-4.0.so.37
#7  0x00007fff9d273444 in webkitUserContentFilterStoreSaveBytes(WTF::GRefPtr<_GTask>&&, WTF::String&&, WTF::GRefPtr<_GBytes>&&) [clone .isra.0] ()
    at /lib64/libwebkit2gtk-4.0.so.37
#8  0x00007fff9d273ad8 in webkit_user_content_filter_store_save () at /lib64/libwebkit2gtk-4.0.so.37
#9  0x00007fffa1f4117c in filter_info_setup_load_file () at /usr/lib64/epiphany/libephymain.so
#10 0x00007fffa1f41758 in download_completed_cb () at /usr/lib64/epiphany/libephymain.so
#11 0x00007fffa118b00c in g_cclosure_marshal_VOID__VOIDv () at /lib64/libgobject-2.0.so.0
#12 0x00007fffa1187d30 in _g_closure_invoke_va () at /lib64/libgobject-2.0.so.0
#13 0x00007fffa11abed4 in g_signal_emit_valist () at /lib64/libgobject-2.0.so.0
#14 0x00007fffa11ac050 in g_signal_emit () at /lib64/libgobject-2.0.so.0
#15 0x00007fffa1f2f0f4 in download_finished_cb () at /usr/lib64/epiphany/libephymain.so
#16 0x00007fffa118af50 in g_cclosure_marshal_VOID__VOID () at /lib64/libgobject-2.0.so.0
#17 0x00007fffa11879dc in g_closure_invoke () at /lib64/libgobject-2.0.so.0
#18 0x00007fffa11a4678 in signal_emit_unlocked_R.isra.0 () at /lib64/libgobject-2.0.so.0
#19 0x00007fffa11abf18 in g_signal_emit_valist () at /lib64/libgobject-2.0.so.0
#20 0x00007fffa11ac050 in g_signal_emit () at /lib64/libgobject-2.0.so.0
#21 0x00007fff9d241b78 in webkitDownloadFinished(_WebKitDownload*) () at /lib64/libwebkit2gtk-4.0.so.37
#22 0x00007fff9d241e74 in DownloadClient::didFinish(WebKit::DownloadProxy&) () at /lib64/libwebkit2gtk-4.0.so.37
#23 0x00007fff9d2f960c in WebKit::DownloadProxy::didFinish() () at /lib64/libwebkit2gtk-4.0.so.37
#24 0x00007fff9ce572a8 in WebKit::DownloadProxy::didReceiveMessage(IPC::Connection&, IPC::Decoder&) () at /lib64/libwebkit2gtk-4.0.so.37
#25 0x00007fff9d02554c in IPC::MessageReceiverMap::dispatchMessage(IPC::Connection&, IPC::Decoder&) () at /lib64/libwebkit2gtk-4.0.so.37
#26 0x00007fff9d0db9cc in WebKit::AuxiliaryProcessProxy::dispatchMessage(IPC::Connection&, IPC::Decoder&) () at /lib64/libwebkit2gtk-4.0.so.37
#27 0x00007fff9d312aa0 in WebKit::NetworkProcessProxy::didReceiveMessage(IPC::Connection&, IPC::Decoder&) () at /lib64/libwebkit2gtk-4.0.so.37
#28 0x00007fff9d01a0e8 in IPC::Connection::dispatchMessage(IPC::Decoder&) () at /lib64/libwebkit2gtk-4.0.so.37
#29 0x00007fff9d01be40 in IPC::Connection::dispatchMessage(std::unique_ptr<IPC::Decoder, std::default_delete<IPC::Decoder> >) () at /lib64/libwebkit2gtk-4.0.so.37
#30 0x00007fff9d01c67c in IPC::Connection::dispatchOneIncomingMessage() () at /lib64/libwebkit2gtk-4.0.so.37
#31 0x00007fff9d01cbf4 in WTF::Detail::CallableWrapper<IPC::Connection::enqueueIncomingMessage(std::unique_ptr<IPC::Decoder, std::default_delete<IPC::Decoder> >)::{lambda()#1}, void>::call() () at /lib64/libwebkit2gtk-4.0.so.37
#32 0x00007fff9c3b554c in WTF::RunLoop::performWork() () at /lib64/libjavascriptcoregtk-4.0.so.18
#33 0x00007fff9c41d698 in WTF::RunLoop::RunLoop()::{lambda(void*)#1}::_FUN(void*) () at /lib64/libjavascriptcoregtk-4.0.so.18
#34 0x00007fff9c41d720 in WTF::{lambda(_GSource*, int (*)(void*), void*)#1}::_FUN(_GSource*, int (*)(void*), void*) () at /lib64/libjavascriptcoregtk-4.0.so.18
#35 0x00007fffa103ea28 in g_main_context_dispatch () at /lib64/libglib-2.0.so.0
#36 0x00007fffa103ef08 in g_main_context_iterate.constprop () at /lib64/libglib-2.0.so.0
#37 0x00007fffa103f02c in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#38 0x00007fffa134da28 in g_application_run () at /lib64/libgio-2.0.so.0
#39 0x00000001303b4ad4 in main ()
```

```
           PID: 4135094 (WebKitWebProces)
           UID: 1000 (tle)
           GID: 1000 (tle)
        Signal: 6 (ABRT)
     Timestamp: Tue 2020-03-24 19:30:27 AEDT (9min ago)
  Command Line: /usr/libexec/webkit2gtk-4.0/WebKitWebProcess 10 38
    Executable: /usr/libexec/webkit2gtk-4.0/WebKitWebProcess
 Control Group: /user.slice/user-1000.slice/session-6.scope
          Unit: session-6.scope
         Slice: user-1000.slice
       Session: 6
     Owner UID: 1000 (tle)
       Boot ID: f7cc7ae1d9e64ccca0b9a401e000e41f
    Machine ID: 5632f07729a648c49d05933910ac9490
      Hostname: orion.dev
       Storage: /var/lib/systemd/coredump/core.WebKitWebProces.1000.f7cc7ae1d9e64ccca0b9a401e000e41f.4135094.1585038627000000000000.lz4
       Message: Process 4135094 (WebKitWebProces) of user 1000 dumped core.

                Stack trace of thread 2:
                #0  0x00007fffa3149258 raise (libc.so.6 + 0x49258)
                #1  0x00007fffa3127c68 abort (libc.so.6 + 0x27c68)
                #2  0x00007fffa11800d4 _ZN3JSC6Config17permanentlyFreezeEv (libjavascriptcoregtk-4.0.so.18 + 0x8800d4)
                #3  0x00007fffa1399360 _ZN3JSC2VMC1ENS0_6VMTypeENS_8HeapTypeE (libjavascriptcoregtk-4.0.so.18 + 0xa99360)
                #4  0x00007fffa139a0c4 _ZN3JSC2VM6createENS_8HeapTypeE (libjavascriptcoregtk-4.0.so.18 + 0xa9a0c4)
                #5  0x00007fffa4dc12a8 _ZN7WebCore12commonVMSlowEv (libwebkit2gtk-4.0.so.37 + 0x19812a8)
                #6  0x00007fffa4e26f74 _ZN7WebCore16ScriptController11createWorldERKN3WTF6StringENS0_9WorldTypeE (libwebkit2gtk-4.0.so.37 + 0x19e6f74)
                #7  0x00007fffa415f618 _ZN6WebKit25InjectedBundleScriptWorld6createERKN3WTF6StringENS0_4TypeE (libwebkit2gtk-4.0.so.37 + 0xd1f618)
                #8  0x00007fffa416c888 webkit_script_world_new_with_name (libwebkit2gtk-4.0.so.37 + 0xd2c888)
                #9  0x00007fff7c018f60 ephy_web_process_extension_initialize (libephywebprocessextension.so + 0x8f60)
                #10 0x00007fff7c019158 webkit_web_extension_initialize_with_user_data (libephywebprocessextension.so + 0x9158)
                #11 0x00007fffa416a09c _ZN6WebKit22WebKitExtensionManager22initializeWebExtensionEPNS_6ModuleEP9_GVariant (libwebkit2gtk-4.0.so.37 + 0xd2a09c)
                #12 0x00007fffa416a614 _ZN6WebKit22WebKitExtensionManager10initializeEPNS_14InjectedBundleEPN3API6ObjectE (libwebkit2gtk-4.0.so.37 + 0xd2a614)
                #13 0x00007fff7c050798 WKBundleInitialize (libwebkit2gtkinjectedbundle.so + 0x798)
                #14 0x00007fffa427adb8 _ZN6WebKit14InjectedBundle10initializeERKNS_28WebProcessCreationParametersEPN3API6ObjectE (libwebkit2gtk-4.0.so.37 + 0xe3adb8)
                #15 0x00007fffa41489d4 _ZN6WebKit14InjectedBundle6createERNS_28WebProcessCreationParametersEPN3API6ObjectE (libwebkit2gtk-4.0.so.37 + 0xd089d4)
                #16 0x00007fffa41301d0 _ZN6WebKit10WebProcess20initializeWebProcessEONS_28WebProcessCreationParametersEON3WTF17CompletionHandlerIFvvEEE (libwebkit2gtk-4.0.so.37 + 0xcf01d0)
                #17 0x00007fffa3c16890 _ZN3IPC18handleMessageAsyncIN8Messages10WebProcess20InitializeWebProcessEN6WebKit10WebProcessEMS5_FvONS4_28WebProcessCreationParametersEON3WTF17CompletionHandlerIFvvEEEEEEvRNS_10ConnectionERNS_7DecoderEPT0_T1_ (libwebkit2gtk-4.0.so.37 + 0x7d6890)
                #18 0x00007fffa3c10e3c _ZN6WebKit10WebProcess27didReceiveWebProcessMessageERN3IPC10ConnectionERNS1_7DecoderE (libwebkit2gtk-4.0.so.37 + 0x7d0e3c)
                #19 0x00007fffa4138e5c _ZN6WebKit10WebProcess17didReceiveMessageERN3IPC10ConnectionERNS1_7DecoderE (libwebkit2gtk-4.0.so.37 + 0xcf8e5c)
                #20 0x00007fffa3dba0e8 _ZN3IPC10Connection15dispatchMessageERNS_7DecoderE (libwebkit2gtk-4.0.so.37 + 0x97a0e8)
                #21 0x00007fffa3dbbe40 _ZN3IPC10Connection15dispatchMessageESt10unique_ptrINS_7DecoderESt14default_deleteIS2_EE (libwebkit2gtk-4.0.so.37 + 0x97be40)
                #22 0x00007fffa3dbc67c _ZN3IPC10Connection26dispatchOneIncomingMessageEv (libwebkit2gtk-4.0.so.37 + 0x97c67c)
                #23 0x00007fffa3dbcbf4 _ZN3WTF6Detail15CallableWrapperIZN3IPC10Connection22enqueueIncomingMessageESt10unique_ptrINS2_7DecoderESt14default_deleteIS5_EEEUlvE_vJEE4callEv (libwebkit2gtk-4.0.so.37 + 0x97cbf4)
                #24 0x00007fffa146554c _ZN3WTF7RunLoop11performWorkEv (libjavascriptcoregtk-4.0.so.18 + 0xb6554c)
                #25 0x00007fffa14cd698 _ZZN3WTF7RunLoopC4EvENUlPvE_4_FUNES1_ (libjavascriptcoregtk-4.0.so.18 + 0xbcd698)
                #26 0x00007fffa14cd720 _ZN3WTFUlP8_GSourcePFiPvES2_E_4_FUNES1_S4_S2_ (libjavascriptcoregtk-4.0.so.18 + 0xbcd720)
                #27 0x00007fffa1dbea28 g_main_context_dispatch (libglib-2.0.so.0 + 0x6ea28)
                #28 0x00007fffa1dbef08 g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0x6ef08)
                #29 0x00007fffa1dbf43c g_main_loop_run (libglib-2.0.so.0 + 0x6f43c)
                #30 0x00007fffa14ce964 _ZN3WTF7RunLoop3runEv (libjavascriptcoregtk-4.0.so.18 + 0xbce964)
                #31 0x00007fffa43a40b4 _ZN6WebKit20AuxiliaryProcessMainINS_10WebProcessENS_17WebProcessMainGtkEEEiiPPc (libwebkit2gtk-4.0.so.37 + 0xf640b4)
                #32 0x00007fffa43a33b8 _ZN6WebKit14WebProcessMainEiPPc (libwebkit2gtk-4.0.so.37 + 0xf633b8)
                #33 0x00000001350007d0 main (WebKitWebProcess + 0x7d0)
                #34 0x00007fffa31280cc generic_start_main.constprop.0.isra.0 (libc.so.6 + 0x280cc)
                #35 0x00007fffa3128290 __libc_start_main (libc.so.6 + 0x28290)

                Stack trace of thread 16:
                #0  0x00007fffa02338ec pthread_cond_wait@@GLIBC_2.17 (libpthread.so.0 + 0x138ec)
                #1  0x00007fffa31a1c50 pthread_cond_wait@@GLIBC_2.17 (libc.so.6 + 0xa1c50)
                #2  0x00007fff7deacaec util_queue_thread_func (radeonsi_dri.so + 0xa8caec)
                #3  0x00007fff7deac2c0 impl_thrd_routine (radeonsi_dri.so + 0xa8c2c0)
                #4  0x00007fffa0229618 start_thread (libpthread.so.0 + 0x9618)
                #5  0x00007fffa323cf14 __clone (libc.so.6 + 0x13cf14)
```

Comment 1 Michael Catanzaro 2020-03-24 13:21:35 UTC
This will be fixed in 2.28.1. I might add a patch sooner than that, but there's a separate bug that's breaking WebKit on all architectures I need to deal with first.

Out of curiosity, how did you get a working ppc64le setup? Are you virtualizing it somehow, or did it require special hardware...?

Comment 2 Michael Catanzaro 2020-03-24 20:49:07 UTC
(In reply to Michael Catanzaro from comment #1)
> This will be fixed in 2.28.1. I might add a patch sooner than that, but
> there's a separate bug that's breaking WebKit on all architectures I need to
> deal with first.

OK, got a build churning....

Comment 3 Fedora Update System 2020-03-24 23:56:22 UTC
FEDORA-2020-b7f42704cc has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-b7f42704cc

Comment 4 Trung LE 2020-03-25 04:55:05 UTC
> Out of curiosity, how did you get a working ppc64le setup? Are you virtualizing it somehow, or did it require special hardware...?

I am using the Raptor Blackbird workstation. Check https://www.raptorcs.com/content/BK1B02/intro.html if you are interested.

Alternatively, if you want to poke into the platform on the cloud, get in touch with integricloud.com. They are very supportive to OSS projects.

Comment 5 Fedora Update System 2020-03-25 12:03:36 UTC
FEDORA-2020-b7f42704cc has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-b7f42704cc`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-b7f42704cc

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Michael Catanzaro 2020-03-27 16:22:24 UTC
*** Bug 1817959 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2020-03-30 00:16:55 UTC
FEDORA-2020-b7f42704cc has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Trung LE 2020-04-08 03:02:09 UTC
Sorry for late reply

The issue is still there.

```
$ sudo dnf reinstall webkit2gtk3
Last metadata expiration check: 2:01:27 ago on Wed 08 Apr 2020 10:43:53 AEST.
Dependencies resolved.
======================================================================================
 Package              Architecture     Version                  Repository       Size
======================================================================================
Reinstalling:
 webkit2gtk3          ppc64le          2.28.0-8.fc32            fedora           16 M

Transaction Summary
======================================================================================


$ coredumpctl info 275577
           PID: 275577 (WebKitWebProces)
           UID: 1000 (tle)
           GID: 1000 (tle)
        Signal: 6 (ABRT)
     Timestamp: Fri 2020-04-03 00:43:09 AEDT (5 days ago)
  Command Line: /usr/libexec/webkit2gtk-4.0/WebKitWebProcess 10 38
    Executable: /usr/libexec/webkit2gtk-4.0/WebKitWebProcess
 Control Group: /user.slice/user-1000.slice/user/gnome-launched-org.gnom>
          Unit: user
     User Unit: gnome-launched-org.gnome.Epiphany.desktop-275501.scope
         Slice: user-1000.slice
     Owner UID: 1000 (tle)
       Boot ID: 0dbc1d185d0c419384a8801e5878dbdd
    Machine ID: 5632f07729a648c49d05933910ac9490
      Hostname: orion.dev
       Storage: /var/lib/systemd/coredump/core.WebKitWebProces.1000.0dbc1d185d0c41938>
       Message: Process 275577 (WebKitWebProces) of user 1000 dumped core.
                
                Stack trace of thread 2:
                #0  0x00007fff91709238 raise (libc.so.6 + 0x49238)
                #1  0x00007fff916e7c68 abort (libc.so.6 + 0x27c68)
                #2  0x00007fff8f7300d4 _ZN3JSC6Config17permanentlyFreezeEv (libjavasc>
                #3  0x00007fff8f949360 _ZN3JSC2VMC1ENS0_6VMTypeENS_8HeapTypeE (libjav>
                #4  0x00007fff8f94a0c4 _ZN3JSC2VM6createENS_8HeapTypeE (libjavascript>
                #5  0x00007fff933812a8 _ZN7WebCore12commonVMSlowEv (libwebkit2gtk-4.0>
                #6  0x00007fff933e6f74 _ZN7WebCore16ScriptController11createWorldERKN>
                #7  0x00007fff9271f618 _ZN6WebKit25InjectedBundleScriptWorld6createER>
                #8  0x00007fff9272c888 webkit_script_world_new_with_name (libwebkit2g>
                #9  0x00007fff5c078f60 ephy_web_process_extension_initialize (libephy>
                #10 0x00007fff5c079158 webkit_web_extension_initialize_with_user_data>
                #11 0x00007fff9272a09c _ZN6WebKit22WebKitExtensionManager22initialize>
                #12 0x00007fff9272a614 _ZN6WebKit22WebKitExtensionManager10initialize>
                #13 0x00007fff5c1d0798 WKBundleInitialize (libwebkit2gtkinjectedbundl>
                #14 0x00007fff9283adb8 _ZN6WebKit14InjectedBundle10initializeERKNS_28>
                #15 0x00007fff927089d4 _ZN6WebKit14InjectedBundle6createERNS_28WebPro>
                #16 0x00007fff926f01d0 _ZN6WebKit10WebProcess20initializeWebProcessEO>
                #17 0x00007fff921d6890 _ZN3IPC18handleMessageAsyncIN8Messages10WebPro>
                #18 0x00007fff921d0e3c _ZN6WebKit10WebProcess27didReceiveWebProcessMe>
                #19 0x00007fff926f8e5c _ZN6WebKit10WebProcess17didReceiveMessageERN3I>
                #20 0x00007fff9237a0e8 _ZN3IPC10Connection15dispatchMessageERNS_7Deco>
                #21 0x00007fff9237be40 _ZN3IPC10Connection15dispatchMessageESt10uniqu>
                #22 0x00007fff9237c67c _ZN3IPC10Connection26dispatchOneIncomingMessag>
                #23 0x00007fff9237cbf4 _ZN3WTF6Detail15CallableWrapperIZN3IPC10Connec>
                #24 0x00007fff8fa1554c _ZN3WTF7RunLoop11performWorkEv (libjavascriptc>
                #25 0x00007fff8fa7d698 _ZZN3WTF7RunLoopC4EvENUlPvE_4_FUNES1_ (libjava>
                #26 0x00007fff8fa7d720 _ZN3WTFUlP8_GSourcePFiPvES2_E_4_FUNES1_S4_S2_ >
                #27 0x00007fff9037ea28 g_main_context_dispatch (libglib-2.0.so.0 + 0x>
                #28 0x00007fff9037ef08 g_main_context_iterate.constprop.0 (libglib-2.>
                #29 0x00007fff9037f43c g_main_loop_run (libglib-2.0.so.0 + 0x6f43c)
                #30 0x00007fff8fa7e964 _ZN3WTF7RunLoop3runEv (libjavascriptcoregtk-4.>
                #31 0x00007fff929640b4 _ZN6WebKit20AuxiliaryProcessMainINS_10WebProce>
                #32 0x00007fff929633b8 _ZN6WebKit14WebProcessMainEiPPc (libwebkit2gtk>
                #33 0x00000001125607d0 main (WebKitWebProcess + 0x7d0)
                #34 0x00007fff916e80cc generic_start_main.constprop.0.isra.0 (libc.so>
                #35 0x00007fff916e8290 __libc_start_main (libc.so.6 + 0x28290)
                
                Stack trace of thread 3:
                #0  0x00007fff917ec55c __poll (libc.so.6 + 0x12c55c)
                #1  0x00007fff903965d8 g_poll (libglib-2.0.so.0 + 0x865d8)
                #2  0x00007fff9037ee84 g_main_context_iterate.constprop.0 (libglib-2.>
                #3  0x00007fff9037f02c g_main_context_iteration (libglib-2.0.so.0 + 0>
                #4  0x00007fff9037f0bc glib_worker_main (libglib-2.0.so.0 + 0x6f0bc)
                #5  0x00007fff903be2bc g_thread_proxy (libglib-2.0.so.0 + 0xae2bc)
                #6  0x00007fff903f33dc linux_pthread_proxy (libglib-2.0.so.0 + 0xe33d>
                #7  0x00007fff8e7d9618 start_thread (libpthread.so.0 + 0x9618)
                #8  0x00007fff917fcf64 __clone (libc.so.6 + 0x13cf64)
```

Comment 9 Michael Catanzaro 2020-04-08 13:50:41 UTC
OK, drat. The patch I used in Fedora is much simpler than the one I committed upstream, but it really should have been sufficient. :/ But I know the upstream patch actually works, because it fixed our internal CI when it landed. So first thing to try is to switch to the upstream patch instead. Will prepare a new build soon-ish.

Comment 10 Michael Catanzaro 2020-04-09 21:38:00 UTC
Second attempt incoming. Please test. I've swapped out my downstream patch for a series of patches from upstream, which worked for our internal ppc64le CI. That doesn't mean the new package will necessarily work....

Comment 11 Fedora Update System 2020-04-09 22:32:25 UTC
FEDORA-2020-d8fe19dd97 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-d8fe19dd97

Comment 12 Fedora Update System 2020-04-09 23:28:43 UTC
FEDORA-2020-98405f3ecd has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-98405f3ecd

Comment 13 Fedora Update System 2020-04-10 00:18:03 UTC
FEDORA-2020-4dfdc0a022 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-4dfdc0a022

Comment 14 Trung LE 2020-04-10 04:54:32 UTC
I grab the updated RPMs from the build https://koji.fedoraproject.org/koji/buildinfo?buildID=1491868

```
wget https://kojipkgs.fedoraproject.org//packages/webkit2gtk3/2.28.0/9.fc32/ppc64le/webkit2gtk3-2.28.0-9.fc32.ppc64le.rpm
wget https://kojipkgs.fedoraproject.org//packages/webkit2gtk3/2.28.0/9.fc32/ppc64le/webkit2gtk3-jsc-2.28.0-9.fc32.ppc64le.rpm
rpm -i --force *.rpm

$ dnf info webkit2gtk3
Last metadata expiration check: 0:02:10 ago on Fri 10 Apr 2020 14:51:01 AEST.
Installed Packages
Name         : webkit2gtk3
Version      : 2.28.0
Release      : 9.fc32
Architecture : ppc64le
Size         : 65 M
Source       : webkit2gtk3-2.28.0-9.fc32.src.rpm
Repository   : @System
Summary      : GTK Web content engine library
URL          : https://www.webkitgtk.org/
License      : LGPLv2
Description  : WebKitGTK is the port of the portable web rendering engine WebKit to the
             : GTK platform.
             : 
             : This package contains WebKit2 based WebKitGTK for GTK 3.

[tle@orion Downloads]$ epiphany 
Aborted (core dumped)
[tle@orion Downloads]$ dnf info webkit2gtk3-jsc
Last metadata expiration check: 0:02:27 ago on Fri 10 Apr 2020 14:51:01 AEST.
Installed Packages
Name         : webkit2gtk3-jsc
Version      : 2.28.0
Release      : 9.fc32
Architecture : ppc64le
Size         : 14 M
Source       : webkit2gtk3-2.28.0-9.fc32.src.rpm
Repository   : @System
Summary      : JavaScript engine from webkit2gtk3
URL          : https://www.webkitgtk.org/
License      : LGPLv2
Description  : This package contains JavaScript engine from webkit2gtk3.

``` 

and re-produce the steps, however the issue still persist, below is the trace:

```
$ coredumpctl info 9211
           PID: 9211 (epiphany)
           UID: 1000 (tle)
           GID: 1000 (tle)
        Signal: 6 (ABRT)
     Timestamp: Fri 2020-04-10 14:53:20 AEST (33s ago)
  Command Line: epiphany
    Executable: /usr/bin/epiphany
 Control Group: /user.slice/user-1000.slice/user/apps.slice/apps-org.gnome.Terminal.slice/vte-spawn-dad22774-a831-4250-811b-68dd5f4d709e.scope
          Unit: user
     User Unit: vte-spawn-dad22774-a831-4250-811b-68dd5f4d709e.scope
         Slice: user-1000.slice
     Owner UID: 1000 (tle)
       Boot ID: e92cda0905de409ba60e02658a42df73
    Machine ID: 5632f07729a648c49d05933910ac9490
      Hostname: orion.dev
       Storage: /var/lib/systemd/coredump/core.epiphany.1000.e92cda0905de409ba60e02658a42df73.9211.1586494400000000000000.lz4
       Message: Process 9211 (epiphany) of user 1000 dumped core.
                
                Stack trace of thread 9211:
                #0  0x00007fff9a589238 raise (libc.so.6 + 0x49238)
                #1  0x00007fff9a567c68 abort (libc.so.6 + 0x27c68)
                #2  0x00007fff95b85bd4 _ZN3JSC8JSObject16ensureLengthSlowERNS_2VMEj (libjavascriptcoregtk-4.0.so.18 + 0x915bd4)
                #3  0x00007fff95ba7ec4 _ZN3JSC8JSObject45putByIndexBeyondVectorLengthWithoutAttributesILh8EEEbPNS_14JSGlobalObjectEjNS_7JSValueE (libjavascriptcoregtk-4.0.s>
                #4  0x00007fff95b881dc _ZN3JSC8JSObject38putDirectIndexSlowOrBeyondVectorLengthEPNS_14JSGlobalObjectEjNS_7JSValueEjNS_18PutDirectIndexModeE (libjavascriptco>
                #5  0x00007fff95c1839c _ZN3JSC13LiteralParserIhE5parseENS_11ParserStateE (libjavascriptcoregtk-4.0.so.18 + 0x9a839c)
                #6  0x00007fff95b7bef8 _ZN3JSC9JSONParseEPNS_14JSGlobalObjectERKN3WTF6StringE (libjavascriptcoregtk-4.0.so.18 + 0x90bef8)
                #7  0x00007fff97b61a94 _ZN7WebCore17ContentExtensions13parseRuleListERKN3WTF6StringE (libwebkit2gtk-4.0.so.37 + 0x1a71a94)
                #8  0x00007fff96c36558 _ZN3API20ContentRuleListStore22compileContentRuleListERKN3WTF6StringEOS2_NS1_17CompletionHandlerIFvNS1_6RefPtrINS_15ContentRuleListEN>
                #9  0x00007fff96cc4e54 _ZL37webkitUserContentFilterStoreSaveBytesON3WTF7GRefPtrI6_GTaskEEONS_6StringEONS0_I7_GBytesEE.isra.0 (libwebkit2gtk-4.0.so.37 + 0xbd>
                #10 0x00007fff96cc54e8 webkit_user_content_filter_store_save (libwebkit2gtk-4.0.so.37 + 0xbd54e8)
                #11 0x00007fff9b99117c filter_info_setup_load_file (libephymain.so + 0xb117c)
                #12 0x00007fff9b991758 download_completed_cb (libephymain.so + 0xb1758)
                #13 0x00007fff9abeb00c g_cclosure_marshal_VOID__VOIDv (libgobject-2.0.so.0 + 0x1b00c)
                #14 0x00007fff9abe7d30 _g_closure_invoke_va (libgobject-2.0.so.0 + 0x17d30)
                #15 0x00007fff9ac0bed4 g_signal_emit_valist (libgobject-2.0.so.0 + 0x3bed4)
                #16 0x00007fff9ac0c050 g_signal_emit (libgobject-2.0.so.0 + 0x3c050)
                #17 0x00007fff9b97f0f4 download_finished_cb (libephymain.so + 0x9f0f4)
                #18 0x00007fff9abeaf50 g_cclosure_marshal_VOID__VOID (libgobject-2.0.so.0 + 0x1af50)
                #19 0x00007fff9abe79dc g_closure_invoke (libgobject-2.0.so.0 + 0x179dc)
```

Comment 15 Fedora Update System 2020-04-10 16:56:33 UTC
FEDORA-2020-d8fe19dd97 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-d8fe19dd97`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-d8fe19dd97

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Michael Catanzaro 2020-04-10 20:51:09 UTC
(In reply to Trung LE from comment #14) 
> and re-produce the steps, however the issue still persist, below is the
> trace:

The crash you just posted is completely different than before, so it looks like the original issue is likely fixed. :)

Try disabling the adblocker and consider reporting a new bug for this new crash (preferably upstream).

Comment 17 Fedora Update System 2020-04-10 21:37:00 UTC
FEDORA-2020-4dfdc0a022 has been pushed to the Fedora 30 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-4dfdc0a022`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-4dfdc0a022

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 18 Trung LE 2020-04-11 02:01:59 UTC
@Michael: I will submit a new bug ticket instead. Please feel free to close this ticket for me.

Comment 19 Fedora Update System 2020-04-11 18:51:12 UTC
FEDORA-2020-98405f3ecd has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-98405f3ecd`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-98405f3ecd

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 20 Dan Horák 2020-04-29 08:50:00 UTC
One more note - when I see callbacks and glib marshalling in a backtrace, then it reminds me the issues with expected vs. actual arguments passed to the callback. There might be an issue in epiphany too. See bug 1631759 (gcr) or 1720701 (gthumb).

Comment 21 Michael Catanzaro 2020-04-29 16:09:11 UTC
afaik the only open ppc64le bug currently is https://bugs.webkit.org/show_bug.cgi?id=210685, which looks different.


Note You need to log in before you can comment on or make changes to this bug.