Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1816547 - Firefox not using langpacks for localization
Summary: Firefox not using langpacks for localization
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Jan Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F33FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2020-03-24 09:16 UTC by Bhushan Barve
Modified: 2020-10-06 12:16 UTC (History)
20 users (show)

Fixed In Version: firefox-74.0.1-3.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-06 12:16:14 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Bhushan Barve 2020-03-24 09:16:50 UTC
Description of problem: Installed F32 beta in ja_JP locale. After starting Firefox, observed that it is loading in English only. 

The locale langpack is installed - 
langpacks-ja-3.0-3.fc32.noarch

Also the firefox langpack is present - 
[test@localhost-live ~]$ rpm -ql firefox | grep langpack-ja
/usr/lib64/firefox/langpacks/langpack-ja.org.xpi


Version-Release number of selected component (if applicable):
firefox-74.0-5.fc32.x86_64
F32 beta

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
Firefox is loading in English

Expected results:
Firefox should load according to the locale.

Additional info:

Comment 1 Martin Stransky 2020-03-24 09:33:11 UTC
Can you try a different locale please?
Thanks.

Comment 2 Jens Petersen 2020-03-24 09:58:28 UTC
This is rather easy to reproduce in F32: eg just boot latest F32 Live iso (I tested with Fedora-Workstation-Live-x86_64-32-20200323.n.0.iso), and then:

run: LANG=de_DE.utf8 firefox

Comment 3 Bhushan Barve 2020-03-24 10:04:04 UTC
I opened following page through Firefox - file://usr/lib64/firefox/langpacks/

From there, I installed langpack-ka.org.xpi and Firefox loaded in Japanese then.

Comment 4 Bhushan Barve 2020-03-24 10:05:08 UTC
(In reply to Bhushan Barve from comment #3)
> I opened following page through Firefox - file://usr/lib64/firefox/langpacks/
> 
> From there, I installed langpack-ka.org.xpi and Firefox
> loaded in Japanese then.

My mistake. It should be - langpack-ja.org.xpi

Comment 5 Jens Petersen 2020-03-24 11:53:37 UTC
I happened to try with Fedora-Workstation-Live-x86_64-32-20200309.n.0.iso
which has firefox-72.0.2-3.fc32, and with that localization still works.

Comment 6 Jens Petersen 2020-03-24 12:00:12 UTC
Whereas with Fedora-Workstation-Live-x86_64-32-20200314.n.0.iso with firefox-74.0-1.nss.fc32
translations are not shown.

Comment 7 Jens Petersen 2020-03-24 13:48:03 UTC
I can also reproduce with firefox-74.0-3.fc31 using F31-WORK-x86_64-LIVE-20200319.iso,
whereas firefox-73.0.1-1.fc31 in F31-WORK-x86_64-LIVE-20200303.iso is okay.

Comment 8 Kamil Páral 2020-03-25 07:31:18 UTC
Proposing as a final blocker:
"All critical path actions on release-blocking desktops must correctly display all sufficiently complete translations available for use."
https://fedoraproject.org/wiki/Fedora_32_Final_Release_Criteria
where https://fedoraproject.org/wiki/Critical_path_package#Actions includes "networking". I don't know whether that includes just network configuration or also browsing the web.

Comment 9 Martin Stransky 2020-03-25 09:47:19 UTC
Jan is going to look at it.

Comment 10 sandeep shedmake 2020-03-30 13:42:36 UTC
(In reply to Jens Petersen from comment #2)
> This is rather easy to reproduce in F32: eg just boot latest F32 Live iso (I
> tested with Fedora-Workstation-Live-x86_64-32-20200323.n.0.iso), and then:
> 
> run: LANG=de_DE.utf8 firefox

seems LANG variable [1] is not getting respected by 'firefox'

[1] https://src.fedoraproject.org/rpms/firefox/blob/HEAD/f/firefox.sh.in#_198

Comment 11 Geoffrey Marr 2020-03-30 19:05:45 UTC
Discussed during the 2020-03-30 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedBlocker" was made as it violates the following criterion :

"All critical path actions on release-blocking desktops must correctly display all sufficiently complete translations available for use."

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-03-30/f32-blocker-review.2020-03-30-16.00.txt

Comment 12 Martin Stransky 2020-03-30 19:31:00 UTC
Thanks for tracking, we'll look at it.

Comment 13 Jan Horak 2020-04-06 19:00:23 UTC
That's going to be fixed in next update in few days.

Comment 14 Martin Stransky 2020-04-06 19:09:18 UTC
Should be fixed by firefox-74.0.1-3.

Comment 15 Fedora Update System 2020-04-06 19:14:57 UTC
FEDORA-2020-22deb6c198 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-22deb6c198

Comment 16 Fedora Update System 2020-04-06 19:14:58 UTC
FEDORA-2020-1691cb65d3 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-1691cb65d3

Comment 17 Fedora Update System 2020-04-06 19:14:59 UTC
FEDORA-2020-cb779fd2ed has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-cb779fd2ed

Comment 18 Adam Williamson 2020-04-06 19:17:09 UTC
This was filed against F32 and is an F32 release blocker. Please don't close it for a Rawhide build. Thanks!

Comment 19 Adam Williamson 2020-04-06 19:18:20 UTC
I also edited the F30 and F31 updates to not close this bug when pushed stable, so they don't close it while the F32 update is not pushed yet.

Comment 20 Martin Stransky 2020-04-06 19:50:19 UTC
Okay, sorry for that.

Comment 21 Fedora Update System 2020-04-07 02:28:11 UTC
FEDORA-2020-22deb6c198 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-22deb6c198`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-22deb6c198

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 22 Fedora Update System 2020-04-07 03:10:25 UTC
FEDORA-2020-1691cb65d3 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-1691cb65d3`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-1691cb65d3

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 23 Fedora Update System 2020-04-07 03:46:48 UTC
FEDORA-2020-cb779fd2ed has been pushed to the Fedora 30 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-cb779fd2ed`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-cb779fd2ed

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 24 Kamil Páral 2020-04-07 09:35:50 UTC
(In reply to Fedora Update System from comment #21)
> https://bodhi.fedoraproject.org/updates/FEDORA-2020-22deb6c198

With firefox-74.0.1-3.fc32.x86_64 things have improved, but still are a bit weird. The first run after changing language still shows English, and only subsequent runs show in the selected language:

$ firefox                       # shows in English
$ LANG=de_DE.utf8 firefox       # shows in English
$ LANG=de_DE.utf8 firefox       # shows in German
$ LANG=de_DE.utf8 firefox       # shows in German
$ LANG=cs_CZ.utf8 firefox       # shows in English
$ LANG=cs_CZ.utf8 firefox       # shows in Czech
$ LANG=cs_CZ.utf8 firefox       # shows in Czech

Comment 25 Kamil Páral 2020-04-07 10:06:18 UTC
I installed Workstation in Czech, updated to firefox-74.0.1-3.fc32, ran it, and it showed in Czech from the first run. So for blocker purposes, I think this problem is resolved with firefox-74.0.1-3.fc32. There are still some corner cases as shown above, but it doesn't affect the common use case.

Comment 26 Martin Stransky 2020-04-07 10:27:28 UTC
(In reply to Kamil Páral from comment #25)
> I installed Workstation in Czech, updated to firefox-74.0.1-3.fc32, ran it,
> and it showed in Czech from the first run. So for blocker purposes, I think
> this problem is resolved with firefox-74.0.1-3.fc32. There are still some
> corner cases as shown above, but it doesn't affect the common use case.

This is a known issue with Firefox extension system caused by delayed loading of extensions after the point where language is set.
We tried to fix that but we failed as it needs to rework how Firefox uses and cache the extensions.
BTW. this bug is here for 2-3 years already from the point where Firefox switched to WebExtensions.

Comment 27 Lukas Ruzicka 2020-04-07 11:44:15 UTC
Yes, I just wanted to add, that if, after a reboot, you start firefox with LANG set to the language you want, it shows the chosen language, even if the installed language is different. Seems I am coming too late again. :)

Comment 28 Kamil Páral 2020-04-07 11:48:35 UTC
(In reply to Martin Stransky from comment #26)
> This is a known issue with Firefox extension system caused by delayed
> loading of extensions after the point where language is set.
> We tried to fix that but we failed as it needs to rework how Firefox uses
> and cache the extensions.
> BTW. this bug is here for 2-3 years already from the point where Firefox
> switched to WebExtensions.

Thanks for the info. So let's consider this particular bug resolved.

Comment 29 Fedora Update System 2020-04-08 02:53:42 UTC
FEDORA-2020-22deb6c198 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 30 Fedora Update System 2020-04-08 05:06:54 UTC
FEDORA-2020-1691cb65d3 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 31 Fedora Update System 2020-04-08 05:28:21 UTC
FEDORA-2020-cb779fd2ed has been pushed to the Fedora 30 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 32 Bhushan Barve 2020-09-08 07:47:46 UTC
Experiencing the similar issue with F33.(Fedora-Everything-netinst-x86_64-33-20200906.n.0)

Installed locale - ja_JP
Firefox version - Firefox-78.0.2-1.fc33.x86_64

With the default locale which is ja_JP, Firefox was still loaded in English.
As per comment #3, opened - file://usr/lib64/firefox/langpacks/ in firefox and installed add on- langpack-ja.org.xpi

After that firefox was loaded in Japanese.
Re-opening it.

Comment 33 Adam Williamson 2020-09-08 19:35:08 UTC
logically, then, proposing as an F33 final blocker...if it's back, it's probably still a blocker.

Comment 34 Kamil Páral 2020-09-10 14:12:35 UTC
I can confirm this problem when running a Workstation Live image (Fedora-Workstation-Live-x86_64-33-20200909.n.0.iso). Running the commands from comment 24 always shows Firefox in English (unlike e.g. gedit which changes its language properly).

Comment 35 Geoffrey Marr 2020-09-14 20:23:54 UTC
Discussed during the 2020-09-14 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedBlocker (Final)" was made as it violates the following criterion:

"All critical path actions on release-blocking desktops must correctly display all sufficiently complete translations available for use" (with precedent from a similar bug in F32)

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-09-14/f33-blocker-review.2020-09-14-16.01.txt

Comment 36 Martin Stransky 2020-10-05 20:46:59 UTC
I just checked my F33 installation (not a live image) and this command:

$LANG=ja_JP.utf8 firefox

shows Firefox localized. Works for other localization too, package firefox-81.0.1-1.fc33.

Note that there's a bug when first Firefox launch when localization changes or with a new profile is uses default (en_US) localization. I can't find the bug right now but it's related to how Firefox handles extensions.

Comment 37 Kamil Páral 2020-10-06 12:16:14 UTC
I tested this live on Fedora-Workstation-Live-x86_64-33-20201003.n.0.iso and it works as expected (using the approach from comment 24). This seems fixed.


Note You need to log in before you can comment on or make changes to this bug.