Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1818807 - gnome-contacts select local address book done button does nothing
Summary: gnome-contacts select local address book done button does nothing
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-contacts
Version: 33
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Elad Alfassa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException AcceptedBlocker
Depends On:
Blocks: F33BetaFreezeException F33FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2020-03-30 12:39 UTC by David Ober
Modified: 2020-08-26 11:25 UTC (History)
9 users (show)

Fixed In Version: gnome-contacts-3.37.2-1.fc33 gnome-contacts-3.37.2-1.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-26 11:25:13 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME gnome-contacts issues 178 0 None None None 2020-08-23 22:26:04 UTC

Description David Ober 2020-03-30 12:39:16 UTC
Description of problem:Launching contacts does not work


Version-Release number of selected component (if applicable):


How reproducible:always


Steps to Reproduce:
1.launch contact application
2.select local address book
3.click done

Actual results: nothing happens


Expected results:expect to go to address book edit mode


Additional info:

Comment 1 Chris Murphy 2020-08-23 22:26:04 UTC
Happens in gnome-contacts-3.37.1-1.fc33.x86_64
Adding upstream tracking bug.

Comment 2 Fedora Blocker Bugs Application 2020-08-23 22:29:09 UTC
Proposed as a Blocker and Freeze Exception for 33-final by Fedora user chrismurphy using the blocker tracking app because:

 Proposing for beta freeze exception, and final blocker.

Final release criterion: All applications that can be launched using the standard graphical mechanism after a default installation of Fedora Workstation on the x86_64 architecture must start successfully and withstand a basic functionality test.

Comment 3 Jonathan Haas 2020-08-24 11:45:16 UTC
I assume you wanted to propose as Beta Freeze Exception from the text, so I fixed that.

Comment 4 Kamil Páral 2020-08-24 12:23:29 UTC
I can confirm this problem with gnome-contacts-3.37.1-1.fc33.x86_64. Local address book can't be selected, nothing else can be done.

Comment 5 Kalev Lember 2020-08-24 15:06:12 UTC
Should be fixed in gnome-contacts-3.37.2-1.fc33 -- can someone test that it works as expected now, please?

Comment 6 Adam Williamson 2020-08-24 22:09:47 UTC
Discussed at 2020-08-24 freeze exception and blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2020-08-24/f33-blocker-review.2020-08-24-16.07.html . Accepted as a Beta freeze exception and a Final blocker - it violates the Final criterion cited in #c2, and obviously will affect Beta lives that can't be fixed with an update so it makes sense to grant it a freeze exception.

Comment 7 Kamil Páral 2020-08-26 11:25:13 UTC
(In reply to Kalev Lember from comment #5)
> Should be fixed in gnome-contacts-3.37.2-1.fc33 -- can someone test that it
> works as expected now, please?

I can confirm this problem is fixed with gnome-contacts-3.37.2-1.fc33.x86_64. It's stable already, closing.


Note You need to log in before you can comment on or make changes to this bug.