Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1820396 - gnome-tweaks cannot open extension dialog preferences
Summary: gnome-tweaks cannot open extension dialog preferences
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-tweaks
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mohamed El Morabity
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1819644 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-03 00:40 UTC by Real Name
Modified: 2020-04-11 17:35 UTC (History)
3 users (show)

Fixed In Version: gnome-tweaks-3.34.0-4.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-06 00:17:05 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
call gnome-extensions instead (deleted)
2020-04-03 19:29 UTC, Real Name
no flags Details | Diff

Description Real Name 2020-04-03 00:40:06 UTC
Description of problem:
Since the 3.36.1 upgrade, GNOME Tweaks cannot open preferences for shell extensions. Running it from a terminal shows the following error:

(gnome-shell-extension-prefs:72338): GLib-GIO-CRITICAL **: 21:22:37.662: This application can not open files.


Version-Release number of selected component (if applicable):
gnome-tweaks-3.34.0-3.fc32.noarch


How reproducible:
Always


Steps to Reproduce:
1. Install an extension that has preferences
2. Open GNOME Tweaks, click "Extensions" and click the gear icon for an extension
3. Nothing happens, the error above is shown if running from a terminal


Actual results:
GNOME Tweaks cannot open extension preferences


Expected results:
GNOME Tweaks should be able to open the preferences dialog for shell extensions


Additional info:
This also breaks Dash to Dock and OpenWeather, which apparently call gnome-shell-extension-prefs directly as well (don't know how to check but I'm aware it's NotYourProblem™). Calling the preferences dialog from the browser still works, and so does running the Extensions app directly.

Tested on a clean user profile, still reproducible.

Comment 1 Leslie Satenstein 2020-04-03 15:24:22 UTC
Problem was corrected with Koji version (April 2) 

April 3.  Problem has returned.  It was broken for 2 weeks, then  the koji patch fixed it.  And today, that patch is broken. 
One cannot update extensions.

Comment 2 Real Name 2020-04-03 19:29:03 UTC
Created attachment 1676115 [details]
call gnome-extensions instead

A one-line fix to make it call 'gnome-extensions prefs <uuid>' instead of gnome-shell-extension-prefs

Comment 3 Mohamed El Morabity 2020-04-04 11:23:05 UTC
(In reply to Real Name from comment #2)
> Created attachment 1676115 [details]
> call gnome-extensions instead
> 
> A one-line fix to make it call 'gnome-extensions prefs <uuid>' instead of
> gnome-shell-extension-prefs

Thanks for the fix, this will be integrated in an up-to-come update.

(In reply to Real Name from comment #0)
> Description of problem:
> Additional info:
> This also breaks Dash to Dock and OpenWeather, which apparently call
> gnome-shell-extension-prefs directly as well (don't know how to check but
> I'm aware it's NotYourProblem™). Calling the preferences dialog from the
> browser still works, and so does running the Extensions app directly.

I haven't found open bugs for this same problem for these extensions.
You should create a ticket for each of these packages, with a reference to this ticket:
* Dash to Dock: https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&component=gnome-shell-extension-dash-to-dock&version=32
* OpenWeather: https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&component=gnome-shell-extension-openweather&version=32

Comment 4 Mohamed El Morabity 2020-04-04 11:23:39 UTC
*** Bug 1819644 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2020-04-04 11:24:34 UTC
FEDORA-2020-77187eea3e has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-77187eea3e

Comment 6 Ian Laurie 2020-04-05 02:37:00 UTC
gnome-tweaks-3.34.0-4.fc32 and gnome-tweaks-3.34.0-4.fc33 are working for me in fc32 and Rawhide respectively.

Comment 7 Fedora Update System 2020-04-05 04:50:01 UTC
FEDORA-2020-77187eea3e has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-77187eea3e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-77187eea3e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2020-04-06 00:17:05 UTC
FEDORA-2020-77187eea3e has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Leslie Satenstein 2020-04-11 06:18:41 UTC
April 11, 

Still not in koji, I would like to test the corrective.

Not in Gnome 3.36.1  (Fedora 32 version of Gnome

Comment 10 Real Name 2020-04-11 17:35:09 UTC
(In reply to Leslie Satenstein from comment #9)
> April 11, 
> 
> Still not in koji, I would like to test the corrective.
> 
> Not in Gnome 3.36.1  (Fedora 32 version of Gnome

It hit stable 5 days ago.

Installed Packages
Name         : gnome-tweaks
Version      : 3.34.0
Release      : 4.fc32
Architecture : noarch
Size         : 1.4 M
Source       : gnome-tweaks-3.34.0-4.fc32.src.rpm
Repository   : @System
From repo    : fedora


Note You need to log in before you can comment on or make changes to this bug.