Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1822561 - Review Request: wget2 - the successor of GNU Wget, a file and recursive website downloader
Summary: Review Request: wget2 - the successor of GNU Wget, a file and recursive websi...
Keywords:
Status: CLOSED DUPLICATE of bug 2007965
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Neal Gompa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-09 10:42 UTC by Anna Khaitovich
Modified: 2021-09-26 15:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-26 15:00:53 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Anna Khaitovich 2020-04-09 10:42:21 UTC
Spec: https://download.copr.fedorainfracloud.org/results/akhaitov/wget2/fedora-rawhide-x86_64/01332110-wget2/wget2.spec

SRPM: https://download.copr.fedorainfracloud.org/results/akhaitov/wget2/fedora-rawhide-x86_64/01332110-wget2/wget2-1.99.2-1.fc33.src.rpm

Description:
GNU Wget2 is the successor of GNU Wget, a file and recursive website downloader.
Designed and written from scratch it wraps around libwget, that provides the basic
functions needed by a web client.
Wget2 works multi-threaded and uses many features to allow fast operation.
In many cases Wget2 downloads much faster than Wget1.x due to HTTP2, HTTP compression,
parallel connections and use of If-Modified-Since HTTP header.

Comment 1 Peter Lemenkov 2020-04-10 10:59:49 UTC
Provides: libtool
Provides: wget2-debugsource = 1.99.2-1
Provides: wget2-debuginfo = 1.99.2-1
# Versioned libraries
Provides: libwget.so.0
Provides: libwget_alloc.so.0
Provides: libwget_common.so.0
Provides: libwget_css.so.0
Provides: libwget_dns.so.0
Provides: libwget_dnscache.so.0
Provides: libwget_encoding.so.0
Provides: libwget_hashfile.so.0
Provides: libwget_hpkp_db.so.0
Provides: libwget_ip.so.0
Provides: libwget_iri.so.0
Provides: libwget_logger.so.0
Provides: libwget_metalink.so.0

^^^ This looks wrong. Please remove it. 

%{_libdir}/libwget*.a
%{_libdir}/libwget*.la

^^^ These files shouldn't be packaged.

Comment 2 Peter Lemenkov 2020-04-10 11:01:10 UTC
Also you likely mean devel sub-packages of these packages, not the packages itself:

BuildRequires: glibc
BuildRequires: zlib >= 1.2.3
BuildRequires: gnutls
BuildRequires: libidn2 >= 0.14
BuildRequires: flex >= 2.5.35
BuildRequires: libpsl >= 0.5.0

# Optional
# HTTP/2 support
BuildRequires: libnghttp2 >= 1.3.0
# run the test suite
BuildRequires: libmicrohttpd >= 0.9.51
# build distribution tarballs
BuildRequires: lzip
# coverage reports
BuildRequires: lcov
# automatic signature verification)
BuildRequires: gpgme >= 0.4.2
# filtering by PCRE regex
BuildRequires: pcre
# HTTP zstd decompression)
BuildRequires: libzstd >= 1.3.0

Comment 3 Neal Gompa 2020-04-10 12:57:11 UTC
Taking this review.

Comment 5 Package Review 2021-05-05 00:45:36 UTC
This is an automatic check from review-stats script.

This review request ticket hasn't been updated for some time, but it seems
that the review is still being working out by you. If this is right, please
respond to this comment clearing the NEEDINFO flag and try to reach out the
submitter to proceed with the review.

If you're not interested in reviewing this ticket anymore, please clear the
fedora-review flag and reset the assignee, so that a new reviewer can take
this ticket.

Without any reply, this request will shortly be resetted.

Comment 6 Neal Gompa 2021-05-05 11:33:32 UTC
Anna, we don't generally ship libtool archives, so those should be deleted. The end result would be that we wouldn't have a -static subpackage.

Please delete libtool archives and remove the -static subpackage.

See: https://docs.fedoraproject.org/en-US/packaging-guidelines/#packaging-static-libraries

Comment 7 Neal Gompa 2021-09-26 15:00:53 UTC
As Anna no longer works at Red Hat and cannot be contacted, this review is effectively dead and superseded by a new one.

*** This bug has been marked as a duplicate of bug 2007965 ***


Note You need to log in before you can comment on or make changes to this bug.