Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1829329 - Firewox crashes - moz_container_get_wl_surface
Summary: Firewox crashes - moz_container_get_wl_surface
Keywords:
Status: CLOSED DUPLICATE of bug 1888920
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1847005 (view as bug list)
Depends On:
Blocks: ffwayland
TreeView+ depends on / blocked
 
Reported: 2020-04-29 12:00 UTC by Vít Ondruch
Modified: 2020-10-29 19:20 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-26 21:12:31 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
about:support content (deleted)
2020-09-14 07:31 UTC, Vít Ondruch
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1819195 0 unspecified CLOSED Firewox crashes - moz_container_get_wl_surface 2021-02-22 00:41:40 UTC

Description Vít Ondruch 2020-04-29 12:00:53 UTC
Unfortunately, it seems that the fix for Bug #1819195 was not enough. I still have occasional crashes, although not that often. One happened today:

https://crash-stats.mozilla.org/report/index/edb65646-bc3b-484f-90a3-4cf820200429

It was (as always) during BlueJeans meeting, when I was talking :/

~~~
$ rpm -q firefox
firefox-75.0-2.fc33.x86_64
~~~

Comment 1 Martin Stransky 2020-04-29 18:28:10 UTC
It looks like https://bugzilla.mozilla.org/show_bug.cgi?id=1628583 which may be a bit difficult to backport :(

Comment 2 Martin Stransky 2020-04-29 18:29:28 UTC
Can you try to use Firefox nightly with Wayland for the BJ session and check if you see any crash there?
Thanks.

Comment 3 Vít Ondruch 2020-05-12 12:31:35 UTC
Yet another appearance of the issue:

https://crash-stats.mozilla.org/report/index/aade3128-d516-49b8-b1dc-3f8070200512


~~~
$ rpm -q firefox
firefox-76.0-2.fc33.x86_64
~~~

Comment 4 Martin Stransky 2020-05-12 12:35:13 UTC
Yes, Bug 1628583 is fixed in FF77.

Comment 5 Martin Stransky 2020-05-27 06:18:28 UTC
Firefox 77 is coming next week but can you try to enable webrender? It should solve the https://crash-stats.mozilla.org/report/index/aade3128-d516-49b8-b1dc-3f8070200512
Go to about:config and set gfx.webrender.enabled to true.

Comment 6 Vít Ondruch 2020-05-29 08:58:18 UTC
(In reply to Martin Stransky from comment #5)
> Go to about:config and set gfx.webrender.enabled to true.

Does this need FF restart? Will this option become default in FF 77?

Comment 7 Martin Stransky 2020-05-29 10:16:00 UTC
(In reply to Vít Ondruch from comment #6)
> (In reply to Martin Stransky from comment #5)
> > Go to about:config and set gfx.webrender.enabled to true.
> 
> Does this need FF restart?

Yes.

> Will this option become default in FF 77?

No, it enrolls slowly, see https://wiki.mozilla.org/Platform/GFX/WebRender_Where

Comment 8 Vít Ondruch 2020-06-15 12:30:22 UTC
I don't thin I have met the issue in recent days (using FF 77 since June 9). Instead, I hit today another issue (bug 1847005).

Comment 9 Martin Stransky 2020-06-16 13:32:26 UTC
*** Bug 1847005 has been marked as a duplicate of this bug. ***

Comment 10 Martin Stransky 2020-06-16 13:33:35 UTC
It's the same bug but with a different bt. 78 should fix that, it comes out 30.6.

Comment 11 Vít Ondruch 2020-07-13 12:06:47 UTC
Is this something different?

https://crash-stats.mozilla.org/report/index/5bff3195-2fd8-4245-ba3f-826990200713

This happened with firefox-78.0-1.fc33.x86_64

Comment 12 Vít Ondruch 2020-07-15 08:51:51 UTC
And also with firefox-78.0.2-1.fc33.x86_64:

https://crash-stats.mozilla.org/report/index/69219597-e8dd-4c8c-9541-feb5d0200715

Comment 13 Vít Ondruch 2020-07-15 08:54:59 UTC
The previous crashes typically happened during confcalls via Bluejeans. But the following happened when I was typing into the search box of "Simple Tab Groups" extension:

https://crash-stats.mozilla.org/report/index/0c5bbfb0-b121-498f-bea3-b43fa0200715

Comment 14 Martin Stransky 2020-07-21 09:30:32 UTC
(In reply to Vít Ondruch from comment #13)
> The previous crashes typically happened during confcalls via Bluejeans. But
> the following happened when I was typing into the search box of "Simple Tab
> Groups" extension:
> 
> https://crash-stats.mozilla.org/report/index/0c5bbfb0-b121-498f-bea3-
> b43fa0200715

This is fixed by https://bugzilla.mozilla.org/show_bug.cgi?id=1641778 which comes in Firefox 79 next week.

Comment 15 Ben Cotton 2020-08-11 13:21:14 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 33 development cycle.
Changing version to 33.

Comment 16 Vít Ondruch 2020-09-04 12:37:21 UTC
It seems that the situation with FF 79 is better then it used to be, but:

https://crash-stats.mozilla.org/report/index/f58e44ca-de4c-4875-9c04-e0f300200904

Comment 17 Martin Stransky 2020-09-13 18:34:30 UTC
Will look at it, Thanks.

Comment 18 Martin Stransky 2020-09-13 18:35:11 UTC
btw. Can you please attach content of about:support?
Thanks.

Comment 19 Vít Ondruch 2020-09-14 07:31:39 UTC
Created attachment 1714727 [details]
about:support content

Comment 20 Martin Stransky 2020-09-30 14:23:18 UTC
Do you still see the crashes with Firefox 81?
Thanks.

Comment 21 Vít Ondruch 2020-09-30 16:01:40 UTC
I am still on firefox-79.0-5.fc32.x86_64 (because it seems you had issue building FF for Rawhide for some while), but looking at about:crashes it seems the last crash I observed was the one I referred above on Sept 4. Going to update to FF81 out of curiosity.

Comment 22 Martin Stransky 2020-09-30 17:30:40 UTC
Thanks for testing. 81 packages for Fedora 33 are available here: https://koji.fedoraproject.org/koji/buildinfo?buildID=1614366

Comment 23 Vít Ondruch 2020-09-30 17:37:45 UTC
I have updated to:

~~~
$ rpm -q firefox
firefox-81.0-6.fc34.x86_64
~~~

and I'll be back in case of troubles.

Comment 25 Martin Stransky 2020-10-07 20:10:25 UTC
(In reply to Vít Ondruch from comment #24)
> New crash today:
> 
> https://crash-stats.mozilla.org/report/index/7cc3fb42-7072-49a9-833f-
> 3a0f00201007

Can you please try the latest packages - firefox-81.0.1-5.fc33 - from https://koji.fedoraproject.org/koji/buildinfo?buildID=1621239 ?
It should contain a fix for this one, https://bugzilla.mozilla.org/show_bug.cgi?id=1656727
Thanks.

Comment 26 Vít Ondruch 2020-10-08 06:30:33 UTC
Updated. I'll keep watching.

~~~
$ rpm -q firefox
firefox-81.0.1-5.fc34.x86_64
~~~

Comment 27 Martin Stransky 2020-10-08 06:35:24 UTC
Unfortunately a patch from https://bugzilla.mozilla.org/show_bug.cgi?id=1656727 causes a regression https://bugzilla.redhat.com/show_bug.cgi?id=1886243 so I'm going to revert it in next update firefox-81.0.1-7. I'll look at the patch and try to fix that.

Comment 28 Vít Ondruch 2020-10-08 07:32:46 UTC
(In reply to Martin Stransky from comment #27)
I have already commented there, but if I should choose, I prefer the funky tab popup (which I don't know if I even use) to FF crashes. But of course, the bug 1886243 refers to F32 while I am on Rawhide, which might make a difference.

Comment 29 Martin Stransky 2020-10-08 10:24:50 UTC
New builds with a fix for this one are on the way - https://koji.fedoraproject.org/koji/buildinfo?buildID=1621842

Comment 30 Martin Stransky 2020-10-08 10:26:49 UTC
err, rawhide builds are here - https://koji.fedoraproject.org/koji/buildinfo?buildID=1621843

Comment 31 Vít Ondruch 2020-10-14 14:30:20 UTC
Today I had strange failure:

~~~
$ journalctl -b | grep firefox
... snip ...

Oct 14 16:00:38 localhost.localdomain firefox.desktop[1648975]: [GFX1-]: Receive IPC close with reason=AbnormalShutdown
Oct 14 16:00:38 localhost.localdomain firefox.desktop[1653738]: Exiting due to channel error.
Oct 14 16:00:38 localhost.localdomain firefox.desktop[1648975]: Exiting due to channel error.
Oct 14 16:00:38 localhost.localdomain firefox.desktop[1701097]: [GFX1-]: Receive IPC close with reason=AbnormalShutdown
Oct 14 16:00:38 localhost.localdomain firefox.desktop[1701052]: [GFX1-]: Receive IPC close with reason=AbnormalShutdown
Oct 14 16:00:38 localhost.localdomain firefox.desktop[1644803]: Exiting due to channel error.
Oct 14 16:00:38 localhost.localdomain firefox.desktop[1700892]: [GFX1-]: Receive IPC close with reason=AbnormalShutdown
Oct 14 16:00:38 localhost.localdomain firefox.desktop[1701052]: Exiting due to channel error.
Oct 14 16:00:38 localhost.localdomain firefox.desktop[1700892]: Exiting due to channel error.
Oct 14 16:00:38 localhost.localdomain firefox.desktop[1701097]: Exiting due to channel error.
Oct 14 16:00:38 localhost.localdomain firefox.desktop[1641125]: Exiting due to channel error.
Oct 14 16:00:38 localhost.localdomain firefox.desktop[1641083]: Exiting due to channel error.
Oct 14 16:00:38 localhost.localdomain firefox.desktop[1644157]: Exiting due to channel error.
Oct 14 16:00:38 localhost.localdomain firefox.desktop[1642803]: Exiting due to channel error.
Oct 14 16:00:42 localhost.localdomain firefox.desktop[2021274]: restorecon: Could not set context for /home/vondruch/.mozilla/firefox/13qjb9o9.default/cookies.sqlite-wal:  No such file or directory
Oct 14 16:00:42 localhost.localdomain rtkit-daemon[823]: Successfully made thread 2021362 of process 2021268 (/usr/lib64/firefox/firefox) owned by '16025' RT at priority 10.
Oct 14 16:00:43 localhost.localdomain systemd[1694]: app-gnome-firefox-1640930.scope: Succeeded.
Oct 14 16:00:43 localhost.localdomain systemd[1694]: app-gnome-firefox-1640930.scope: Consumed 1d 1h 43min 12.127s CPU time.

... snip ...

$ rpm -q firefox
firefox-81.0.1-5.fc34.x86_64
~~~

I might just suspect, that is again the same error, because there is no report in `about:crashes` neither ABRT caught anything :/

Comment 32 Vít Ondruch 2020-10-14 14:37:47 UTC
Actually this was preceded by this:

~~~
Oct 14 16:00:38 localhost.localdomain gnome-shell[1832]: WL: error in client communication (pid 1640930)
Oct 14 16:00:38 localhost.localdomain MainThread[1640930]: Error flushing display: Roura přerušena (SIGPIPE)
~~~

Comment 33 Martin Stransky 2020-10-15 07:33:14 UTC
Do you have anything at about:crashes? ABRT ignores Firefox failures as we use upstream tracker.
Thanks.

Comment 34 Vít Ondruch 2020-10-15 10:11:07 UTC
As I said, there is nothing in about:crashes. It just went away without any notice except journal.

Comment 35 Martin Stransky 2020-10-15 11:09:03 UTC
(In reply to Vít Ondruch from comment #34)
> As I said, there is nothing in about:crashes. It just went away without any
> notice except journal.

I see. In that case it looks like Firefox quit itself after the error, that perhaps come from gtk.

Comment 36 Vít Ondruch 2020-10-21 16:49:25 UTC
Not sure this is the same, but the crash is again in wayland-client:

https://crash-stats.mozilla.org/report/index/314a6d21-41d9-4178-bdad-18e830201021

~~~
$ rpm -q firefox
firefox-82.0-5.fc33.x86_64
~~~

Comment 37 Martin Stransky 2020-10-21 20:12:28 UTC
We need to wait until debug symbols are loaded at mozilla servers, that's done when we ship the builds as Fedora updates.

Comment 38 Martin Stransky 2020-10-26 21:12:31 UTC
(In reply to Vít Ondruch from comment #32)
> Actually this was preceded by this:
> 
> ~~~
> Oct 14 16:00:38 localhost.localdomain gnome-shell[1832]: WL: error in client
> communication (pid 1640930)
> Oct 14 16:00:38 localhost.localdomain MainThread[1640930]: Error flushing
> display: Roura přerušena (SIGPIPE)
> ~~~

Looks like a duplicate of Bug 1888920.

*** This bug has been marked as a duplicate of bug 1888920 ***


Note You need to log in before you can comment on or make changes to this bug.