Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1832108 - [abrt] gnome-shell: _pixman_image_fini(): gnome-shell killed by SIGABRT
Summary: [abrt] gnome-shell: _pixman_image_fini(): gnome-shell killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 32
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:de60e774127890578405e2ffbe4...
: 1830975 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-06 06:13 UTC by Jade A
Modified: 2020-06-23 01:20 UTC (History)
6 users (show)

Fixed In Version: mutter-3.36.3-4.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-23 01:20:55 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: backtrace (deleted)
2020-05-06 06:13 UTC, Jade A
no flags Details
File: core_backtrace (deleted)
2020-05-06 06:14 UTC, Jade A
no flags Details
File: cpuinfo (deleted)
2020-05-06 06:14 UTC, Jade A
no flags Details
File: dso_list (deleted)
2020-05-06 06:14 UTC, Jade A
no flags Details
File: environ (deleted)
2020-05-06 06:14 UTC, Jade A
no flags Details
File: limits (deleted)
2020-05-06 06:14 UTC, Jade A
no flags Details
File: maps (deleted)
2020-05-06 06:14 UTC, Jade A
no flags Details
File: mountinfo (deleted)
2020-05-06 06:14 UTC, Jade A
no flags Details
File: open_fds (deleted)
2020-05-06 06:14 UTC, Jade A
no flags Details
File: proc_pid_status (deleted)
2020-05-06 06:14 UTC, Jade A
no flags Details
File: var_log_messages (deleted)
2020-05-06 06:14 UTC, Jade A
no flags Details

Description Jade A 2020-05-06 06:13:56 UTC
Description of problem:
While running Chrome and night light on (have not yet tried without either of those)

1. Open Gnome screenshot tool
2. Chose option "Select area to grab"
3. Select  portion of chrome window (gmail message)
4. gnome-shell crashes and restarts

Problem reproduced twice prior to reporting.

Version-Release number of selected component:
gnome-shell-3.36.2-2.fc32

Additional info:
reporter:       libreport-2.12.0
backtrace_rating: 3
cgroup:         0::/user.slice/user-1000.slice/user/gnome-shell-wayland.service
cmdline:        /usr/bin/gnome-shell
crash_function: _pixman_image_fini
executable:     /usr/bin/gnome-shell
journald_cursor: s=91329673cc5b4275a58f9291cdc0d0f5;i=25568;b=353ff0af835047368a75e1408c14dc9f;m=27b2c6eab;t=5a4f4762c5641;x=9263d8f269e05041
kernel:         5.6.8-300.fc32.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 1 Jade A 2020-05-06 06:13:59 UTC
Created attachment 1685546 [details]
File: backtrace

Comment 2 Jade A 2020-05-06 06:14:01 UTC
Created attachment 1685547 [details]
File: core_backtrace

Comment 3 Jade A 2020-05-06 06:14:02 UTC
Created attachment 1685548 [details]
File: cpuinfo

Comment 4 Jade A 2020-05-06 06:14:03 UTC
Created attachment 1685549 [details]
File: dso_list

Comment 5 Jade A 2020-05-06 06:14:04 UTC
Created attachment 1685550 [details]
File: environ

Comment 6 Jade A 2020-05-06 06:14:06 UTC
Created attachment 1685551 [details]
File: limits

Comment 7 Jade A 2020-05-06 06:14:07 UTC
Created attachment 1685552 [details]
File: maps

Comment 8 Jade A 2020-05-06 06:14:09 UTC
Created attachment 1685553 [details]
File: mountinfo

Comment 9 Jade A 2020-05-06 06:14:10 UTC
Created attachment 1685554 [details]
File: open_fds

Comment 10 Jade A 2020-05-06 06:14:11 UTC
Created attachment 1685555 [details]
File: proc_pid_status

Comment 11 Jade A 2020-05-06 06:14:12 UTC
Created attachment 1685556 [details]
File: var_log_messages

Comment 12 Jade A 2020-05-06 06:20:54 UTC
Further testing: 
Night light enabled/disabled doesn't seem to matter.
I can reliably trigger the crash by trying to take a screenshot of a Chrome browser tab with gmail open. Taking a screenshot of this Bugzilla page does not seem to trigger the crash.

Comment 13 Jade A 2020-06-07 06:09:51 UTC
Workaround: downgrade to gnome-shell-3.36.1-4.fc32.x86_64

Comment 14 Fedora Update System 2020-06-18 07:33:21 UTC
FEDORA-2020-29068632cd has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-29068632cd

Comment 15 Jonas Ådahl 2020-06-18 07:33:49 UTC
*** Bug 1830975 has been marked as a duplicate of this bug. ***

Comment 16 Fedora Update System 2020-06-19 21:54:58 UTC
FEDORA-2020-29068632cd has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-29068632cd`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-29068632cd

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Fedora Update System 2020-06-23 01:20:55 UTC
FEDORA-2020-29068632cd has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.