Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1837783 - gi.repository.GLib.GError: g-io-error-quark: No ostree= kernel argument found (0)
Summary: gi.repository.GLib.GError: g-io-error-quark: No ostree= kernel argument found...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Javier Martinez Canillas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1611ab270fe49c47d1efb59c9bf...
Depends On:
Blocks: IoT
TreeView+ depends on / blocked
 
Reported: 2020-05-20 00:41 UTC by iliketurtlesbro
Modified: 2020-05-21 16:14 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-21 16:14:33 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: anaconda-tb (deleted)
2020-05-20 00:41 UTC, iliketurtlesbro
no flags Details
File: anaconda.log (deleted)
2020-05-20 00:41 UTC, iliketurtlesbro
no flags Details
File: dbus.log (deleted)
2020-05-20 00:41 UTC, iliketurtlesbro
no flags Details
File: environ (deleted)
2020-05-20 00:41 UTC, iliketurtlesbro
no flags Details
File: lorax-packages.log (deleted)
2020-05-20 00:41 UTC, iliketurtlesbro
no flags Details
File: lsblk_output (deleted)
2020-05-20 00:41 UTC, iliketurtlesbro
no flags Details
File: nmcli_dev_list (deleted)
2020-05-20 00:41 UTC, iliketurtlesbro
no flags Details
File: os_info (deleted)
2020-05-20 00:41 UTC, iliketurtlesbro
no flags Details
File: program.log (deleted)
2020-05-20 00:41 UTC, iliketurtlesbro
no flags Details
File: storage.log (deleted)
2020-05-20 00:41 UTC, iliketurtlesbro
no flags Details
File: syslog (deleted)
2020-05-20 00:41 UTC, iliketurtlesbro
no flags Details

Description iliketurtlesbro 2020-05-20 00:41:18 UTC
Version-Release number of selected component:
anaconda-33.14

The following was filed automatically by anaconda:
anaconda 33.14 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.8/site-packages/pyanaconda/payload/rpmostreepayload.py", line 449, in post_install
    sysroot.load(cancellable)
  File "/usr/lib64/python3.8/site-packages/pyanaconda/installation_tasks.py", line 456, in run_task
    self._task(*self._task_args, **self._task_kwargs)
  File "/usr/lib64/python3.8/site-packages/pyanaconda/installation_tasks.py", line 490, in start
    self.run_task()
  File "/usr/lib64/python3.8/site-packages/pyanaconda/installation_tasks.py", line 311, in start
    item.start()
  File "/usr/lib64/python3.8/site-packages/pyanaconda/installation_tasks.py", line 311, in start
    item.start()
  File "/usr/lib64/python3.8/site-packages/pyanaconda/installation_tasks.py", line 311, in start
    item.start()
  File "/usr/lib64/python3.8/site-packages/pyanaconda/installation.py", line 393, in run_installation
    queue.start()
  File "/usr/lib64/python3.8/threading.py", line 870, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.8/site-packages/pyanaconda/threading.py", line 280, in run
    threading.Thread.run(self)
gi.repository.GLib.GError: g-io-error-quark: No ostree= kernel argument found (0)

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-SB-ostree-x86_64-rawh rd.live.check quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         5.7.0-0.rc5.20200515git1ae7efb38854.1.fc33.x86_64
product:        Fedora
release:        Fedora release 33 (Rawhide)
release_type:   pre-release
type:           anaconda
version:        rawhide

Comment 1 iliketurtlesbro 2020-05-20 00:41:20 UTC
Created attachment 1690040 [details]
File: anaconda-tb

Comment 2 iliketurtlesbro 2020-05-20 00:41:22 UTC
Created attachment 1690041 [details]
File: anaconda.log

Comment 3 iliketurtlesbro 2020-05-20 00:41:23 UTC
Created attachment 1690042 [details]
File: dbus.log

Comment 4 iliketurtlesbro 2020-05-20 00:41:24 UTC
Created attachment 1690043 [details]
File: environ

Comment 5 iliketurtlesbro 2020-05-20 00:41:26 UTC
Created attachment 1690044 [details]
File: lorax-packages.log

Comment 6 iliketurtlesbro 2020-05-20 00:41:27 UTC
Created attachment 1690045 [details]
File: lsblk_output

Comment 7 iliketurtlesbro 2020-05-20 00:41:28 UTC
Created attachment 1690046 [details]
File: nmcli_dev_list

Comment 8 iliketurtlesbro 2020-05-20 00:41:29 UTC
Created attachment 1690047 [details]
File: os_info

Comment 9 iliketurtlesbro 2020-05-20 00:41:31 UTC
Created attachment 1690048 [details]
File: program.log

Comment 10 iliketurtlesbro 2020-05-20 00:41:32 UTC
Created attachment 1690049 [details]
File: storage.log

Comment 11 iliketurtlesbro 2020-05-20 00:41:34 UTC
Created attachment 1690050 [details]
File: syslog

Comment 12 Javier Martinez Canillas 2020-05-20 12:50:08 UTC
I think the problem is that the grub2-mkconfig script now updates the option field of the BLS snippets to make sure that these have the latest value set in the GRUB_CMDLINE_LINUX variable of the /etc/default/grub file. Since users expect to update their cmdline by executing grub2-mkconfig.

But the BLS snippets created by OSTree are not really managed by the GRUB script so it's wrong to update them.

I've pushed a grub2 update for Rawhide that should fix this issue: https://bodhi.fedoraproject.org/updates/FEDORA-2020-6176820819

Comment 13 Adam Williamson 2020-05-21 00:35:31 UTC
Note this is actually breaking Rawhide/F33 IoT composes at present, they're hitting the same error message - see e.g. the screenshot and oz log from https://koji.fedoraproject.org/koji/taskinfo?taskID=44500207 .

Since you've sent a build we can mark this as ON_QA now, though Rawhide composes are currently held up by a problem with KDE, see https://pagure.io/releng/failed-composes/issue/1459 for more on that.

Comment 14 Peter Robinson 2020-05-21 11:40:15 UTC
FYI This fixed the IoT compose.

Comment 15 Javier Martinez Canillas 2020-05-21 13:11:09 UTC
(In reply to Peter Robinson from comment #14)
> FYI This fixed the IoT compose.

Thanks a lot for confirming it and sorry for the inconvenience with this issue.

Comment 16 Adam Williamson 2020-05-21 16:14:33 UTC
Since we ran an IoT compose and it succeeded I think we can call this fixed. It'll be fixed for mainstream Rawhide whenever we next get a compose done.


Note You need to log in before you can comment on or make changes to this bug.