Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1839428 - file /usr/include/mysql/mariadb_rpl.h conflicts
Summary: file /usr/include/mysql/mariadb_rpl.h conflicts
Alias: None
Product: Fedora
Classification: Fedora
Component: mariadb-connector-c
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Michal Schorm
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2020-05-24 03:08 UTC by Orion Poplawski
Modified: 2020-09-22 08:22 UTC (History)
8 users (show)

Fixed In Version: mariadb-3:10.4.12-6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2020-05-24 14:06:21 UTC
Type: Bug

Attachments (Terms of Use)

Description Orion Poplawski 2020-05-24 03:08:58 UTC
Description of problem:

file /usr/include/mysql/mariadb_rpl.h conflicts between attempted installs of mariadb-devel-3:10.4.12-5.fc33.aarch64 and mariadb-connector-c-devel-3.1.8-1.fc33.aarch64

Version-Release number of selected component (if applicable):

This appears to be new with mariadb-connector-c 3.1.7-2.20200316git -> 3.1.8-1.fc33

Comment 1 Lukas Javorsky 2020-05-24 08:55:48 UTC
This conflict is caused by this commit:

We remove the libraries in mariadb package to prevent conflicts with connector-c's libraries, so I've included this library to the delete list too, and it should solve this problem
Currently building the mariadb-3:10.4.12-6 which contains this change.

Comment 2 Orion Poplawski 2020-05-24 14:06:21 UTC
That does indeed appear to fix the conflict.  Thanks.

Comment 3 Erik P. Olsen 2020-06-21 06:21:13 UTC
This is a problem in F32 as well.

Comment 4 Lukas Javorsky 2020-06-22 09:27:07 UTC
Hi Erik,

Please can you tell me what version of mariadb and mariadb-connector-c are you using?

You can use this commads:
rpm -qa mariadb
rpm -qa mariadb-connector-c

Thank you

Comment 5 Erik P. Olsen 2020-06-22 09:51:53 UTC
[erik@Erik-PC ~]$ rpm -qa mariadb
[erik@Erik-PC ~]$ rpm -qa mariadb-connector-c

Comment 6 Lukas Javorsky 2020-06-22 10:30:05 UTC
And what is the exact problem here?

I've just tried to install mariadb-10.4.13 with mariadb-connector-c-3.8.1 and everything went successfully.

Comment 7 Erik P. Olsen 2020-06-22 10:49:50 UTC
The problem was as I described in fedora user mailing list:

After dnf system-upgrade download --releasever=32 I get the following error:

the file /usr/include/mysql/mariadb_rpl.h makes conflict between the attempted
installation of mariadb-devel-3:10.4.12-3.fc32.x86_64 and mariadb-connector-c-devel-3.1.8-1.fc32.x86_64

The original error message was in Danish but I have attempted to translate it as well as I could. I hope it is understood.

Removing mariadb-devel made the system-upgrade run successfully.

Comment 8 Lukas Javorsky 2020-06-22 11:14:30 UTC
Yes thanks for investigation, I've tried manually install version 10.4.12-3 and it failed.

It's weird that this version is being installed when version 10.4.13 is default for f32.

I will look into that and give you update as soon as possible.

Comment 9 Lukas Javorsky 2020-06-22 11:24:40 UTC
I think I see the problem.

Did you upgraded the packages before fedora upgrade?
Using: sudo dnf upgrade --refresh

It's recommended to do before upgrading OS.

Here is the fedora-magazine guide to upgrade fedora 31 to 32:

Comment 10 Erik P. Olsen 2020-06-22 12:45:50 UTC
Yes, I did upgrade --refresh before system-upgrade. I think the problem was mariadb-devel and since I don't use it, it was safe to remove it.

Comment 11 Lukas Javorsky 2020-06-24 08:55:44 UTC
Okay, I will try to reproduce it.

So IIRC you had Fedora 31 installed with mariadb-devel and mariadb-connector-c-devel packages installed.

Then you followed these steps:
1) sudo dnf upgrade --refresh (Updated all packages)
2) sudo dnf install dnf-plugin-system-upgrade (Install dnf plugin)
3) sudo dnf system-upgrade download --releasever=32 (Tried to install Fedora 32, but it failed here!)

Is my estimation correct?

Comment 12 Erik P. Olsen 2020-06-24 10:50:00 UTC
Yes, that is correct.

Comment 13 Lukas Javorsky 2020-06-25 12:36:09 UTC
I've created a new Fedora 31 machine with mariadb-devel and mariadb-connector-c-devel packages installed (conflicting ones),
and followed steps mentioned above.

Everything went smooth, so I can't see why did you had the conflict problem.

If anyone reading this have the same problem please add comment here and I will give this one another look, but for now I think it's fixed.

Comment 14 amarza 2020-09-07 07:28:20 UTC
I am experiencing this in F31 now:

rpm -qa mariadb

rpm -qa mariadb-connector-c

The problem appears when I try to install mariadb-devel:
Error: Transaction test error:
  file /usr/include/mysql/mariadb_rpl.h from install of mariadb-devel-3:10.3.22-1.fc31.x86_64 conflicts with file from package mariadb-connector-c-devel-3.1.9-5.fc31.x86_64

Comment 15 Lukas Javorsky 2020-09-07 08:53:21 UTC
Thanks for reporting.

I've already started a build for it.

I'll link the update to this BZ for you to know when it's done

Comment 16 Lukas Javorsky 2020-09-07 09:08:28 UTC
The tracking will be in BZ#1876012

I apologize for the confusion

Comment 17 Roger Wells 2020-09-21 21:24:16 UTC
I am experiencing the same results as reported in comment 14 but in F32.
An attempt to update fails with 
Transaction test error:  file /usr/include/mysql/mariadb_rpl.h  etc.

Comment 18 Lukas Javorsky 2020-09-22 08:22:31 UTC
Hi Roger,

We should lead this conversation only in one BZ.

My answer is in BZ#1876012

Thank you for understanding.

Note You need to log in before you can comment on or make changes to this bug.