Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1840194 - /usr/share/systemtap/tapset/sssd_functions.stp missing a comma
Summary: /usr/share/systemtap/tapset/sssd_functions.stp missing a comma
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sssd
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: avisiedo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: sync-to-jira
Depends On:
Blocks: 1850961
TreeView+ depends on / blocked
 
Reported: 2020-05-26 14:27 UTC by William Cohen
Modified: 2020-07-30 18:56 UTC (History)
11 users (show)

Fixed In Version: sssd-2.3.1-2.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1850961 (view as bug list)
Environment:
Last Closed: 2020-07-30 18:56:43 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
patch to insert missing comma in file (728 bytes, patch)
2020-05-26 14:27 UTC, William Cohen
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Github SSSD sssd issues 5201 0 None closed sssd-common: missing comma in file sssd_functions.stp 2020-12-16 12:08:30 UTC

Description William Cohen 2020-05-26 14:27:00 UTC
Created attachment 1692292 [details]
patch to insert missing comma in file

Description of problem:

When running systemtap testsuite on fedora rawhide I saw a lot of failures. Like the following:

FAIL: abort: TEST 5: abort() in the middle of a probe handler body (--compatible 3.3): stderr: fails to match regex "^semantic error: unresolved function \(similar: [^\n]*?\): identifier 'abort' at [^\n]*?\.stp:3:5\n": got "parse error: expected 'probe', 'global', 'private', 'function', or '%{'
        saw: identifier 'METHOD_SENTINEL' at /usr/share/systemtap/tapset/sssd_functions.stp:10:34
     source:        METHOD_RESOLVER_HANDLER=9 METHOD_SENTINEL=10
                                              ^

1 parse error.
WARNING: tapset "/usr/share/systemtap/tapset/sssd_functions.stp" has errors, and will be skipped
Pass 2: analysis failed.  [man error::pass2]
"
FAIL: abort: TEST 7: abort() in timer.profile (more concurrency and no globals): stderr: string should be "", but got "parse error: expected 'probe', 'global', 'private', 'function', or '%{'
        saw: identifier 'METHOD_SENTINEL' at /usr/share/systemtap/tapset/sssd_functions.stp:10:34
     source:        METHOD_RESOLVER_HANDLER=9 METHOD_SENTINEL=10
                                              ^

1 parse error.
WARNING: tapset "/usr/share/systemtap/tapset/sssd_functions.stp" has errors, and will be skipped
"


Version-Release number of selected component (if applicable):


How reproducible:

every time


Steps to Reproduce:
1. dnf install systemtap-testsuite kernel-devel
2. dnf debuginfo kernel
3.  sudo stap -e 'probe timer.profile { 
    abort();
    error("fire after abort!\n")
}'


Actual results:


parse error: expected 'probe', 'global', 'private', 'function', or '%{'
        saw: identifier 'METHOD_SENTINEL' at /usr/share/systemtap/tapset/sssd_functions.stp:10:34
     source:        METHOD_RESOLVER_HANDLER=9 METHOD_SENTINEL=10
                                              ^

1 parse error.
WARNING: tapset "/usr/share/systemtap/tapset/sssd_functions.stp" has errors, and will be skipped


Expected results:

$ sudo stap -e 'probe timer.profile { 
    abort();
    error("fire after abort!\n")
}'



Additional info:

Looks like a trivial missing comma to fix the issue.

Comment 1 William Cohen 2020-05-26 14:51:50 UTC
Also see the same problem with the sssd_functions.stp file on F32 with sssd-common-2.3.0-1.fc32.x86_64.

Comment 2 avisiedo 2020-06-11 07:58:45 UTC
Hi William,

Thank you very much for spotting this issue and your patch. I will push the changes as soon as possible.

Best regards

Whiteboard: sync-to-jira

Comment 3 Alexey Tikhonov 2020-06-25 08:24:39 UTC
Upstream PR: https://github.com/SSSD/sssd/pull/5202

Comment 4 Pavel Březina 2020-06-25 12:04:07 UTC
Pushed PR: https://github.com/SSSD/sssd/pull/5202

* `master`
    * 66029529fa0f0e2d16999f22294822deeec5f60b - systemtap: Missing a comma

Comment 5 Fedora Update System 2020-07-27 14:07:17 UTC
FEDORA-2020-63a418c824 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-63a418c824

Comment 6 Fedora Update System 2020-07-28 15:20:07 UTC
FEDORA-2020-63a418c824 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-63a418c824`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-63a418c824

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2020-07-30 18:56:43 UTC
FEDORA-2020-63a418c824 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.