Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1851779 - Advanced partitioning ignores request to use btrfs raid1, uses raid0 instead
Summary: Advanced partitioning ignores request to use btrfs raid1, uses raid0 instead
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: blivet-gui
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vojtech Trefny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F33FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2020-06-28 22:45 UTC by Chris Murphy
Modified: 2020-07-18 01:44 UTC (History)
13 users (show)

Fixed In Version: blivet-gui-2.1.15-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-11 01:08:48 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
anacondalog (9.74 KB, text/plain)
2020-06-28 22:46 UTC, Chris Murphy
no flags Details
program.log (9.71 KB, text/plain)
2020-06-28 22:46 UTC, Chris Murphy
no flags Details
storage.log (98.84 KB, text/plain)
2020-06-28 22:47 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2020-06-28 22:45:11 UTC
Description of problem:

Advanced Custom (blivet-gui), upon choosing raid1, while the setting does stick and seems to be accepted, the overview shows 2x the expected space. And when I go to 'display info about selected device' it shows data and metadata as 'none' which is not a valid profile for btrfs. The actual layout created is raid0.

The problem does not happen in Custom. The actual layout created is raid1 as expected.


Version-Release number of selected component (if applicable):
anaconda-33.20-1.fc33.x86_64
blivet-data-3.2.2-2.fc33.noarch
python3-blivet-3.2.2-2.fc33.noarch
blivet-gui-runtime-2.1.14-2.fc33.noarch


How reproducible: Always


Steps to Reproduce:
1. Two vda devices chosen as targets
2. Advanced Custom (blivet-gui) path
3. Click + Device Type = Btrfs + check both vda and vdb + RAID level set to raid1
4. name=fedorap, mount point = /, click OK.


Actual results:

"display information about selected device" says data level none and metadata level none. Proceeding with the installation it uses raid0 for data and raid1 for metadata (mkfs.btrfs default)


Expected results:

raid1 for data and metadata

Additional info:

Comment 1 Chris Murphy 2020-06-28 22:46:48 UTC
Created attachment 1699053 [details]
anacondalog

Comment 2 Chris Murphy 2020-06-28 22:46:59 UTC
Created attachment 1699054 [details]
program.log

Comment 3 Chris Murphy 2020-06-28 22:47:14 UTC
Created attachment 1699055 [details]
storage.log

Comment 4 Fedora Blocker Bugs Application 2020-06-28 22:48:39 UTC
Proposed as a Blocker for 33-final by Fedora user chrismurphy using the blocker tracking app because:

 final release criterion: The installer must be able to create and install to any workable partition layout using any file system and/or container format combination offered in a default installer configuration.

Comment 5 Vojtech Trefny 2020-06-29 07:32:50 UTC
upstream PR: https://github.com/storaged-project/blivet-gui/pull/199

Comment 6 Fedora Update System 2020-07-02 13:51:12 UTC
FEDORA-2020-7525f4fdf7 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-7525f4fdf7

Comment 7 Fedora Update System 2020-07-02 14:04:57 UTC
FEDORA-2020-3cfdf1a75e has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-3cfdf1a75e

Comment 8 Fedora Update System 2020-07-02 14:27:22 UTC
FEDORA-EPEL-2020-82cc3846a3 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-82cc3846a3

Comment 9 Fedora Update System 2020-07-03 01:23:13 UTC
FEDORA-2020-3cfdf1a75e has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-3cfdf1a75e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-3cfdf1a75e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2020-07-03 02:02:37 UTC
FEDORA-EPEL-2020-82cc3846a3 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-82cc3846a3

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2020-07-03 02:04:40 UTC
FEDORA-2020-7525f4fdf7 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-7525f4fdf7`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-7525f4fdf7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2020-07-11 01:08:48 UTC
FEDORA-2020-7525f4fdf7 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 13 Fedora Update System 2020-07-18 01:08:21 UTC
FEDORA-2020-3cfdf1a75e has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Fedora Update System 2020-07-18 01:44:50 UTC
FEDORA-EPEL-2020-82cc3846a3 has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.