Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1861794 - LibreOffice Calc Fixed Width Import no longer shows handles
Summary: LibreOffice Calc Fixed Width Import no longer shows handles
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-29 15:01 UTC by Louis van Dyk
Modified: 2020-08-05 13:13 UTC (History)
4 users (show)

Fixed In Version: libreoffice-6.4.5.2-5.fc32 libreoffice-6.4.5.2-5.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-01 00:49:59 UTC
Type: Bug


Attachments (Terms of Use)

Description Louis van Dyk 2020-07-29 15:01:52 UTC
Description of problem:
Previously when importing a block of text into Calc, e.g. through copy and paste, or a CSV file, the "Fixed Width" option allows you to add a column for the fixed width item.  

At the top of this column used to be a red handle in the ruler section.   This handle would allow you to drag it to the left or right, or right click it to remove it.

As of this version, when selecting Fixed Width:
- No red handles are displayed in the ruler section above the displayed text
- I can add a column by left clicking in the ruler
- I can move a column left or right by hovering the pointer in the ruler and then the pointer will change to a double-headed arrow when above a separator line - this I can drag left or right
- However, I cannot remove a separator column once added.  I've tried to hover the pointer as if I were to drag and got the double-headed arrow, and then single clicked, double clicked, right clicked and even middle clicked.  The column remains in place.

I've eventually discovered that I can remove the separator by hovering as above and pressing the DEL key, but this is definitely counter-intuitive regression, considering a mouse right-click would do the same thing before.


Version-Release number of selected component (if applicable):
libreoffice-calc-6.4.5.2-2.fc32.x86_64


How reproducible:
Paste a block of text as fixed width, or Select Data/Text to Columns/Fixed Width on existing text.  Every time.

Steps to Reproduce:
1. As above
2.
3.

Actual results:
One cannot remove an added separator using the mouse.  The red separator handles are no longer shown.

Expected results:
Allow one to remove an added separator using the mouse - as before.  I liked the red separator handles, but can understand the reason for removing them.

Additional info:

Comment 1 Caolan McNamara 2020-07-29 16:40:15 UTC
red dot exists in 6-3 and not in 6-4, so I will at least track down when it went away

Comment 2 Fedora Update System 2020-07-30 12:55:07 UTC
FEDORA-2020-ebc86c5efe has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-ebc86c5efe

Comment 3 Fedora Update System 2020-07-30 19:55:28 UTC
FEDORA-2020-ebc86c5efe has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-ebc86c5efe`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-ebc86c5efe

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2020-08-01 00:49:59 UTC
FEDORA-2020-ebc86c5efe has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 5 Fedora Update System 2020-08-05 13:13:19 UTC
FEDORA-2020-1dbe7da7a2 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.