Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1869140 - adding a disk after make some partitions makes anaconda crash everytime
Summary: adding a disk after make some partitions makes anaconda crash everytime
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vendula Poncova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
Depends On:
Blocks: F33FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2020-08-17 04:33 UTC by lnie
Modified: 2021-04-30 07:29 UTC (History)
16 users (show)

Fixed In Version: anaconda-34.4-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-30 07:29:28 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
anaconda tar with iscsi target crash (344.17 KB, application/gzip)
2020-08-17 04:33 UTC, lnie
no flags Details
anaconda log of iscsi crash (31.07 KB, text/plain)
2020-08-17 04:38 UTC, lnie
no flags Details
syslog of iscsi crash (955.65 KB, text/plain)
2020-08-17 04:39 UTC, lnie
no flags Details

Description lnie 2020-08-17 04:33:17 UTC
Created attachment 1711535 [details]
anaconda tar with iscsi target crash

Description of problem:
Boot the installer,and click into "Manual Partitioning" page,create some partitions,then come back to "Installation Destination"page,and click "Add a disk",add a fcoe or iscsi disk,and click into "Manual Partitioning" page,
and made some partitions,you will see the crash after click"Begin installation".
I've reproduced this crash many times,but failed to make the reports due to#1869126.Please note that as said in #1868577,anaconda will crash no matter you create or not create partitions on the added disk.

Version-Release number of selected component (if applicable):
Fedora-Server-x86_64-Rawhide-20200811
How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 lnie 2020-08-17 04:38:26 UTC
Created attachment 1711536 [details]
anaconda log of iscsi crash

Comment 2 lnie 2020-08-17 04:39:00 UTC
Created attachment 1711537 [details]
syslog of iscsi crash

Comment 3 Fedora Blocker Bugs Application 2020-08-17 04:44:04 UTC
Proposed as a Blocker for 33-beta by Fedora user lnie using the blocker tracking app because:

 This seems affects :
When using the guided partitioning flow, the installer must be able to: 
Complete an installation using any combination of disk configuration options it allows the user to select

Comment 4 Geoffrey Marr 2020-08-17 23:12:51 UTC
Discussed during the 2020-08-17 blocker review meeting: [0]

The decision to classify this bug as a "RejectedBlocker (Beta)" was made as we do not believe this violates the Beta criteria (the cited criterion refers to "guided partitioning" but the bug involves using custom partitioning, and network storage devices are only in the Final criteria). There is some support for making this a Final blocker but not clear enough to accept it yet.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-08-17/f33-blocker-review.2020-08-17-16.11.txt

Comment 5 Vladimír Slávik 2020-09-01 16:26:00 UTC
> 03:52:26,620 WARNING org.fedoraproject.Anaconda.Modules.Storage:gi.overrides.BlockDev.LVMError: Failed to call the 'PvCreate' method on the '/com/redhat/lvmdbus1/Manager' object: GDBus.Error:org.freedesktop.DBus.Python.dbus.exceptions.DBusException: ('com.redhat.lvmdbus1.Manager', 'PV /dev/sda1 Already exists!')

This seems to be a problem in the storage library. Reassigning.

Comment 6 Vendula Poncova 2020-09-16 11:09:27 UTC
Based on the comment https://bugzilla.redhat.com/show_bug.cgi?id=1868577#c36, the bug seems to be fixed by https://github.com/rhinstaller/anaconda/pull/2823.

Comment 7 lnie 2020-09-16 11:51:32 UTC
(In reply to Vendula Poncova from comment #6)
> Based on the comment
> https://bugzilla.redhat.com/show_bug.cgi?id=1868577#c36, the bug seems to be
> fixed by https://github.com/rhinstaller/anaconda/pull/2823.

yeah,checked on fcoe and iscsi server with Rawhide repo,but it's fixed in anaconda-34.4-1 but not anaconda-33.25.3-1


Note You need to log in before you can comment on or make changes to this bug.