Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1869458 - the installer crashed after change the size of the Lvm thin provisioning partition
Summary: the installer crashed after change the size of the Lvm thin provisioning part...
Keywords:
Status: CLOSED DUPLICATE of bug 1868623
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F33FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2020-08-18 03:55 UTC by lnie
Modified: 2020-08-18 05:59 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-18 05:59:31 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
screencast (782.42 KB, video/webm)
2020-08-18 03:55 UTC, lnie
no flags Details
anaconda log (22.17 KB, text/plain)
2020-08-18 03:58 UTC, lnie
no flags Details
storage.log (204.50 KB, text/plain)
2020-08-18 03:58 UTC, lnie
no flags Details
anaconda-tb1 (1.10 MB, text/plain)
2020-08-18 03:59 UTC, lnie
no flags Details
anaconda-tb2 (1.09 MB, text/plain)
2020-08-18 03:59 UTC, lnie
no flags Details

Description lnie 2020-08-18 03:55:28 UTC
Created attachment 1711673 [details]
screencast

Description of problem:
As shown in the attached screencast,the reproducer is:
On "Manual Partitioning"page,add a root partition of Lvm thin provisioning,
and then change the size of that partition,you will see the crash almost immediately after you click the "Update Settings" button

Version-Release number of selected component (if applicable):
Fedora-Workstation-Live-x86_64-Rawhide-20200811.n.0.iso
Fedora-Server-dvd-x86_64-Rawhide-20200811.n.0.iso

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 lnie 2020-08-18 03:58:09 UTC
Created attachment 1711674 [details]
anaconda log

Comment 2 lnie 2020-08-18 03:58:32 UTC
Created attachment 1711675 [details]
storage.log

Comment 3 lnie 2020-08-18 03:59:05 UTC
Created attachment 1711676 [details]
anaconda-tb1

Comment 4 lnie 2020-08-18 03:59:29 UTC
Created attachment 1711677 [details]
anaconda-tb2

Comment 5 Fedora Blocker Bugs Application 2020-08-18 04:29:09 UTC
Proposed as a Blocker for 33-final by Fedora user lnie using the blocker tracking app because:

 This seems affects:
Any installer mechanism for resizing storage volumes must correctly attempt the requested operation.

Comment 6 Vojtech Trefny 2020-08-18 05:59:31 UTC

*** This bug has been marked as a duplicate of bug 1868623 ***


Note You need to log in before you can comment on or make changes to this bug.