Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1869901 - Online Accounts Facebook login doesn't work
Summary: Online Accounts Facebook login doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-online-accounts
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Debarshi Ray
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-18 23:51 UTC by Matthew Saltzman
Modified: 2021-04-27 00:30 UTC (History)
4 users (show)

Fixed In Version: gnome-online-accounts-3.40.0-1.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-27 00:30:05 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME gnome-online-accounts issues 128 0 None None None 2021-01-14 21:27:44 UTC

Description Matthew Saltzman 2020-08-18 23:51:28 UTC
Description of problem:
Logging into Facebook using GNOME Online Accounts fails after the second factor of 2FA is confirmed. The error reported on the next screen is:

App Not Setup: This app is still in development mode, and you don't have access to it. Switch to a registered test user or ask an app admin for permissions.

Version-Release number of selected component (if applicable):
gnome-online-accounts-3.36.0-1.fc32.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Try to log in to Facebook via Online Accounts
2.
3.

Actual results:
The above-described failure

Expected results:
Successful login

Additional info:
This used to work but has not for a while. I no longer recall the version number of a working version, though.

Comment 1 Scott Williams 2021-01-14 21:27:44 UTC
I can verify that this also happens on Fedora 33.  Seems to be an upstream Gnome issue: https://gitlab.gnome.org/GNOME/gnome-online-accounts/-/issues/128

Comment 2 Frank Crawford 2021-03-19 11:23:11 UTC
While this is an upstream issue, it has been open for over 8 months, with the only comments by everyone saying they are seeing it.

Has anyone in the gnome team even acknowledged it, and have they a plan to fix it.

Otherwise wouldn't it make sense to just disable the facebook login from Online Accounts?

Even here it is still in NEW status, and just appears to be ignored.

Comment 3 Fedora Update System 2021-04-21 22:51:22 UTC
FEDORA-2021-54d701e56e has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-54d701e56e

Comment 4 Debarshi Ray 2021-04-21 23:00:21 UTC
Right now the only "solution" is to disable the Facebook provider.

It's completely broken at the moment and needs serious work upstream to get it back in shape. Unfortunately, resources are limited and if nobody steps up to do this work, then we might have to permanently remove the Facebook integration.

Comment 5 Fedora Update System 2021-04-22 18:24:58 UTC
FEDORA-2021-54d701e56e has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-54d701e56e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-54d701e56e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2021-04-27 00:30:05 UTC
FEDORA-2021-54d701e56e has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.