Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1872445 - conflict between MATE 33 wallpaper package dependencies
Summary: conflict between MATE 33 wallpaper package dependencies
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: f33-backgrounds
Version: 33
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Luya Tshimbalanga
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-25 18:01 UTC by Adriano
Modified: 2020-09-29 00:15 UTC (History)
4 users (show)

Fixed In Version: f33-backgrounds-33.0.3-1.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-29 00:15:24 UTC
Type: Bug


Attachments (Terms of Use)

Description Adriano 2020-08-25 18:01:18 UTC
Description of problem:

When installing the MATE 33 environment from another previously installed environment, the dependency conflict error occurs between Fedora backgrounds 33 packages and additional 32 backgrounds.


Version-Release number of selected component (if applicable):

fc33-backgrounds-mate-33-0.2.1.fc33.noarch
fc32-backgrounds-mate-32-2.2.2.fc33.noarch

How reproducible:

just install the MATE 33 environment from another environment previously installed by Live-ISO and the dependency conflict occurs.

Steps to Reproduce:

1. Install Fedora LXDE 33 or Cinnamon 33 from a Live-ISO.
2. Try to install MATE 33 Desktop Enviroment with (sudo dnf install mate-desktop @mate).
3. After download all MATE packages the "DNF Resolv Extraction install" will reṕort the conflict in /usr/share/backgrounds/mate/default.xml

Actual results:



Expected results:

No conflict between backgrounds packages those constain imagens.

Additional info:

Comment 1 Luya Tshimbalanga 2020-08-29 00:02:22 UTC
Hello Adriano, 
a new update is available which should resolve the conflicting default wallpaper when upgrading in MATE desktop environment.

Comment 2 Fedora Update System 2020-08-29 00:05:48 UTC
FEDORA-2020-353dcd4cfc has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-353dcd4cfc

Comment 3 Fedora Update System 2020-08-31 14:27:45 UTC
FEDORA-2020-353dcd4cfc has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-353dcd4cfc`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-353dcd4cfc

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Wolfgang Ulbrich 2020-09-15 11:38:11 UTC
It would be nice to inform Mate package maintainer (me) when you change the default directory for Mate.
Communication is world class !
I have to change a default gsettings key which define the location for the default background.
```
org.mate.background picture-filename
```
This key is defined by a gsettings override from mate-desktop package.

What is the problem with using /usr/share/backgrounds/mate/default.xml ?
I mean which file does conflict with /usr/share/backgrounds/mate/default.xml ?.

With the new dir /usr/share/mate-background-properties/f33.xml
i have to change the gesettings key again every 6 month with a new fedora release, because of using a number in name!
Sorry , i can't except that.

If you really want to change the location, can you please use /usr/share/mate-background-properties/default.xml ?
This should be a symlink to /usr/share/backgrounds/f33/default/f33.xml

Comment 5 Wolfgang Ulbrich 2020-09-15 12:26:29 UTC
The default of Mate is using a static xml background since f23. And this file is removed! So shipping only mate-background-properties/f33.xml which isn't a static background is wrong. We need a static xml background file which was /usr/share/backgrounds/mate/default.xml

So, this update breaks the common usage of a background for MATE.

Comment 6 Wolfgang Ulbrich 2020-09-15 12:33:48 UTC
(In reply to Adriano from comment #0)
> Description of problem:
> 
> When installing the MATE 33 environment from another previously installed
> environment, the dependency conflict error occurs between Fedora backgrounds
> 33 packages and additional 32 backgrounds.
> 
> 
> Version-Release number of selected component (if applicable):
> 
> fc33-backgrounds-mate-33-0.2.1.fc33.noarch
> fc32-backgrounds-mate-32-2.2.2.fc33.noarch
> 
> How reproducible:
> 
> just install the MATE 33 environment from another environment previously
> installed by Live-ISO and the dependency conflict occurs.
> 
> Steps to Reproduce:
> 
> 1. Install Fedora LXDE 33 or Cinnamon 33 from a Live-ISO.
> 2. Try to install MATE 33 Desktop Enviroment with (sudo dnf install
> mate-desktop @mate).

Command is wrong, mate-desktop is a package, not an desktop environment.
So you generated a conflict yourself.
Please use only `sudo dnf install @mate`

Comment 7 Wolfgang Ulbrich 2020-09-15 15:00:50 UTC
I tested it for myself. Installing Mate desktop environment from Cinnamon-spin-installation works like a charm when using the correct command.

```
[root@f33-test rave]# LANG=C
[root@f33-test rave]# rpm -qa f33-back*
f33-backgrounds-base-33.0.2-1.fc33.noarch
f33-backgrounds-gnome-33.0.2-1.fc33.noarch
[root@f33-test rave]# dnf install @mate
Last metadata expiration check: 0:02:13 ago on Tue Sep 15 16:49:33 2020.
Dependencies resolved.
================================================================================
 Package                         Arch   Version           Repository       Size
================================================================================
Upgrading:
 blivet-gui-runtime              noarch 2.2.0-1.fc33      updates-testing 300 k
 gvfs                            x86_64 1.45.92-1.fc33    updates-testing 359 k
 gvfs-afc                        x86_64 1.45.92-1.fc33    updates-testing  59 k
 gvfs-archive                    x86_64 1.45.92-1.fc33    updates-testing  25 k
 gvfs-client                     x86_64 1.45.92-1.fc33    updates-testing 755 k
 gvfs-goa                        x86_64 1.45.92-1.fc33    updates-testing  68 k
 gvfs-gphoto2                    x86_64 1.45.92-1.fc33    updates-testing  64 k
 gvfs-mtp                        x86_64 1.45.92-1.fc33    updates-testing  65 k
 gvfs-smb                        x86_64 1.45.92-1.fc33    updates-testing  42 k
 usermode                        x86_64 1.112-9.fc33      updates-testing 174 k
Installing group/module packages:
 NetworkManager-ovs              x86_64 1:1.26.2-1.fc33.1 fedora           42 k
 NetworkManager-ssh-gnome        x86_64 1.2.11-2.fc33     fedora           31 k
 NetworkManager-sstp-gnome       x86_64 1:1.2.6-7.fc33    fedora           44 k
 NetworkManager-strongswan-gnome x86_64 1.5.0-2.fc33      fedora           29 k
 atril                           x86_64 1.24.0-3.fc33     fedora          1.2 M
 atril-caja                      x86_64 1.24.0-3.fc33     fedora           18 k
 atril-thumbnailer               x86_64 1.24.0-3.fc33     fedora          8.3 k
 blivet-gui                      noarch 2.2.0-1.fc33      updates-testing  19 k
 caja-actions                    x86_64 1.8.3-13.fc33     fedora          450 k
 caja-image-converter            x86_64 1.24.1-1.fc33     fedora           25 k
 caja-open-terminal              x86_64 1.24.1-1.fc33     fedora           21 k
 caja-sendto                     x86_64 1.24.1-1.fc33     fedora           69 k
 caja-wallpaper                  x86_64 1.24.1-1.fc33     fedora           16 k
 caja-xattr-tags                 x86_64 1.24.1-1.fc33     fedora           16 k
 dconf-editor                    x86_64 3.37.91-1.fc33    updates-testing 676 k
 engrampa                        x86_64 1.24.1-1.fc33     fedora          1.3 M
 f33-backgrounds-extras-base     noarch 33.0.3-1.fc33     updates-testing  14 k
 f33-backgrounds-extras-mate     noarch 33.0.3-1.fc33     updates-testing 7.4 k
 fedora-release-matecompiz       noarch 33-0.14           fedora           12 k
 filezilla                       x86_64 3.49.1-2.fc33     fedora          4.4 M
 gnome-epub-thumbnailer          x86_64 1.6-4.fc33        fedora           28 k
 gnome-logs                      x86_64 3.36.0-3.fc33     fedora          373 k
 gnote                           x86_64 3.37.0-3.fc33     fedora          3.8 M
 gparted                         x86_64 1.1.0-3.fc33      fedora          2.0 M
 gtk2-engines                    x86_64 2.20.2-21.fc33    fedora          304 k
 gvfs-afp                        x86_64 1.45.92-1.fc33    updates-testing  75 k
 gvfs-fuse                       x86_64 1.45.92-1.fc33    updates-testing  30 k
 gvfs-nfs                        x86_64 1.45.92-1.fc33    updates-testing  32 k
 marco                           x86_64 1.24.1-1.fc33     fedora          127 k
 mate-applets                    x86_64 1.24.1-2.fc33     updates-testing 9.1 M
 mate-backgrounds                noarch 1.24.1-2.fc33     fedora           20 M
 mate-calc                       x86_64 1.24.1-1.fc33     fedora          1.1 M
 mate-control-center             x86_64 1.24.1-1.fc33     fedora          2.9 M
 mate-desktop                    x86_64 1.24.1-2.fc33     fedora           85 k
 mate-dictionary                 x86_64 1.24.0-2.fc33     fedora          6.9 M
 mate-disk-usage-analyzer        x86_64 1.24.0-2.fc33     fedora          6.9 M
 mate-icon-theme                 noarch 1.24.0-2.fc33     fedora           14 M
 mate-media                      x86_64 1.24.1-1.fc33     fedora          303 k
 mate-menus-preferences-category-menu
                                 x86_64 1.24.1-1.fc33     fedora          8.6 k
 mate-notification-daemon        x86_64 1.24.1-1.fc33     fedora          161 k
 mate-polkit                     x86_64 1.24.0-3.fc33     fedora           90 k
 mate-power-manager              x86_64 1.24.2-1.fc33     fedora          5.9 M
 mate-screensaver                x86_64 1.24.1-1.fc33     fedora          4.6 M

<cut>

 wxBase3                         x86_64 3.0.5.1-2.fc33    fedora          979 k
 wxGTK3                          x86_64 3.0.5.1-2.fc33    fedora          4.4 M
 wxGTK3-i18n                     noarch 3.0.5.1-2.fc33    fedora          528 k
Installing weak dependencies:
 brltty                          x86_64 6.1-11.fc33.1     updates-testing 1.4 M
 fortune-mod                     x86_64 2.28.0-1.fc33     fedora          1.0 M
Installing Groups:
 MATE                                                                          

Transaction Summary
================================================================================
Install  151 Packages
Upgrade   10 Packages

Total download size: 197 M
Is this ok [y/N]: y
Downloading Packages:
(1/161): blivet-gui-2.2.0-1.fc33.noarch.rpm     119 kB/s |  19 kB     00:00    
(2/161): brlapi-0.8.0-11.fc33.1.x86_64.rpm      783 kB/s | 170 kB     00:00    
(3/161): dconf-editor-3.37.91-1.fc33.x86_64.rpm 1.7 MB/s | 676 kB     00:00    
(4/161): brltty-6.1-11.fc33.1.x86_64.rpm        2.4 MB/s | 1.4 MB     00:00    
(5/161): f33-backgrounds-extras-base-33.0.3-1.f 107 kB/s |  14 kB     00:00    
(6/161): f33-backgrounds-extras-mate-33.0.3-1.f  35 kB/s | 7.4 kB     00:00    

<cut>
  
(161/161): usermode-1.112-9.fc33.x86_64.rpm     3.5 MB/s | 174 kB     00:00    
--------------------------------------------------------------------------------
Total                                           6.0 MB/s | 197 MB     00:32     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Running scriptlet: dpdk-2:19.11.3-1.fc33.x86_64                           1/1 
  Preparing        :                                                        1/1 
  Upgrading        : gvfs-client-1.45.92-1.fc33.x86_64                    1/171 
  Upgrading        : gvfs-1.45.92-1.fc33.x86_64                           2/171 
  Running scriptlet: gvfs-1.45.92-1.fc33.x86_64                           2/171 
  Installing       : mate-utils-common-1.24.0-2.fc33.noarch               3/171 

<cut>
               
  usermode-gtk-1.112-9.fc33.x86_64                                              
  wxBase3-3.0.5.1-2.fc33.x86_64                                                 
  wxGTK3-3.0.5.1-2.fc33.x86_64                                                  
  wxGTK3-i18n-3.0.5.1-2.fc33.noarch                                             

Complete!
[root@f33-test rave]# 

So please do not push this weird update to fedora 33 stable

Comment 8 Wolfgang Ulbrich 2020-09-16 11:48:23 UTC
The f33-backgrounds-mate-33.0.2-1.fc33.noarch was pulled in by Mate environment group of comps.
The f32-backgrounds-mate-32.2.2-2.fc33.noarch was pulled in by mate-desktop-1.24.1-1.fc33 package.
I updated mate-desktop package to fix this mismatch at Aug 25 2020 13:12:00 shortly before beta freeze, but report is from 2020-08-25 18:01:18.
https://src.fedoraproject.org/rpms/mate-desktop/c/f41df67b39a438faf9db00637fa8fe23235801b1?branch=master
So this problem was fixed when mate-desktop-1.24.1-2.fc33 reached stable branch before beta freeze ;)

Comment 9 Fedora Update System 2020-09-17 01:04:29 UTC
FEDORA-2020-9e58541c44 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-9e58541c44

Comment 10 Fedora Update System 2020-09-17 17:55:10 UTC
FEDORA-2020-9e58541c44 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-9e58541c44`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-9e58541c44

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Andre Robatino 2020-09-20 22:09:07 UTC
With the latest version, the conflict with f32-backgrounds-mate is back.

Error: Transaction test error: file /usr/share/backgrounds/mate/default.xml from install of f32-backgrounds-mate-32.2.2-2.fc33.noarch conflicts with file from package f33-backgrounds-mate-33.0.4-1.fc33.noarch

Comment 12 Andre Robatino 2020-09-21 21:11:09 UTC
Appears to be a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1880776 (or vice versa).

Comment 13 Fedora Update System 2020-09-23 04:50:18 UTC
FEDORA-2020-9e58541c44 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-9e58541c44

Comment 14 Luya Tshimbalanga 2020-09-28 07:13:42 UTC
Version 33.0.4-1 is unpushed due to request so 33.0.3 should remain available. 33.0.5 reverted the change made on 33.0.4 but the freeze is in effect preventing to add it.
https://koji.fedoraproject.org/koji/buildinfo?buildID=16145584

Once Fedora 33 Beta is launched the fix will be available.

Comment 15 Wolfgang Ulbrich 2020-09-28 08:36:16 UTC
(In reply to Luya Tshimbalanga from comment #14)
> Version 33.0.4-1 is unpushed due to request so 33.0.3 should remain
> available. 33.0.5 reverted the change made on 33.0.4 but the freeze is in
> effect preventing to add it.
> https://koji.fedoraproject.org/koji/buildinfo?buildID=16145584
> 
> Once Fedora 33 Beta is launched the fix will be available.

Thanks.
Version 33.0.3 isn't available because it is unpushed too.
Btw, since the beta announcement last friday the freeze is over and updates can be pushed to stable.

Comment 16 Fedora Update System 2020-09-28 15:21:14 UTC
FEDORA-2020-353dcd4cfc has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-353dcd4cfc

Comment 17 Fedora Update System 2020-09-29 00:15:24 UTC
FEDORA-2020-353dcd4cfc has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.